No puedo ni actualizar ni descargar paquetes. Dependencias rotas.

Imagen de audry05
0 puntos

Tengo ubuntu 12.04 y me ha salido una senal roja como de prohibido en la barra superior izquierda y al hacer click en ella me sale:

Ocurrio un error, ejecute el gestor de paquetes con el boton derecho del raton sobre el menu o apt-get en una terminal para ver que esta pasando.
El mensaje de error es: "Error: abriendo la cache(E: Read Error - read (5: Input/output error), E: The package list or status file could not be a parsed o r opened.)" Normalmente esto significa que ha instalado paquetes cuyas dependencias no se han podido satisfacer.

y al hacer algun sudo apt-get install o sudo apt-get upgrade o update me sale el siguiente error:

Reading package lists... Error!
E: Read error - read (5: Input/output error)
E: The package lists or status file could not be parsed or opened.

Estuve investigando y encontre que ejecutara los siguientes comandos
sudo rm /var/lib/apt/lists/* -vf
y luego
sudo LC_ALL=C apt-get update

y con eso se solucionaria, pero al hacerlos el primero se ejecuta bien pero el segundo me sale lo siguiente:
...
Fetched 18.8 MB in 2min 52s (109 kB/s)
Reading package lists... Error!
E: Read error - read (5: Input/output error)
E: The package lists or status file could not be parsed or opened.

osea no se termina de ejecutar.

Tambien trate meterme en configuracion del sistema >> origenes del software y no abre.
Porque tambien lei que ahi podia modificar algo que tal vez lo solucionaria pero no se me abre ignora completamente el click en el icono de origenes.

Necesito instalar unas cosas y este error no me deja. Espero me puedan ayudar! Gracias!