Filtros l7

Imagen de m_medina87
0 puntos

Nos hemos visto en la necesidad de usar estos filtros l7 por la utilidad que nos brinda para la clasificación de ciertos tipos de tráfico por las redes. El obstáculo que se nos presentó es el hecho de que la última versión de filtros l7 que viene es la versión 2.22 (es decir, la parte de los filtros para el kernel, porque además hay otra para la parte de usuario) que les dejo en este link http://sourceforge.net/projects/l7-filter/files/l7-filter%20kernel%20ver... y el parche menos obsoleto que viene engloba desde kernel 2.6.26 hasta 2.6.28.

Ya lo probé y directamente el parche NO funciona en las versiones nuevas de ubuntu donde el kernel es 3.x (esto es, desde la versión 11.10 de Ubuntu).

Mientras tanto, intenté descargar algún Ubuntu viejo cuyo kernel caiga entre esas versiones y busqué hasta encontrar que ubuntu 9.04 tiene un kernel nativo 2.6.28. Descargue entonces, pero tengo problemas con los paquetes (ni siquiera puedo correr un apt-get update o upgrade por la cantidad de errores que me tira). Podría dejarles una imagen de los errores de ser necesario.

Algún consejo? Alguien sabe si estas versiones viejas de Ubuntu siguen corriendo, o mejor aún, si hay algun versión nueva de los filtros l7 que sí corran en los ubuntus más modernos (el que mejor me anduvo hasta ahora es un ubuntu 11.10 que es una maravilla, hasta ahora, no se cuál sera la opinión general).
Gracias!!