Internet Lento en Ubuntu

+1
0
-1

Hola a todos!!!

Al instalar la primera vez ubuntu 10.04 el internet funcionaba de maravilla pero una vez que hice pruebas no sé que pasó y empezó a ponerse lenta la conexión a internet aunque formateara la pc incluso instalé madriva, fedora y con ninguno funcionaba tampoco.. pensaba que era el módem que no aceptaba Ubuntu o las distros de linux porque en windows seven si funcionaba normal y empezé a buscar soluciones, sólo que me rendí en ese momento. más allá del problema no quedaba conforme porque me gustó ubuntu 10.04 y 10.10 (tambien me gustó mucho la interfaz del centro de software ubuntu que para mí es el mejor que fedora, mandriva y google chrome os) me esmeré en buscar la solución en internet en páginas americanas hasta que dí con mi problema.

Bueno en fin y para no hacerles tanto rollo aquí les va la solución y las especificaciones de mi pc:

http://support.gateway.com/s/PC/R/3724/nv.jpg
Versión de Sistema Operativo: Ubuntu 10.04 y 10.10 Desktop cuando lo probé
Procesador: Intel Pentium IV (3.0Ghz)
Disco Duro: 80Gb
Memoria Ram: 2.5Gb
(Yo le instalé mas memoria ram jejeje)

Primero deben verificar que tipo de tarjeta tienen en mi caso es wlan0 la de ustedes puede ser diferente y lo checan con ifconfig:

$ sudo ifconfig

Siguiente tienen que crearse el archivo 99wifi-fix.sh y lo haremos desde la terminal, dentro de él copien este código:

$ sudo gedit /etc/NetworkManager/dispatcher.d/99wifi-fix.sh

#!/bin/bash

if [ $1 == "wlan0" ] && [ $2 == "up" ]; then
iwconfig wlan0 power off
iwconfig wlan0 rate 11M fixed
fi

Cierran el archivo y le damos permisos para su ejecución:

sudo chmod +x /etc/NetworkManager/dispatcher.d/99wifi-fix.sh

Verificamos que el internet no se alente por problemas de ipv6, como ahora no lo necesitamos, tecleamos en terminal:

sudo cat /proc/sys/net/ipv6/conf/all/disable_ipv6

Si les regresa un 0 quiere decir que la configuración http://es.wikipedia.org/wiki/Ipv6 está habilitada y tenemos que deshabilitarla.

Abrimos el archivo sysctl así:

sudo gedit /etc/sysctl.conf

Al final del archivo copiamos y pegamos esto:

#Disable IPv6
net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1

Reinicien y luego me platican…

Los problemas pueden variar pero así solucione el mío.

Saludos !!