Instalación Xubuntu - Error al copiar los archivos al Disco (Solucionado)

Imagen de octavopain
0 puntos

Buenas, tengo una máquina notebook AMD X4 N970, ATI R HD 4250GB de ram.
tengo en mi máquina windows 7 y ubuntu 12.10, quise instalar xubuntu 12.10 arriba de ubuntu pero llegado al final de la instalación en la fase de dar continuar a la parte de "tome una foto" y "A punto de terminar la copia de archivos" me sale un error que dice más o menos así: El instalador encontró un error al copiar los archivos del disco duro y me dice que puede ser que el cd no esté limpio o el disco de la máquina está dañado etc.
Busqué en internet y hay quienes dicen que es la RAM y otros el cd y otros el disco. Yo dudo que así sea porque instalé ubuntu 12.10 hace unos meses en perfecta manera.

Ahora mi miedo es el siguiente: estoy en el live USB todavía, es decir no me animo a reiniciar por miedo que el GRUB o algo de eso se haya perdido porque elegí eliminar ubuntu 12.10 y reinstalar, también lo inetenté por las particiones formateando la "/" y la "/ home".

La pregunta sería: como se que si reninicio voy a tener mi ubuntu 12.10 y w 7 tal y como estaban? lo otro no me interesa, la verdad que podría probar de nuevo con unebooting volver a grabarlo e intentar nuevamente pero todo esto con la seguridad de que ubuntu no se me haya perdido y no poder iniciarlo. Perdonen mi ignorancia.

Muchas gracias.

Imagen de Gabriel_M
+1
+1
-1

... es posible saberlo.
Reinstala el Grub para poder iniciar el ordenador, en una terminal ejecuta:

sudo su
fdisk -l (ele minúscula)
(te informará cual es tu partición /, linux 83, supongamos sea /dev/sda5)
mount /dev/sda5 /mnt
mount --bind /dev /mnt/dev
mount --bind /dev/pts  /mnt/dev/pts
mount --bind /proc /mnt/proc
mount --bind /sys  /mnt/sys
chroot /mnt
grub-install --boot-directory=/boot/ --recheck /dev/sda 

Es posible que Ubuntu no inicie, pero el ordenador si lo hará y tendrás a W7 para iniciar del disco rígido.
Para instalar Xubuntu solo hace falta, en Ubuntu ejecutar:

sudo su
apt-get install xubuntu-desktop
+1
+1
-1
Imagen de octavopain
+1
0
-1

Buenas, lei en internet, probe con gparted como instale ubuntu la primera vez, elimnado todas las particiones (asimismo me saltaron algunos errores) instale nuevamente y nada sigue el error. Con el grub sigo en los mismo luego de instalado sale como un grub con un entorno no grafico el cual no se que hacer.
La otra, hice el chequeo del disco, antes de instalar, y me dice que hay un solo error aunque no lo especifica debe tener algo que ver no.
Estaba pensando quizas en hacer un live usb desde el live usb por terminal, suena redundante pero se podra?
Perdon, son muchas dudas pero la verdad es que siento que no voy a poder con este problema.

En fin, si la solucion es arreglando el grub para que arranque el windows y de ahi hacer un live usb .... ... lo que no se es si el live usb si lo hago desde windows sirve?????

+1
0
-1
Imagen de octavopain
+1
0
-1

Muchas gracias por contestar, lo que me arroja el fdisk -l son varias particiones y dos con linux 83, como se cual es la "/".
xubuntu@xubuntu:~$ sudo su
root@xubuntu:/home/xubuntu# fdisk -l

Disk /dev/sda: 640.1 GB, 640135028736 bytes
255 heads, 63 sectors/track, 77825 cylinders, total 1250263728 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xb1448944

Device Boot Start End Blocks Id System
/dev/sda1 * 2048 31459327 15728640 27 Hidden NTFS WinRE
/dev/sda2 31459328 31664127 102400 7 HPFS/NTFS/exFAT
/dev/sda3 31664128 738260991 353298432 7 HPFS/NTFS/exFAT
/dev/sda4 738263038 1250263039 256000001 5 Extended
/dev/sda5 796856320 802713599 2928640 82 Linux swap / Solaris
/dev/sda6 802715648 1250263039 223773696 83 Linux
/dev/sda7 738263040 796856319 29296640 83 Linux

Partition table entries are not in disk order

Disk /dev/sdb: 4089 MB, 4089446400 bytes
255 heads, 63 sectors/track, 497 cylinders, total 7987200 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x475fa272

Device Boot Start End Blocks Id System
/dev/sdb1 * 2048 7984304 3991128+ b W95 FAT32
root@xubuntu:/home/xubuntu#

+1
0
-1
Imagen de octavopain
+1
0
-1

Pero cuando inicio me sale una patalla negra como para que le ponga comandos, dice algo en ingles al principio y despues GRUB>
No se si tengo que iniciar el sistema operativo con comandos?? ni idea si conservo ubuntu, como hago para que el grub tenga entorno grafico, estoy en el live usb de nuevo.
Mil gracias, pero me parece que estoy en un aprieto...

+1
0
-1
Imagen de octavopain
+1
0
-1

"GNU GRUB Version 2.00-7Ubuntu11
Minimal Bash-Like editing is supported. For the first word tab list.... etc etc"
busque el mismo en internet y en el foro, una era probar priemero con boot. Lo hice puse boot enter y me salio lo siguiente (siempre en la pantalla negra del GRUB): "Error: you need to load the kernel fist"
Tengo que instlalar el Kernel????
La otra era hacer un update del grub por terminal pero tengo miedo de hacerlo ya que estoy en el live usb.
Perdon por tantos mensajes solo voy poniendo mis intentos hasta ahora fallidos. Agradeceria muchisimo si alguien me pudiera ayudar.

+1
0
-1
Imagen de rioport
+1
0
-1

El instalador crea un registro y ahí debe decir más específicamente cuál fue ese error, pero no sé dónde lo guarde (No uso Ubuntu). También podrías revisar el disco duro, quizá tenga errores, una forma gráfica es con palimpset del paquete gnome-disk-utility o en la terminal con smartctl del paquete smartmontools.

+1
0
-1

-- GC --

Imagen de octavopain
+1
0
-1

Por lo que pude ver al instalar, ya que cuando da el error el sistema no me deja ver toda la bitácora abajo (y no sé donde se guardará tampoco), los errores son (por lo menos los que se muestra allí:
Xubuntu kernel: ...unos números... error: squashfs-read.dat failed to read block 0B28....
Xubuntu Kernel: .................................error: Unable read fragment cache entry
Xubuntu Kernel:..................................error: Unable to read page, block 28790665, size 7c82

Y luego se repiten el penultimo y el ultimo nuevamente, puede que haya mas errores pero no los puedo ver

Gracias por responder, todo esta apuntando al kernel entonces?? o podría ser un tema de permisos?

+1
0
-1
Imagen de rioport
+1
0
-1

Lo instalas desde USB ¿verdad?, podrías probar con otro USB y ver si sucede lo mismo o revisa la memoria RAM, al iniciar el USB si presionas ESC te da una opción que dice revisar la memoria RAM (?) o memtest, selecciona esa y prueba porque puede ser que alguno de los módulos de la RAM esté fallando.

+1
0
-1

-- GC --

Imagen de octavopain
+1
0
-1

Lo instalo desde un usb, me gustaria probar con otro usb pero como puedo hacerlo, no puedo instalar el unetbootin aqui porque el live usb no me lo permite o por lo menos me da error al instalarlo, luego pense en hacerlo por terminal pero como lo hago? tengo otro usb, pero lei q para hacerlo por terminal tengo que tener enchufado solo un usb puede ser?
Con respect al test memory al darle enter para hacer el check me dice> "load a ramdisk whith an old kernel image" y luego "boot:" le doy enter y vuelve a las opciones. Que puedo hacer?
Ademas de todo mi compu no arranca desde cd y eso lo probe de mil maneras la que me quedaba era actualizar la bios lo cual no me anime.. es otro dato para descartar esa posibilidad.

+1
0
-1
Imagen de rioport
+1
+1
-1

Para que memtest pueda cargar debes editar la forma en que arranca. En el menú de arranque lo seleccionas, presionas TAB y buscas la linea initrd=/ubninit la borras y presionas enter para iniciar. Y a esperar a que termine de revisar los módulos de la RAM.

Si la RAM no es el problema debes probar otro pendrive, quizá ese sea el problema y tú andas buscando solución por otro lado.

+1
+1
-1

-- GC --

Imagen de Gabriel_M
+1
+1
-1

... sesión live abre una terminal y ejecuta en ella:

sudo su
fsck -c -y -v /dev/sda6
fsck -c -y -v /dev/sda7 
mount /dev/sda6 /mnt
mount --bind /dev /mnt/dev
mount --bind /dev/pts  /mnt/dev/pts
mount --bind /proc /mnt/proc
mount --bind /sys  /mnt/sys
chroot /mnt
apt-get update
apt-get install grub-common grub-pc grub-pc-bin grub2-common
grub-install --boot-directory=/boot/ --recheck /dev/sda 
update-grub
+1
+1
-1
Imagen de octavopain
+1
0
-1

Gracias a los dos antes que nada!!!!
La verdad estoy sorprendido de la flexibilidad de Ubuntu, no se si windows es así pero los años de experiencia que he tenido en este último me dice que no. LLevo unos meses con ubuntu nada más y me rehuso a volver a w. El motivo; la flexibilidad, en mi compu no funciona arrancar desde cd con lo cual no puedo usarlo. Entonces intenté probar lo más lógico antes otro usb, pero no podía porque el live no me dejaba instalar unetbootin. Por lo tanto avergué y siguiendo un poco lo que me decían ustedes, tratar de usar otro usb. Encontré este tuto: http://deblinux.wordpress.com/2012/10/29/como-crear-un-usb-live-desde-la... de cómo hacerlo por terminal es decir crear un usb desde la terminal (ya que me era imposible hacerlo por unetbootin). Lo hice ya sabiendo que dev/sbc era mi segundo usb.
Al final de todo cree un usb nuevo a través de xubuntu live, con la distro ubuntu 12.10 (la que tenía antes) quedando el grub en perfectas condiciones. Así que ahora es solo instalar xubuntu escritorio como dice Gabriel-
Muchas gracias, perdón por lo largo de todo pero quizás a alguien más le sirve. Si falla la instalación puede probar esto.

+1
0
-1