Ayuda con Webcam (solucionado)

Imagen de DOA1
0 puntos

Nesecito hacer funcionar correctamente la WebCam con Skype y tengo el siguiente problema.
Sí lo ejecuto directamente como se instala no funciona.

Sí lo ejecuto desde el terminal con siguiente comando funciona perfecto
LD_PRELOAD=/usr/lib32/libv4l/v4l2convert.so skype

Sí cambio el comando del lanzador de "Skype" por el comando anterior me sale el siguiente error
Falló al ejecutar el proceso hijo «LD_PRELOAD=/usr/lib32/libv4l/v4l2convert.so» (No existe el fichero o el directorio)

En otra página encontre este comando parecido, (le agrega el "env" al principio)
env LD_PRELOAD=/usr/lib32/libv4l/v4l2convert.so skype
Con este comando abre la cámara pero se ven solo rayas.

Me pueden ayudar para hacerla andar como corresponde.
En Cheese funciona bien.

Imagen de Jose Luis 1320
+1
0
-1

Edita con permisos de root el archivo /etc/environment agrega la linea:

 
LD_PRELOAD=/usr/lib32/libv4l/v4l2convert.so 

Guarda y cierra el archivo, reinicia y ejecuta Skype

Un consejo, nunca abras aplicaciones gráficas con sudo, si deseas abrir gedit u otro editor de textos gráfico usa gksudo en su lugar.

En fin, si esto solo aplica para Skype, entonces puede afectar al funcionamiento de la cámara en otros programas como Cheese.

Y otra cosa, la cámara funciona bien, quien no funciona bien es Skype, de tal manera que le debes sobrecargar una variable para que funcione con la cámara.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de DOA1
+1
0
-1

Muchas gracias, me funcionó.

+1
0
-1