Error al instalar la impresora Dell P513w.

Imagen de jacinto_ruiz
0 puntos

Tengo problemas para instalar una impresora Dell P513w la cual compre porque supuestamente era compatible con Linux Ubuntu y así no iba a tener problemas de compatibilidad, que sorpresa me llevé!
Yo tengo instalado en mi computadora el Linux Ubuntu 12.10 a 64 bits. Al conectar la impresora a la computadora me detecta el modelo, sin embargo, Ubuntu no localiza algún controlador compatible. El disco de instalación que viene junto con la impresora solo contiene los controladores para Windows, haciendo la aclaracion a los usuarios de Mac y de Linux que sus controladores se encuentran en la pagina de Dell. Efectivamente encontré los controladores, sin embargo, aclaran que solo es compatible con Linux Ubuntu 8.04 LTS y 8.10, así como tambien con las distros OpenSuSE 11.0 y 11.1 y con Fedora 10. Entre al portal de Dell y descargué el archivo dell-inkjet-09-driver-1.0-1.i386.deb.sh. Al ejecutarlo me pide abrir una terminal para continuar con la instalación, sin embargo se detiene inesperadamente presentandome el siguiente error:

Lua error detected: While parsing install.lua: config/run.lua:1358: attempt to index global ´ownhership´ (a nil value)

inserto enlace del mensaje de error aquí: https://dl.dropboxusercontent.com/u/60751679/Captura%20de%20pantalla%20d...

Le doy aceptar a error y se cierra la terminal. Ya descargue los otros archivos para OpenSuSE y para Fedora y me manda el mismo error.

Buscando en Google encontre el caso de una persona que le habia pasado el mismo error al intentar instalar una impresora Lexmark en Linux Ubuntu. El comentaba que el error consiste en que Lexmark al realizar la compilación de sus controladores ocupó una versión anterior a Linux Ubuntu y que su solución habia sido abrir el archivo .deb.sh dandose privilegios de root, modificar un error de sintaxis que contiene el archivo (comentaba de que se repetian dos veces la letra "h" en un comando y eso generaba que se detuviera la instalación), guardar el archivo compilandolo de nuevo a la extension .deb.sh y regresando los privilegios de root a su estado original. Rapidamente les comento que intente hace esto pero no logre realizar ningun cambio al archivo. Quizas porque estamos hablando de impresoras diferentes y de errores diferentes.

Otra cosa, la impresora ya la instale en una computadora con Windows y funciona correctamente.