recuperar antigua /home tras instalar Ubuntu 12.10 "solucionado"

Imagen de JavierL
0 puntos

He instalado Ubuntu 12.10, anteriormente en esta PC tenía dual boot Mandriva 2011/windows. Actualmente tengo dual boot Ubuntu 12.10/windows.

El Mandriva 2011 lo tenía instalado con 3 particiones: /, swap y /home. Al instalar Ubuntu opté por formatear / pero no quería hacerlo con /home puesto que ahí tengo muchos archivos.

La instalación anduvo bien; el problema que se me presenta es que ahora Ubuntu está instalado en la partición raíz (hasta ahí) todo bien, pero ahí mismo tengo la "nueva" /home que por supuesto sólo tiene una estructura de archivos pero aún nada de datos. Mientras tanto, la antigua "/home" que tenía la puedo ver en Nautilus por ejemplo bajo "/media/hildajavier/fa6b8d00-1ea9-11de-9988-2943a6fc8b52" y de hecho los archivos los puedo abrir.

Lo que quiero conseguir es que esta antigua partición pudiera estar montada en /home. Intenté hacerlo editando /etc/fstab, agregando estas líneas:

# /home was on /dev/sda8 during installation
UUID=fa63651c-1ea9-11de-a230-3372d3e13b5b /home ext3 defaults 1 2

pero esto me da error al intentar reiniciar el sistema. Agradezco si me pueden ayudar con esto. Saludos
Javier

Imagen de Gabriel_M
+1
0
-1

Reinstala, con particionamiento guiado.
Monta / a formatear
Monta /home sin dar formato
Utiliza el mismo nombre de usuario y la misma contraseña que tenias en Mandriva.

Se podría mover /home a la partición, pero es complicado, te llevará más tiempo y el sistema puede quedar inutilizado.

+1
0
-1
Imagen de cuentos
+1
0
-1

en primer lugar seguro que el formato es ext3. mejor corre blkid en la terminal:
sudo blkid
y mira la uiid de la particion que quieres montar y el tipo de formato.
Y antes de montarla mira los archivos ocultos de esta particion (la anterior) que son las configuraciones, o mueve estos archivos ocultos a una carpeta por ejemplo "anterior) para que una configuracion de esta no interfiera con el nuevo sistema

Viendo lo que te puso Gabriel, si no estas tan seguro mejor reinstala.

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de JavierL
+1
0
-1

Agrego la información obtenida de blkid:

blkid /dev/sda8
/dev/sda8: UUID="fa6b8d00-1ea9-11de-9988-2943a6fc8b52" TYPE="ext3"

+1
0
-1
Imagen de cuentos
+1
0
-1

la que pusiste primero donde decias que agregaste al fstab:
UUID=fa63651c-1ea9-11de-a230-3372d3e13b5b /home ext3 defaults 1 2
UUID=fa6b8d00-1ea9-11de-9988-2943a6fc8b52 TYPE="ext3"
y la segunda donde no son las mismas por eso el error.

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de JavierL
+1
0
-1

Probé con la otra UUID pero no funcionó, de hecho para poder arrancar nuevamente el sistema tuve que volver a la anterior versión de fstab.
Intentaré con la otra sugerencia (instalar nuevamente).

+1
0
-1
Imagen de cuentos
+1
0
-1

Si pusieras como esta el fstab que te dio error para ver.
Pero bueno si reinstalas ten en cuenta de no formatear la /home

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de Alcruz
+1
0
-1

Para que pueda montar , ka carpeta de nontaje debe estar vacía
1.- Edita el fstab con el UUID correcto, que es el que sale al ejecutar
sudo blkid /dev/sad8
2.- Abre un terminal y pones
gedit aaa111
pones lo siguiente
rm -Rf /home
mkdir /home
init 6
3.- Guardas, cierras y cierras terminal
4.- Abre un terminal y pones
sudo su
bash aaa111
solo queda esperar a que reinicie y ya.

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

.... el /home, borrará el directorio de su usuario, el que instaló el sistema, al montar el /home de la instalación anterior, no tendrá usuario que pueda actuar con permisos temporarios de administrador, asi que previamente debería habilitar el usuario administrador o el sistema quedará imposibilitado de configurar.

+1
0
-1
Imagen de Alcruz
+1
0
-1

Asumo que durante la instalación se hizo con el mismo nombre de usuario, los permisos y la cuenta se alojarán en /etc y eso no se toca.
Si te da mas confianza, lo que puedes hacer es borrar todo el contenido de /home desde un Live CD, lo importante es que la carpeta /home tiene que estar vacía de elementos visibles y ocultos antes de poder usarse como punto de montaje
Solo para fines ilustrativos, en el siguiente enlace detallo los pasos para mover /usr , el proceso es muy similar para el caso de /home
http://www.ubuntu-es.org/node/177142#.UX5r_apfFV5

+1
0
-1
Imagen de cuentos
+1
0
-1

@Alcruz
Para no desviar el hilo te contesto rapido. ya que me quedo una duda en cuanto a montar una particion que tenga datos, que si puede, te pongo una prueba rapida:

root@deb-most:/media# ls
cdrom cdrom0 homes prueba
root@deb-most:/media# ls prueba
seamonkey-2.17.tar.bz2
root@deb-most:/media# mount -t ext4 /dev/sda9 /media/prueba
root@deb-most:/media# ls prueba
alex lost+found
root@deb-most:/media#
root@deb-most:/media# cd prueba
root@deb-most:/media/prueba# ls
alex lost+found
root@deb-most:/media/prueba# cd ..
root@deb-most:/media# umount /media/prueba
root@deb-most:/media# ls prueba
seamonkey-2.17.tar.bz2
root@deb-most:/media#

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de Alcruz
+1
0
-1

Lo que te puedo decir que la primera vez que intenté mover /home a otra partición , no pude por que había quedado en /home un archivo oculto, lo borré y ya.
Volviendo al tema, aquí dejo un enlace de una consulta similar en la que el interesado dio por solicionado el tema
http://www.ubuntu-es.org/node/176586

+1
0
-1
Imagen de JavierL
+1
0
-1

Ante todo, gracias a cuentos, Alcruz, Gabriel_M por sus mensajes y ayuda. Intenté con la edición del fstab y demás pero el sistema ya no arrancaba de modo normal. Tenía que entrar en modo de emergencia y ahí no podía generar el archivo aaa111 o ejecutar los comandos correspondientes porque el sistema de archivos estaba montado como sólo lectura. Lo mismo si arrancaba desde el LiveUSB, no podía hacer esas modificaciones; ahí el fstab que me mostraba era otro.
Finalmente, opté por copiar los datos que tenía en el antiguo /home y hacer una nueva instalación, de la versión 13.04 y usando como sistema de archivos ext4. Ahora sí tengo el sistema funcionando, acabo de entrar y de hecho esta entrada la estoy escribiendo en él. Lo que sí ahora me encuentro con que mi monitor (Acer x193w) se ve extraño ya que la resolución es de 1024 x 768 cuando debería ser de 1440 x 900 (no lo detecta Ubuntu) pero esto lo indicaré en otro hilo. (http://www.ubuntu-es.org/node/178603#.UX8sm0mDAtM)

+1
0
-1