Modo avión no se puede desactivar (ya he probado soluciones)

Imagen de Alexsansa
2 puntos

Pues eso, no puedo desactivarlo, y al intentar conectar el wifi me dice: "la red está desactivada por el interruptor físico". Ya he comprobado que este interruptor está activado, ya he probado el "rfkill unblock all", he probado bastantes comandos e instrucciones, pero no va. ¿Los drivers de Nvidia tienen algo que ver? Bueno, primero la pregunta principal: ¿qué hago?

Imagen de Jose Luis 1320
+1
0
-1

¿De que demonios estas hablando? ¿De una tostadora? ¿y has probado bastantes comandos? solo has descrito uno.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de Alexsansa
+1
0
-1

Me he puesto nervioso >.< A ver, tengo un portátil Toshiba Satellite, con 4 GB de ram, y una Nvidia GeForce 310M. La versión que tengo es la 13.04 (obvio) con 32 bits, y mi tarjeta de red, si he buscado bien, es:

0c:00.0 Ethernet Controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller [10ec:8168] (rev 03)

He probado:

sudo rfkill unblock all (no funciona)
sudo ifconfig wlan0 up (radiofrecuencia desactivada)
iwlist wlan0 scanning (no se puede porque "Network is down")
rfkill unblock 0 (lo mismo que con unblock all)

Y de momento no me acuerdo de más. Cuando pongo rfkill list all sale:

0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes

1: hci0: Bluetooth
Soft blocked: no
Hard blocked: no

También me he dado cuenta de que, cuando desactivo el modo avión y después el Bluetooth, se vuelve a activar el modo avión.

+1
0
-1
Imagen de Alexsansa
+1
0
-1

He avanzado, al menos no está exactamente desconectado... Lo que he hecho es desinstalar el driver de la página oficial de Nvidia e instalar el que ofrece Ubuntu. Ahora el problema es que pone: "El dispositivo no está listo". ¿alguna idea? De momento voy a reiniciar a ver si va...

+1
0
-1
Imagen de Alexsansa
+1
0
-1

De nuevo, vuelve a aparecer "la red está desactivada por el interruptor físico". No sé qué pasa... He probado nuevos comandos:

root@alexsansa-Satellite-A500:/home/alexsansa# ifup wlan0
Ignoring unknown interface wlan0=wlan0.
root@alexsansa-Satellite-A500:/home/alexsansa# iwlist scanning
wlan0     Interface doesn't support scanning : Network is down

lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.
root@alexsansa-Satellite-A500:/home/alexsansa# ifconfig wlan0 up
SIOCSIFFLAGS: Operación imposible por estar la radiofrecuencia desactivada

Y, por supuesto:

root@alexsansa-Satellite-A500:/home/alexsansa# rfkill unblock all

Pero cuando hago

rfkill list all

sale:

root@alexsansa-Satellite-A500:/home/alexsansa# rfkill list all
0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: yes
1: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no

Ya no sé que hacer... >.<

+1
0
-1
Imagen de Alexsansa
+1
0
-1

He encontrado un nuevo comando, pero no funciona:

$ sudo rmmod rtl8192se

Desaparece la opción de redes inalámbricas, pero si ahora hago:

$ sudo modprobe rtl8192se

Por un momento detecta redes, pero al instante vuelve a aparecer que ha sido bloqueado por el interruptor físico. He intentado buscar drivers para mi tarjeta (Realtek rtl8191sevb), pero no he encontrado nada. Además, el de la tarjeta rtl8192se es para kernel más antiguo. ¿Alguna sugerencia?

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

Eso quizás venga en el manual de tu dispositivo. El que sea.

Por más que hagas y deshagas en el software, si el interruptor FÍSICO esta en "apagado" o que se yo, no vas a hacer funcionar el wifi de otra manera.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de ubu777
+1
0
-1

En primer lugar, NINGUNA máquina Toshiba esta certificada para funcionar con Ubuntu -> http://www.ubuntu.com/certification/desktop/
¿Que significa esto?
Esto significa que Toshiba no quiere saber nada de Ubuntu (Y posiblemente de GNU/Linux), por lo tanto, no coopera en el desarrollo de drivers, software, etc. para hacer sus máquinas compatibles.
Y, ¿Esto que tiene que ver con el problema del Wireless?
Mucho. Como ya lo he comentado antes, los fabricantes de portátiles de "Marca", aunque utilizan componentes 100% compatibles con Ubuntu (Por ejemplo: Una MoBo Intel, un HDD Seagate, etc.), desafortunadamente le "imprimen" el sello de su marca a sus "aparatejos", modificando el estándar APM (Gestión de Energía y Hardware), solo tomando en cuenta a windows.
Es una acusación grave, ¿La evidencia?
La activación del Wireless y su driver especifico en portátiles Toshiba, se gestiona con lo que ellos llaman "TVAP" o "Toshiba Value Added Pack" y específicamente con este ejecutable -> C:\Program Files\Toshiba\TBS\TBSWireless.exe
Ya hemos hablado de la poca o nula cooperación, por lo tanto es OBVIO que no existe el TVAP para GNU/Linux.
Pero, me he encariñado con el Ñu ¿Que puedo hacer?
La única solución al momento (Mañana puede ocurrir algo), es tener windows en arranque dual y usarlo solo para encender/apagar el Wireless, y luego reiniciar en Ubuntu.
Es poco practico, pero es la única solución...por el momento.
PD: Ni lo intentes con Wine, ya que no hay interacción con el Hardware.

+1
0
-1

--------------------------------------------------------------------
*I'm sorry, I've played very sensitive fibers. This forum is not ready for my help. You can contact me in the master forums.
Ubuntu Forums Org.

Imagen de Alexsansa
+1
0
-1

¿Pero no hay ninguna forma de instalar Windows sin tener que eliminar Ubuntu? Y de todas formas, gracias por la ayuda.

+1
0
-1
Imagen de gabi3848
+1
0
-1

Yo hago un sudo NetworkManager y despues el password y me funciona

+1
0
-1