ubuntu lento hasta que se cuelga

Imagen de salvaestudio
0 puntos

Hola a todos.
He instalado Ubuntu en un iMac del 2006 porque con OsX iba bastante lento. Quería resucitarlo porque leí que con linux van más ligeros.
Al principio contento porque veía que iba más ligero. Desde ayer me estoy dando cuenta que no es así. Al principio va bien pero conforme pasa el tiempo y lo uso y abro aplicaciones (sencillas) y uso internet, cada vez va siendo más lento. En el monitor del sistema lo que veo es que la CPU va bien pero la RAM se va llenando poco a poco y no se vacia. El último caso fue que se me llenó al 91% y llegados a ese punto ya no podía hacer nada. He probado metodos de liberar RAM por el terminal pero no veo que vacíe RAM.
Por ejemplo, noto que al abrir el centro de software de ubuntu le pesa bastante y abrir el buscador también. La cosa es que conforme abro aplicaciones, aunque luego las cierre, va acumulando RAM. Ahora, por ejemplo llevo el 53% y se que cuando suba a 90 no podré hacer nada.
Es una pena porque esto de linux me estaba gustando bastante pero este problema parece gordo. ¿Alguien me puede ayudar a solucionarlo?
Saludos!!

Imagen de Goyo
+1
0
-1

Usa el monitor del sistema para ver si es algún proceso concreto el que se lleva la memoria.

+1
0
-1
Imagen de salvaestudio
+1
0
-1

Nada, lo pruebo incluso cerrando todo. Ahora el único proceso activo es el gnome-system-monitor. Ya tengo un 70% de ram. Ahora no sube pero tampoco baja. Si vuelvo a abrir cosas y usar internet y centro de software etc, seguirá subiendo.

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

Pero en hardware normal.

Tu ignorante afirmación equivaldría a juzgar a un pez por su habilidad de escalar arboles.

Abre como te dijeron el gnome-system-monitor y fijate que procesos usan más RAM.

Puedes de igual manera usar top desde Terminal.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de salvaestudio
+1
0
-1

En momentos que voy con la ram a 70% y he cerrado todo, en el monitor de sistema no hay procesos activos. he mirado todos los procesos y como soy nuevo en esto hay procesos que no se qué son, pero en general no veo ninguno que consuma excesivamente.
Lo que veo es que esto gasta RAM y no la libera, por eso cuando pasa un tiempo, despues de usar varias aplicaciones, es como que se llena y se bloquea. Es un iMac viejuno con 2Gb de ram.
Por cierto, ¿cual es mi ignorante afirmación?

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

¿No puedes ver la cantidad de RAM que usan los procesos? Es la información que necesitamos para darnos una idea de tu problema.

Y tu afirmación es esta:

Al principio contento porque veía que iba más ligero. Desde ayer me estoy dando cuenta que no es así.

Lo digo por que eso que dices no es correcto, estas usando un hardware Mac del 2006, cerrado y sin especificaciones de como funciona.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de salvaestudio
+1
0
-1

Pues yo veo muchos procesos pero ninguno me llama la atención especialmente por su gasto de memoria. Hay uno, el compiz, que usa 110 MiB, no se si eso es normal. De todas formas puede haber un proceso que en un momento dado gaste mucha RAM pero cuando cierro todo y el unico proceso activo es el del mismo monitor, no entiendo por qué no libera ram y se queda a tope ¿?¿ ¿es normal que con todo cerrado esté a 70%?

+1
0
-1
Imagen de salvaestudio
+1
0
-1

Ahora me marca en RAM 84% y solo tengo abiento el monitor del sistema, Banshee, Firefox y Thunderbird ¿?¿ Me da que va a subir a 90 como la otra vez y se va a colgar...

+1
0
-1
Imagen de Goyo
+1
0
-1

La verdad, no sé. A mí a veces me ha dado la sensación de que me ocurría algo semejante con otro equipo viejuno pero apenas lo uso y no me he puesto a mirarlo con detalle. A veces la memoria aparece ocupada con cosas cacheadas que en realidad es memoria disponible porque cuando se necesita se libera. Tiene que haber formas de distinguir eso de una fuga de memoria y de examinarla en profundidad para ver en qué se usa, si se puede soltar o no y por qué, pero yo no las sé.

Aquí hay algunas sugerencias para comprobar el uso de la memoria (yo no entiendo nada de estas cosas):
http://www.codigomaestro.com/linux/comprobar-el-uso-de-memoria-en-linux/

Seguramente es una idiotez pero ¿es posible que una memoria defectuosa pueda producir problemas como éste? Hay una utilidad para comprobar el estado de la memoria, a la que se puede acceder de alguna forma desde el menú de GRUB.

+1
0
-1
Imagen de salvaestudio
+1
0
-1

Pues no se... lo que es seguro es que la misma memoria me iba mas o menos bien en OsX. Si me pasaba a Linux es por ganar agilidad en un equipo viejo pero si con los mismos recursos parece que va mas lento o igual... pues no soluciono nada. Si hay memoria defectuosa, también afectaría al otro sistema operativo mac OsX ¿no?
Agradezco las respuestas pero no encuentro solucón... ¿qué es lo del menú GRUB? La verdad es que o controlas demasiado o no me entero de nada...

+1
0
-1
Imagen de rioport
+1
0
-1

La salida de los siguientes comandos:

free -m
ps -e -orss=,args= | sort -b -k1,1n

El segundo al ser un poco largo pégalo acá http://paste.ubuntu.com/

+1
0
-1

-- GC --

Imagen de salvaestudio
+1
0
-1

Gracias por la info pero ¿qué quiere decir eso? Cuenta que soy nuevo en esto y estas respondiendo en el foro de los nuevos, je... a mi me pones eso y me quedo igual...

+1
0
-1
Imagen de Goyo
+1
0
-1

Abres un terminal.
Copias el primer comando, lo pegas en el terminal y pulsas Enter
Copias la salida y la pegas aquí.
Copias el segundo comando, lo pegas en el terminal y pulsas Enter
Copias la salida, la pegas en el pastebin y pones aquí la dirección que salga.

En OSX también hay terminal ¿no?

+1
0
-1
Imagen de salvaestudio
+1
0
-1

Gracias por la aclaración.
Si, en mac hay terminal, lo que no entendía es lo de "salida" que se quería decir que elr esultado de esos comandos los inserte aquí.
A ver, pongo resultados. Hay que contar que acabo de arrancarlo y solo tengo thunderbird y firefox.

total usado libre compart. búffers almac.
Mem: 2001 1755 246 0 72 734
-/+ buffers/cache: 948 1053
Intercambio: 1023 0 1023

Lo otro:
http://paste.ubuntu.com/5670124/

+1
0
-1
Imagen de salvaestudio
+1
0
-1

Por si sirve de algo. Con Inkscape no puede. Lo abre y puedo trabajar un rato con él pero al rato se oscurece y bloquea. Luego se vuelve a iluminar y puedo seguir pero al rato más tiempo bloqueado y así hasta que decido salir. Solo tenía abierto además el Thunderbird y Firefox.

+1
0
-1
Imagen de linuxstore.es
+1
0
-1

Usa un live cd, aunque sea de otra version anterior u otra distro a ver que te hace...

+1
0
-1

www.linuxstore.es
Ordenadores económicos con linux o sin S.O.

Imagen de salvaestudio
+1
0
-1

Gracias por el consejo. Si uso un cd live ¿como compruebo que va mejor? ¿De verdad sirve eso para algo? Si va mejor ¿qué tendría que hacer? Por cierto, igual interesa que pruebe Xubuntu que dicen que es más ligero ¿no?

+1
0
-1
Imagen de rioport
+1
0
-1

Si bien 948 MiB parece mucho, no lo es tanto si estás usando aplicaciones que consumen mucha memoria y además usas Ubuntu que no es una distro ligera que digamos, de los datos que pones no se ve nada raro, ¿por qué no pruebas Xubuntu?.

+1
0
-1

-- GC --

Imagen de salvaestudio
+1
0
-1

Ok, probaré xubuntu y os cuento.
¡Saludos!

+1
0
-1