Paquetes con dependencias incumplidas

Imagen de Natita de leche
0 puntos

Hace una semana actualice Ubuntu 11.10 por el 12.04 esto porque me aparecía un mensaje que debía de hacerlo porque ya no tenía soporte. El problema es que intento instalar google chrome pero el centro de software de ubuntu no me permite.

los siguientes paquetes tienen dependencias incumplidas
libxml-libxml-perl:
depende perlapi- 5.12.3 pero no va a instalarse
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.

Y el gestor de paquetes synaptic me dice E: libxml-libxml-perl: el subproceso instalado el script pre-removal devolvió el código de salida de error 127

¿qué puedo hacer?

Imagen de Jose Luis 1320
+1
0
-1

sudo apt-get remove --purge libxml-perl.

E intenta de nuevo.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de Natita de leche
+1
-2
-1

Hola Jose Luis 1320 :D gracias por tu respuesta. Ya hice lo que me comentas y pasa lo siguiente:

No se pudo bloquear var/lib/dpkg/lock/ - open (11: recurso no disponible temporalmente)
E: No se pudo bloquear el directorio de administración (var/lib/dpkg/), quizás haya otro proceso utilizándolo?

Te agradezco si me ayudas llevo varios días tratando de solucionar el problema, buscando soluciones en la web pero sin éxito, por eso decidí registrarme. Soy muy nueva en esto. De hecho nunca le había movido a la terminal. Ayuda por favor!!!!

+1
-2
-1
Imagen de cuentos
+1
0
-1

No tenias otro proceso abierto, como synaptic.

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de Natita de leche
+1
-2
-1

Es verdad Synaptic abierto, volví a intentar sudo apt-get remove --purge libxml-perl. pero esa no es la
solución pues pasa esto:

Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... hecho
E: No se ha podido localizar el paquete libxml-perl
E: No se pudo encontrar ningun paquete con la expresion regular <>

¿y ahora?

+1
-2
-1
Imagen de Jose Luis 1320
+1
0
-1

Entonces purgas el paquete problemático como ya te dije.

Lee los mensajes de error.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de cuentos
+1
0
-1

Entonces lo mas probable es que agregaste un archivo ppa, que a varios usuarios les rompe el sistema de dependencias.
si ejecutas este comando en la terminal que error te da, (solamente la parte final de error)
sudo apt-get upgrade
y esto otro comado, para ver los ppa
ls /etc/apt/sources.list.d

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de Natita de leche
+1
-2
-1

[sudo] password for natalia:
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Tal vez quiera ejecutar «apt-get -f install» para corregirlo.
Los siguientes paquetes tienen dependencias incumplidas:
libxml-libxml-perl : Depende: perlapi-5.12.3 pero no es instalable
Depende: libxml-sax-perl pero no está instalado
E: Dependencias incumplidas. Pruebe de nuevo usando -f.
________________

bash: ls/etc/apt/sources.list.d: No existe el archivo o el directorio

¿? :S

+1
-2
-1
Imagen de Jose Luis 1320
+1
0
-1

http://es.wikipedia.org/wiki/Ubuntu
http://es.wikipedia.org/wiki/Linux
http://www.ubuntu-es.org/Preguntas_Frecuentes
http://es.wikipedia.org/wiki/Bash

man ls
man apt-get

Creo que esto te podría ayudar mucho mejor que nosotros. El dia de ayer otro usuario subio un pregunta por el mismo error que el tuyo. No es nuestro problema, es el de cada uno que debe entender como usar la Terminal, puesto que es necesario.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de cuentos
+1
+1
-1

como dice jose luis, si miras bien:
el comando es:
ls(espacio)/etc/apt/sources.list.d

+1
+1
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de Natita de leche
+1
-2
-1

De acuerdo.. al poner el comando correcto me aparece lo siguiente, ¿cómo soluciono el problema el usuario de ayer? disculpen en realidad soy principiante pero tienen razón debo de conocer al menos lo básico, disculpen agradezco su apoyo.
~$ ls /etc/apt/sources.list.d
canonical-partner-maverick.list
canonical-partner-maverick.list.distUpgrade
canonical-partner-maverick.list.save
ferramroberto-gsharkdown-oneiric.list
ferramroberto-gsharkdown-oneiric.list.distUpgrade
ferramroberto-gsharkdown-oneiric.list.save
google-chrome.list
google-chrome.list.distUpgrade
google-chrome.list.save
kazam-team-unstable-series-oneiric.list
kazam-team-unstable-series-oneiric.list.distUpgrade
kazam-team-unstable-series-oneiric.list.save

+1
-2
-1
Imagen de Jose Luis 1320
+1
0
-1

..que el usuario estuvo pregunte y pregunte por lo mismo, no sabia como separar comandos y parametros.

preguntaba algo como esto:

tengo un problema pongo cd/Descargas/Programas y me sale esto:
bash: cd/Descargas/Programas No existe el archivo o directorio

Le habíamos dicho a detalle de como debería de usar los comandos en Terminal y el seguía preguntando lo mismo, por que no puso atención.

Su problema era muy diferente al tuyo.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de cuentos
+1
0
-1

realmente no se si estos ppa que agregaste sean tan útiles, por ejemplo:
google-chrome.list tenemos en los repositorios chromium que es lo mismo.
luego este otro kazam-team-unstable-series-oneiric.list, que por su propio nombre dice inestable.
y luego este de canonical-partner-maverick.list
que según ya cambiaste de versión.
cuando cambias de versión tienes que comentar los ppa, o desisntalarlos, actualizas de versión y luego si crees necesario volver a ponerlos para la nueva versión si están disponibles.
Verifica en orígenes del software y desmárcalo
o borra los ppa, mira esta guía.
http://usemoslinux.blogspot.com/2010/07/ppa-purge-como-remover-un-reposi...
cuando ya borres los ppa primero verifica que ya este corregido las dependencias
y luego si aun quieres vuélveles a poner los ppa.

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de ubu777
+1
0
-1

O una de dos:
Mezclaste repositorios para distintas versiones de Ubuntu o
Actualizaste sin seguir una buena guia -> http://www.ubuntu-es.org/node/179430

Tu sistema esta irremediablemente lleno de conflictos de librerias mezcladas, lo mas sano es la reinstalación.

+1
0
-1

--------------------------------------------------------------------
*I'm sorry, I've played very sensitive fibers. This forum is not ready for my help. You can contact me in the master forums.
Ubuntu Forums Org.

Imagen de Gabriel_M
+1
0
-1

La orden es:

sudo su
apt-get remove --purge libxml-libxml-perl

Luego, cambia todos los nombres de la distribución en el archivo sources.list

sudo su
nano /etc/apt/sources.list

Control + O guarda, Control+X cierra
O son todos maverick u oneiric o precise o quantal o raring, pero no mezclados.

+1
0
-1