SOLUCIONADO.Leer particiones ntfs

Imagen de patxicurro
0 puntos

Después de la instalación limpia de 13.04, el ordenador, de vez en cuando, no puede montar las particiones ntfs ni un disco duro externo con dicho formato.
Después de reiniciar varias veces, igual lo monta. ¿os pasa a alguno?, ¿cual es la solución?, gracias.

SOLUCION

Para evitar la pérdida de datos, asegúrese de que el rápido reinicio de Windows 8 está desactivado. Esto se puede lograr mediante la emisión como un administrador el comando:
powercfg / h off

Puede verificar los ajustes actuales en:
Panel de control> Hardware y sonido> Opciones de energía> Sistema> Configuración de los botones de encendido lo que elija Ejecutar
El "Activar inicio rápido" caja bien se debe desactivar o falta.

Imagen de Scorpyo82
+1
0
-1

Pueden pasar dos cosas.
1- Una, que el disco no esté siendo montado por su identificador UUID, y que se esté usando su dirección en el arbol de dispositivos..... "/dev/sdax", esto puede dar lugar a problemas ya que podría serle asignado otro nombre por hallarse otros dispositivos conectados al pc.
2- Que el disco contenga errores y no se pueda montar a veces...

Yo opino que seguramente es la primera.

Cuando dices que no lo monta, ¿te refieres al automontaje al inicio??

Abre una terminal y coloca estos comandos para obtener datos sobre tus particiones, sus números UUID y tu configuración de /etc/fstab

sudo fdisk -l
sudo blkid
cat /etc/fstab

Pega los resultados aquí y comenta mas o menos cual es la partición que intentas montar.

Un saludo.

+1
0
-1

Si entro en Window$ estoy más tenso que en el bautizo de un gremlin.
Linux user: 545.017
Por favor, si solucionas el hilo añade [Solucionado] al título.

Imagen de patxicurro
+1
0
-1

Gracias por la respuesta, te pego lo que me manda la terminal.
avier@curroparato:~$ sudo fdisk -l
[sudo] password for javier:

Disco /dev/sda: 1500.3 GB, 1500301910016 bytes
255 cabezas, 63 sectores/pista, 182401 cilindros, 2930277168 sectores en total
Unidades = sectores de 1 * 512 = 512 bytes
Tamaño de sector (lógico / físico): 512 bytes / 4096 bytes
Tamaño E/S (mínimo/óptimo): 4096 bytes / 4096 bytes
Identificador del disco: 0x5d4012c0

Dispositivo Inicio Comienzo Fin Bloques Id Sistema
/dev/sda1 * 2 586132817 293066408 7 HPFS/NTFS/exFAT
La partición 1 no se inició en el limite físico del sector
/dev/sda2 586132819 1172527778 293197480 7 HPFS/NTFS/exFAT
La partición 2 no se inició en el limite físico del sector
/dev/sda3 1172529150 2930276351 878873601 5 Extendida
La partición 3 no se inició en el limite físico del sector
/dev/sda5 2888620032 2930276351 20828160 82 Linux swap / Solaris
/dev/sda6 1172529152 2888620031 858045440 83 Linux

Las entradas de la tabla de particiones no están en el orden del disco

Disco /dev/sdb: 500.1 GB, 500107862016 bytes
255 cabezas, 63 sectores/pista, 60801 cilindros, 976773168 sectores en total
Unidades = sectores de 1 * 512 = 512 bytes
Tamaño de sector (lógico / físico): 512 bytes / 512 bytes
Tamaño E/S (mínimo/óptimo): 512 bytes / 512 bytes
Identificador del disco: 0x0005b189

Dispositivo Inicio Comienzo Fin Bloques Id Sistema
/dev/sdb1 * 2048 969441277 484719615 7 HPFS/NTFS/exFAT

javier@curroparato:~$ sudo blkid
/dev/sda1: UUID="7870EE8C70EE5104" TYPE="ntfs"
/dev/sda2: UUID="02BEB8B87B2F874E" TYPE="ntfs"
/dev/sda5: UUID="52439880-921a-4a11-9775-9d9bc84920d8" TYPE="swap"
/dev/sda6: UUID="fafc575f-d5a2-4352-a988-2339df36968a" TYPE="ext4"
/dev/sdb1: UUID="416235816068031D" TYPE="ntfs"

javier@curroparato:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
#
# / was on /dev/sda6 during installation
UUID=fafc575f-d5a2-4352-a988-2339df36968a / ext4 errors=remount-ro 0 1
# swap was on /dev/sda5 during installation
UUID=52439880-921a-4a11-9775-9d9bc84920d8 none swap sw

A ver como lo ves.

+1
0
-1

patxicurro

Imagen de Jose Luis 1320
+1
0
-1

1) Tu disco externo NTFS no esta en el fstab, ese disco debe de estar en el fstab para que pueda ser montado, de otra manera, nunca lo vas poder montar al inicio, es decir que se monte automáticamente cada que prendas el ordenador, pero debes conectarlo antes de prender la computadora.

De otra manera, prendes el computador y le dices a la configuración del sistema que monte automáticamente medios externos, cuando los conectes.

2) por otro lado las particiones de windows en tu disco interno tienen errores, asi como la partición extendida en donde alojas las particiones de Ubuntu.

Dispositivo Inicio Comienzo Fin Bloques Id Sistema
/dev/sda1 * 2 586132817 293066408 7 HPFS/NTFS/exFAT
La partición 1 no se inició en el limite físico del sector
/dev/sda2 586132819 1172527778 293197480 7 HPFS/NTFS/exFAT
La partición 2 no se inició en el limite físico del sector
/dev/sda3 1172529150 2930276351 878873601 5 Extendida
La partición 3 no se inició en el limite físico del sector
/dev/sda5 2888620032 2930276351 20828160 82 Linux swap / Solaris
/dev/sda6 1172529152 2888620031 858045440 83 Linux
+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de cuentos
+1
0
-1

Una duda que me queda,
Con el administrador de archivos, puedes ver y montar las particiones. O es aquí donde te aparecen o no las particiones/discos para montar.
O no puedes escribir en estas.

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de patxicurro
+1
0
-1

Pues eso, que si veo las particiones con nautilus, pero cuando pico en cualquiera de ellas me sale esto:Error mounting /dev/sda2 at /media/javier/02BEB8B87B2F874E: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177" "/dev/sda2" "/media/javier/02BEB8B87B2F874E"' exited with non-zero exit status 14: The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sda2': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.

Hasta hace poco sí las montaba, pero cuando se actualizó el kernel, no me acuerdo el que era, me da este problema.
Como verás tengo en el disco duro de 1,5 teras, 3 particiones, la más grande de Ubuntu, otra con W8, y otra para intercambio entre los dos sistemas operativos. También tengo un disco duro de 500 gb, pinchado con sata.

+1
0
-1

patxicurro

Imagen de cuentos
+1
+1
-1

Windows 8 trae un "nuevo" método para arrancar mas rápido el sistema, no te desmonta las particiones. Por esto ubuntu no te las puede montar, por que detecta que están semi-montadas
tienes que ir a configuración de win8 y desmarcas la opción.
esto que pongo a continuación fue de otro problema parecido, mira y prueba:

Para evitar la pérdida de datos, asegúrese de que el rápido reinicio de Windows 8 está desactivado. Esto se puede lograr mediante la emisión como un administrador el comando:

powercfg / h off

Puede verificar los ajustes actuales en:
Panel de control> Hardware y sonido> Opciones de energía> Sistema> Configuración de los botones de encendido lo que elija Ejecutar
El "Activar inicio rápido" caja bien se debe desactivar o falta.

mira lo que me sale con google traductor lo que te pone:

El disco contiene un sistema de archivos sucia (0, 0).
Metadatos guarda en caché de Windows, se negó a montar.
Error al montaje '/ dev/sda2': Operación no permitida
La partición NTFS está en un estado inseguro. Por favor, curriculum vitae y apagado
Totalmente Windows (sin hibernación o rápido reinicio) o montar el volumen

+1
+1
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de cuentos
+1
0
-1

si desde un principio hubieras comentado

omo verás tengo en el disco duro de 1,5 teras, 3 particiones, la más grande de Ubuntu, otra con W8, y otra para intercambio entre los dos sistemas operativos. También tengo un disco duro de 500 gb, pinchado con sata.
+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de patxicurro
+1
0
-1

Luego te comento, que la parienta me está llamando para cenar. Gracias por la respuesta, ya te contaré.

+1
0
-1

patxicurro

Imagen de patxicurro
+1
0
-1

Muchas gracias cuentos.
Efectivamente, el mal provenía del lado oscuro. He hecho lo que comentas en tu post y efectivamente, al reiniciar se han montado las particiones automáticamente.
Lo malo de todo es que no puede quitar la partición del w8, porque necesito un programa de edición musical que no tiene análogo en Linux.
No obstante muchas gracias por la ayuda.

+1
0
-1

patxicurro

Imagen de cuentos
+1
0
-1

Solamente recuerda no activar este "gran adelanto" que trae win (al creerse el único sistema operativo).
Y ten pendiente de una posible actualización te quiera volver activar esto.

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de Ayala86
+1
0
-1

Tenía el mismo problema pero se ha solucionado con la opción comentada por "cuentos".
Nada mas que en mi caso (aunque creo que así debe de ser para todos), al ejecutar el comando powercfg/h off, la opción "Desaparece", no destildo la casilla, sino que dejó de aparecer la opción de "activar incio rápido".

Esto puede ser a que no había entendido correctamente la instrucción, y en vez de ejecutar el comando mencionado, destilde la opción manualmente? (entendía que eran Dos Opciones, y no como bien lo dice: Entrar a la configuración para Verrificar como estaba Antes de ejecutar el comando) todo por tratar de leer rápido.

Gracias, saludos cordiales.

+1
0
-1

El ordenador es la evolución lógica del hombre: inteligencia sin moral.
J. Osborne.