Problemas con el gestror de actualizaciones

Imagen de alexei8a
0 puntos

Hola, estaba instalando algunos paquetes en mi Ubuntu 12.04, estaba instalando concretamente el qgis, cuando me sali{o lo siguiente:

Ocurrió un error, ejecute el gestor de paquetes con el boton derecho del ratón sobre el menú o apt-get en una terminal para ver que está pasando. El mensaje de error es: << Error:BrokenCount 0 Normalmente, esto significa que ha instalado paquetes cuyas dependencias no se han podido satisfacer.

He intentado en la terminal con el comando sudo apt-get -f install
Y el resultado es este:

Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Corrigiendo dependencias... Listo
Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios.
kde-l10n-es language-pack-kde-es-base amarok-help-en amarok-help-es
language-pack-kde-en language-pack-kde-es kde-l10n-engb
language-pack-kde-en-base
Utilice «apt-get autoremove» para eliminarlos.
Se instalarán los siguientes paquetes extras:
grass-core
Paquetes sugeridos:
grass-doc grass-gui grass-dev e00compr avce00 gpstrans python-rpy2 xml2
Se instalarán los siguientes paquetes NUEVOS:
grass-core
0 actualizados, 1 se instalarán, 0 para eliminar y 5 no actualizados.
1 no instalados del todo o eliminados.
Se necesita descargar 0 B/11,3 MB de archivos.
Se utilizarán 31,6 MB de espacio de disco adicional después de esta operación.
¿Desea continuar [S/n]? s
(Leyendo la base de datos ... 304915 ficheros o directorios instalados actualmente.)
Desempaquetando grass-core (de .../grass-core_6.4.2~upstream2-3~precise4_amd64.deb) ...
dpkg: error al procesar /var/cache/apt/archives/grass-core_6.4.2~upstream2-3~precise4_amd64.deb (--unpack):
intentando sobreescribir `/usr/bin/grass64', que está también en el paquete grass 6.4.1-1ubuntu2
dpkg-deb: error: el subproceso copiado se mató con la señal (Tubería rota)
Se encontraron errores al procesar:
/var/cache/apt/archives/grass-core_6.4.2~upstream2-3~precise4_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
alexei@alexei-MS-7380:~$ clear

alexei@alexei-MS-7380:~$ sudo apt-get -f install
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Corrigiendo dependencias... Listo
Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios.
kde-l10n-es language-pack-kde-es-base amarok-help-en amarok-help-es
language-pack-kde-en language-pack-kde-es kde-l10n-engb
language-pack-kde-en-base
Utilice «apt-get autoremove» para eliminarlos.
Se instalarán los siguientes paquetes extras:
grass-core
Paquetes sugeridos:
grass-doc grass-gui grass-dev e00compr avce00 gpstrans python-rpy2 xml2
Se instalarán los siguientes paquetes NUEVOS:
grass-core
0 actualizados, 1 se instalarán, 0 para eliminar y 5 no actualizados.
1 no instalados del todo o eliminados.
Se necesita descargar 0 B/11,3 MB de archivos.
Se utilizarán 31,6 MB de espacio de disco adicional después de esta operación.
¿Desea continuar [S/n]? S
(Leyendo la base de datos ... 304915 ficheros o directorios instalados actualmente.)
Desempaquetando grass-core (de .../grass-core_6.4.2~upstream2-3~precise4_amd64.deb) ...
dpkg: error al procesar /var/cache/apt/archives/grass-core_6.4.2~upstream2-3~precise4_amd64.deb (--unpack):
intentando sobreescribir `/usr/bin/grass64', que está también en el paquete grass 6.4.1-1ubuntu2
dpkg-deb: error: el subproceso copiado se mató con la señal (Tubería rota)
Se encontraron errores al procesar:
/var/cache/apt/archives/grass-core_6.4.2~upstream2-3~precise4_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Retorna un error, y no me deja ni instalar ni desisntalar nada, como puedo reparar esto?
Muchas gracias

Imagen de Jose Luis 1320
+1
0
-1

Puede ser que:

1) Tengas grass-core instalado desde los repositorios oficiales.
2) El repositorio de QGis, trata de instalar su propia versión de grass-core, la cual crea conflicto con la versión de grass-core que tienes instalado.

Favor de Editar el título, de otra manera mandare tu hilo a la papelera, Tu no tienes "Problema con el gestor de actualziaciones"

Tu tienes un "conflicto de dependencias al instalar QGis desde respositorios externos".

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de ubu777
+1
0
-1

La clave esta aqui:

Se encontraron errores al procesar:
/var/cache/apt/archives/grass-core_6.4.2~upstream2-3~precise4_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Parece ser que tu cache o el paquete mencionado se corrompió, manos a la obra con estos comandos:

sudo apt-get clean
sudo apt-get autoremove
sudo apt-get -f install
sudo apt-get update

+1
0
-1

--------------------------------------------------------------------
*I'm sorry, I've played very sensitive fibers. This forum is not ready for my help. You can contact me in the master forums.
Ubuntu Forums Org.