Dependencias rotas Python2.7

Imagen de osw000
0 puntos

Hola,
Tengo un problema con el paquete Python2.7. En el centro de Software me aparece un mensaje de catálogo roto, pero no es capaz de repararlo.
En el terminal he probado bastantes procedimientos que leí en otros foros pero ninguna consigue solucionarlo
Mi version de Ubuntu es 12.04 LTS. Tengo este problema desde hace un tiempo, pero no recuerdo a partir de que evento, pero pudo ser debido a alguna actualización en la que se cortó la red y quedó a medias.

Así que empiezo por describir lo que pasa al hacer un
sudo apt-get install -f

Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Corrigiendo dependencias... Listo
Se instalarán los siguientes paquetes extras:
  python2.7
Paquetes sugeridos:
  python2.7-doc
Se actualizarán los siguientes paquetes:
  python2.7
1 actualizados, 0 se instalarán, 0 para eliminar y 3 no actualizados.
27 no instalados del todo o eliminados.
Se necesita descargar 0 B/2.652 kB de archivos.
Se utilizarán 16,4 kB de espacio de disco adicional después de esta operación.
¿Desea continuar [S/n]? 
S

dpkg: problemas de dependencias impiden la configuración de python2.7:
 python2.7 depende de python2.7-minimal (= 2.7.3-0ubuntu3); sin embargo:
  La versión de `python2.7-minimal' en el sistema es 2.7.3-0ubuntu3.1.

dpkg: error al procesar python2.7 (--configure):
 problemas de dependencias - se deja sin configurar
No se escribió un informe «apport» porque el mensaje de error indica que es un mensaje de error asociado a un fallo previo.
                                           dpkg: problemas de dependencias impiden la configuración de python-apt:
 python-apt depende de python2.7; sin embargo:
 El paquete `python2.7' no está configurado todavía.
dpkg: error al procesar python-apt (--configure):
 problemas de dependencias - se deja sin configurar

No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
         dpkg: problemas de dependencias impiden la configuración de language-selector-common:
 language-selector-common depende de python2.7; sin embargo:
 El paquete `python2.7' no está configurado todavía.
 language-selector-common depende de python-apt (>= 0.7.12.0); sin embargo:
 El paquete `python-apt' no está configurado todavía.
dpkg: error al procesar language-selector-common (--configure):
 problemas de dependencias - se deja sin configurar

No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
         dpkg: problemas de dependencias impiden la configuración de python-problem-report:
 python-problem-report depende de python2.7; sin embargo:
 El paquete `python2.7' no está configurado todavía.
dpkg: error al procesar python-problem-report (--configure):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de python-apport:No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports» 

Este último párrafo se repite con todos estos paquetes:

Se encontraron errores al procesar:
 python2.7
 python-apt
 language-selector-common
 python-problem-report
 python-apport
 apport
 apport-gtk
 gwibber-service
 libgwibber2
 libgwibber-gtk2
 gwibber
 gwibber-service-facebook
 gwibber-service-identica
 gwibber-service-twitter
 jockey-common
 jockey-gtk
 python-aptdaemon
 aptdaemon
 python-aptdaemon.gtk3widgets
 language-selector-gnome
 python-uno
 libreoffice-emailmerge
 python-libxml2
 software-center
 unity-scope-video-remote
 xdiagnose
 python-aptdaemon.pkcompat

He probado reinstall, dist-upgrade, clean, autoclean, remove, ...
Pero nada me resuelve el lio
Alguna sugerencia?
La mayor parte de los programas me funcionan, pero el sistema está inestable y algunas aplicaciones no me las abre.

Muchas gracias
Osw.

Imagen de Jose Luis 1320
+1
0
-1

los PPA e intenta de nuevo.

dpkg: problemas de dependencias impiden la configuración de python2.7:
 python2.7 depende de python2.7-minimal (= 2.7.3-0ubuntu3); sin embargo:
  La versión de `python2.7-minimal' en el sistema es 2.7.3-0ubuntu3.1.
+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de Goyo
+1
0
-1

No me explico cómo podéis montar estos líos, es que ni queriendo.

Instala la versión requerida de python2.7-minimal:
sudo apt-get install python2.7-minimal=2.7.3-0ubuntu3

+1
0
-1