Ubuntu no actualiza el kernel (SOLUCIONADO)

Imagen de balhaus
0 puntos

Estimados poseo Ubuntu 12 lts y me ha funcionado perfecto, estoy feliz de haberme cambiado de windows. Sin embargo he estado teniendo una serie de problemas que creo comenzaron con lo siguiente:

- En las actualizaciones me aparecio un dia "nucleo linux generico" y "generic kernel linux image". EN la descripcion dice que mi version de ambas es 3.2.0.24.26 y que la version que se actualizara es la 3.2.0.45.54. CUando le doy a actualizar al final dice que hubo un error y no se pudo actualizar.

- Estas actualizaciones siempre aparecen en el gestor de actualizaciones y siempre terminan dando errores.

- Ahora cuando instalo algo aparece al final: no se ha podido instalar siendo que aveces queda instalado.... otras veces no corre lo instalado.

Los problemas creo son de ese par de actualizaciones...

Soy un novato en esto de ubuntu quien me puede ayudar. se los agradeceria mucho!!!

Saludos

Imagen de cuentos
+1
0
-1

Mira que error te da al correr estos dos comandos en la terminal.
sudo apt-get update
sudo apt-get upgrade
Y mira al final si te dan un error. (y pon solo el error en caso de que te de uno).

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de balhaus
+1
0
-1

al poner update sale:

Err http://ppa.launchpad.net precise/main Sources
404 Not Found
Err http://ppa.launchpad.net precise/main amd64 Packages
404 Not Found
Err http://ppa.launchpad.net precise/main i386 Packages
404 Not Found
Ign http://ppa.launchpad.net precise/main Translation-es_CL
Ign http://ppa.launchpad.net precise/main Translation-es
Ign http://ppa.launchpad.net precise/main Translation-en
Ign http://ppa.launchpad.net precise/main Translation-es_CL
Ign http://ppa.launchpad.net precise/main Translation-es
Ign http://ppa.launchpad.net precise/main Translation-en
Ign http://ppa.launchpad.net precise/main Translation-es_CL
Ign http://ppa.launchpad.net precise/main Translation-es
Ign http://ppa.launchpad.net precise/main Translation-en
Ign http://ppa.launchpad.net precise/main Translation-es_CL
Ign http://archive.canonical.com precise/partner Translation-es_CL
Ign http://ppa.launchpad.net precise/main Translation-es
Ign http://ppa.launchpad.net precise/main Translation-en
Ign http://extras.ubuntu.com precise/main Translation-es_CL
Ign http://archive.canonical.com precise/partner Translation-es
Ign http://extras.ubuntu.com precise/main Translation-es
Ign http://archive.canonical.com precise/partner Translation-en
Ign http://extras.ubuntu.com precise/main Translation-en
W: Imposible obtener http://ppa.launchpad.net/pmcenery/ppa/ubuntu/dists/precise/main/source/S... 404 Not Found

W: Imposible obtener http://ppa.launchpad.net/pmcenery/ppa/ubuntu/dists/precise/main/binary-a... 404 Not Found

W: Imposible obtener http://ppa.launchpad.net/pmcenery/ppa/ubuntu/dists/precise/main/binary-i... 404 Not Found

E: Algunos archivos de índice fallaron al descargar. Se han ignorado, o se han utilizado unos antiguos en su lugar

Esto es cuando pongo upgrade:

dpkg: problemas de dependencias impiden la configuración de linux-image-generic:
linux-image-generic depende de linux-image-3.2.0-24-generic; sin embargo:
El paquete `linux-image-3.2.0-24-generic' no está configurado todavía.
dpkg: error al procesar linux-image-generic (--configure):
problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de linux-generic:
linux-generic depende de linux-image-generic (= 3.2.0.24.26); sin embargo:
El paquete `linux-image-generic' no está configurado todavía.
dpkg: error al procesar linux-generic (--configure):
problemas de dependencias - se deja sin configurar
No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
Se encontraron errores al procesar:
linux-image-3.10.0-031000rc4-generic
linux-image-3.2.0-24-generic
linux-image-3.2.0-25-generic
linux-image-3.2.0-26-generic
linux-image-3.2.0-27-generic
linux-image-3.2.0-29-generic
linux-image-3.2.0-31-generic
linux-image-3.2.0-32-generic
linux-image-3.2.0-34-generic
linux-image-3.2.0-35-generic
linux-image-3.2.0-37-generic
linux-image-3.2.0-38-generic
linux-image-3.2.0-39-generic
linux-image-3.2.0-40-generic
linux-image-3.2.0-41-generic
linux-image-3.2.0-43-generic
linux-image-3.2.0-44-generic
linux-image-3.2.0-45-generic
linux-image-3.9.3-030903-generic
linux-image-generic
linux-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)

Muchas gracias por tu ayuda

+1
0
-1
Imagen de cuentos
+1
0
-1

A mi manera de ver, la manera mas fácil, y que no tengas problemas es instalar primero synaptic, y desde este tratar de instalar el kernel. primero instala synaptic:
sudo apt-get install synaptic
EDITADO
y después ejecutas synaptic y desde este buscas un kernel y lo marcas para intalar. y el programa te lo instala y configura junto con las dependencias.
Trata desde esta forma.
EDITADO.

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de balhaus
+1
0
-1

Lo instale, ejecute, busque el kernel pero aparecio error indicando lo siguiente

E: linux-image-3.10.0-031000rc4-generic: el subproceso instalado el script post-installation devolvió el código de salida de error 2
E: linux-image-3.2.0-24-generic: el subproceso instalado el script post-installation devolvió el código de salida de error 2
E: linux-image-3.2.0-25-generic: el subproceso instalado el script post-installation devolvió el código de salida de error 2
E: linux-image-3.2.0-26-generic: el subproceso instalado el script post-installation devolvió el código de salida de error 2
E: linux-image-3.2.0-27-generic: el subproceso instalado el script post-installation devolvió el código de salida de error 2
E: linux-image-3.2.0-29-generic: el subproceso instalado el script post-installation devolvió el código de salida de error 2
E: linux-image-3.2.0-31-generic: el subproceso instalado el script post-installation devolvió el código de salida de error 2
E: linux-image-3.2.0-32-generic: el subproceso instalado el script post-installation devolvió el código de salida de error 2
E: linux-image-3.2.0-34-generic: el subproceso instalado el script post-installation devolvió el código de salida de error 2
E: linux-image-3.2.0-35-generic: el subproceso instalado el script post-installation devolvió el código de salida de error 2
E: linux-image-3.2.0-37-generic: el subproceso instalado el script post-installation devolvió el código de salida de error 2
E: linux-image-3.2.0-38-generic: el subproceso instalado el script post-installation devolvió el código de salida de error 2
E: linux-image-3.2.0-39-generic: el subproceso instalado el script post-installation devolvió el código de salida de error 2
E: linux-image-3.2.0-40-generic: el subproceso instalado el script post-installation devolvió el código de salida de error 2
E: linux-image-3.2.0-41-generic: el subproceso instalado el script post-installation devolvió el código de salida de error 2
E: linux-image-3.2.0-43-generic: el subproceso instalado el script post-installation devolvió el código de salida de error 2
E: linux-image-3.2.0-44-generic: el subproceso instalado el script post-installation devolvió el código de salida de error 2
E: linux-image-3.2.0-45-generic: el subproceso instalado el script post-installation devolvió el código de salida de error 2
E: linux-image-3.9.3-030903-generic: el subproceso instalado el script post-installation devolvió el código de salida de error 2
E: linux-image-generic: problemas de dependencias - se deja sin configurar
E: linux-generic: problemas de dependencias - se deja sin configurar

gracias por tu dedicacion cuentos

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

Y no me refiero a lo del foro, sino que antes de tener este problema tu hiciste algo y lo hiciste mal, puesto que este problema no se da de la nada.

Y el problema no esta en sólo 2 kernel, sino en todos, tienes más de 20 con el problema.

¿De donde sacaste los kernel 3.9.3-030903-generic y 3.10.0-031000rc4?

"linux-image-generic" y "linux-generic" tienen un problema y ese es que el sistema no los puede configurar y al no poder configurarlos no puedes terminar de instalar los demás kernel y probablemente ningún otro programa.

Y la otra pregunta, tal vez se relacione con la primera...

¿Como llegaste a esta situación, en donde el sistema no puede configurar 'linux-image-generic' ni 'linux-generic'?.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de balhaus
+1
0
-1

CUando ya el problema estaba en el notebook lei que se podia actualizar el kernel instalando las cabeceras y despues la image. Asi que entre en una pagina que tenia varios kernel con versiones mas actuales que la mia y probe con una de ellas un dia y luego con otra. DE ahi que aparece la 3.9 y la 3.10. Pero el problema ya estaba de antes... se puede decir que lo empeore pero el problema ya existia.

¿Que puedo hacer? o tendre que instalar ubuntu de nuevo?

Saludos y gracias de nuevo

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

para ayudarte no sirve.

¿de que pagina hablas?

Y no, los kernel que instalaste de tu pagina web fantasma no se han terminado de configurar.

CUando ya el problema estaba en el notebook lei que se podia actualizar el kernel instalando las cabeceras y despues la image

De esto no te entiendo nada, ¿que quieres decir?.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de balhaus
+1
0
-1

De esta pagina los obtuve http://kernel.ubuntu.com/~kernel-ppa/mainline/ LOs baje e instale como decia en esta pagina http://www.leanuxeros.com/linux/como-actualizar-el-kernel-en-ubuntu-12-0...

Lo hice tal cual primero con la 3.9 y despues con la 3.10

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

Si el problema lo tenías antes de instalar los kernel, entonces tienes que ver la raìz del problema. No se como tuviste el problema, no te puedo decir más.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de balhaus
+1
0
-1

BUeno gracias por tu ayuda Jose Luis :)

Alguien mas puede tener alguna idea de que puedo hacer en este caso???

Muy agradecido de todos.

Saludos

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

Puesto que nadie sabe como tuviste el problema.

Te repito: Ese problema que tienes no se da de la nada, algo hiciste.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de balhaus
+1
0
-1

JOse Luis lo unico que podria agregar a lo que ya he dicho es que yo tenia ubuntu 10 y aparecio el 12 y lo actualice a traves de internet. Deje activa las actualizaciones asi que cada vez que el gestor me las daba yo las instalaba.

Un dia aparecieron esas actualizaciones de kernel y comenzaron los problemas por que no se pudieron instalar y una y otra vez el gestor me las mostraba. Luego se me ocurrio meterme en la pagina que nombre e instale la 3.9 y como no funciono instale la mas nueva que encontre que fue la 3.10

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

¿y como actualizaste? el problema puede estar en como lo hayas hecho, en uno de tus comentarios, en donde muestras la salida de algunos comandos, se puede ver que tienes repositorios externos... ¿cuando y como los agregaste?.

Y no, para actualizaciones de software, no de la distribución, tu no eliges, esas se dan automáticamente por que son actualizaciones de, entre otras cosas, seguridad.

Y tampoco dijiste que actualizaste de ubuntu '10' a Ubuntu '12'. Nunca lo has dicho, hasta ahora. No digas mentiras.

¿Que más hiciste?.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de bean
+1
0
-1

Que este boy tiene más kérneles que Linus en su armario. Es una de las cosas más raras - como un Oopart ((Out of Place Artifact) - que he visto nunca, nunca jamás, hasta hoy; parece que todos ellos están desenfocados o precisamente, fuera de lugar.
Saludos.

+1
0
-1
Imagen de balhaus
+1
0
-1

Solo esta en la configuracion de Ubuntu para que se actualicen las importantes de seguridad. Nada mas que esas. SImplemente cuando sugiere actualizaciones le doy para que las actualice y listo. Solo el kernel 3.9 y 3.10 los instale de las paginas que ya puse en los comentarios anteriores

+1
0
-1
Imagen de ubu777
+1
0
-1

Nunca se deben instalar los kernel (un novato) con DPKG, no manejan las dependencias correctamente.
Debiste haberlo echo con herramientas mas de acuerdo a usuarios noveles, como Gdebi por ejemplo.
Tienes un problema de dependencias con los kernel's, lo que sugiero en estos casos es la reversion.
Trata de desintalar con DPKG lo que hayas instalado con esa herramienta en el orden como lo hiciste.
Luego aplica un:

sudo apt-get -f install
sudo apt-get update
sudo apt-get updgrade

Tambien borra el repositorio PPA, que no funciona con :

sudo ppa-purge ppa:pmcenery/ppa

+1
0
-1

--------------------------------------------------------------------
*I'm sorry, I've played very sensitive fibers. This forum is not ready for my help. You can contact me in the master forums.
Ubuntu Forums Org.

Imagen de balhaus
+1
+1
-1

SOLUCIONADO: trate de desinstalar pero salen errores una y otravez asi que mejor respalde y reinstale. Listo , de todas maneras sumando y restando me quedo con ubuntu.

Gracias por la ayuda!

+1
+1
-1