Instalar y actualizar Ubuntu 10.04.4 LTS lucid x64

Imagen de drhalo
0 puntos

Hola foro,

Tenemos un producto el cual el distribuidor nos pide instalarlo solo en un Ubuntu 10.04, bien, ningún problema, nos bajamos la versión correspondiente a 10.04 LTS, versión 64Bits, creamos una máquina virtual para la bestia y ale, a instalarlo.

La sorpresa nos la llevamos una vez ya instalado el servidor y tratando de actualizar repositorios. Error, ya no existen. Bueno, vamos a buscar documentación a padre google, entre la mucha que encontramos vemos EOLUpgrades que indica que hemos de cambiar nuestro sources.list de es.archive.ubuntu.com a old-releases.ubuntu.com.
Nuestro sources.list queda de la siguiente forma:

## EOL upgrade sources.list
# Required
deb http://old-releases.ubuntu.com/ubuntu/ lucid main restricted universe multiverse
deb http://old-releases.ubuntu.com/ubuntu/ lucid-updates main restricted universe multiverse
deb http://old-releases.ubuntu.com/ubuntu/ lucid-security main restricted universe multiverse

# Optional
#deb http://old-releases.ubuntu.com/ubuntu/ lucid-backports main restricted universe multiverse

pedimos ahora de hacer un apt-get update y parece que va bien pero muestra los siguientes errores:

root@contentDM:/etc/apt# apt-get update
Obj http://old-releases.ubuntu.com lucid Release.gpg
Obj http://old-releases.ubuntu.com/ubuntu/ lucid/main Translation-es
Ign http://old-releases.ubuntu.com/ubuntu/ lucid/restricted Translation-es
Ign http://old-releases.ubuntu.com/ubuntu/ lucid/universe Translation-es
Ign http://old-releases.ubuntu.com/ubuntu/ lucid/multiverse Translation-es
Obj http://old-releases.ubuntu.com lucid-updates Release.gpg
Ign http://old-releases.ubuntu.com/ubuntu/ lucid-updates/main Translation-es
Ign http://old-releases.ubuntu.com/ubuntu/ lucid-updates/restricted Translation-es
Ign http://old-releases.ubuntu.com/ubuntu/ lucid-updates/universe Translation-es
Ign http://old-releases.ubuntu.com/ubuntu/ lucid-updates/multiverse Translation-es
Obj http://old-releases.ubuntu.com lucid-security Release.gpg
Ign http://old-releases.ubuntu.com/ubuntu/ lucid-security/main Translation-es
Ign http://old-releases.ubuntu.com/ubuntu/ lucid-security/restricted Translation-es
Ign http://old-releases.ubuntu.com/ubuntu/ lucid-security/universe Translation-es
Ign http://old-releases.ubuntu.com/ubuntu/ lucid-security/multiverse Translation-es
Obj http://old-releases.ubuntu.com lucid Release
Obj http://old-releases.ubuntu.com lucid-updates Release
Obj http://old-releases.ubuntu.com lucid-security Release
Ign http://old-releases.ubuntu.com lucid/main Packages
Ign http://old-releases.ubuntu.com lucid/restricted Packages
Ign http://old-releases.ubuntu.com lucid/universe Packages
Ign http://old-releases.ubuntu.com lucid/multiverse Packages
Ign http://old-releases.ubuntu.com lucid-updates/main Packages
Ign http://old-releases.ubuntu.com lucid-updates/restricted Packages
Ign http://old-releases.ubuntu.com lucid-updates/universe Packages
Ign http://old-releases.ubuntu.com lucid-updates/multiverse Packages
Ign http://old-releases.ubuntu.com lucid-security/main Packages
Ign http://old-releases.ubuntu.com lucid-security/restricted Packages
Ign http://old-releases.ubuntu.com lucid-security/universe Packages
Ign http://old-releases.ubuntu.com lucid-security/multiverse Packages
Ign http://old-releases.ubuntu.com lucid/main Packages
Ign http://old-releases.ubuntu.com lucid/restricted Packages
Ign http://old-releases.ubuntu.com lucid/universe Packages
Ign http://old-releases.ubuntu.com lucid/multiverse Packages
Ign http://old-releases.ubuntu.com lucid-updates/main Packages
Ign http://old-releases.ubuntu.com lucid-updates/restricted Packages
Ign http://old-releases.ubuntu.com lucid-updates/universe Packages
Ign http://old-releases.ubuntu.com lucid-updates/multiverse Packages
Ign http://old-releases.ubuntu.com lucid-security/main Packages
Ign http://old-releases.ubuntu.com lucid-security/restricted Packages
Ign http://old-releases.ubuntu.com lucid-security/universe Packages
Ign http://old-releases.ubuntu.com lucid-security/multiverse Packages
Err http://old-releases.ubuntu.com lucid/main Packages
  404  Not Found
Err http://old-releases.ubuntu.com lucid/restricted Packages
  404  Not Found
Err http://old-releases.ubuntu.com lucid/universe Packages
  404  Not Found
Err http://old-releases.ubuntu.com lucid/multiverse Packages
  404  Not Found
Err http://old-releases.ubuntu.com lucid-updates/main Packages
  404  Not Found
Err http://old-releases.ubuntu.com lucid-updates/restricted Packages
  404  Not Found
Err http://old-releases.ubuntu.com lucid-updates/universe Packages
  404  Not Found
Err http://old-releases.ubuntu.com lucid-updates/multiverse Packages
  404  Not Found
Err http://old-releases.ubuntu.com lucid-security/main Packages
  404  Not Found
Err http://old-releases.ubuntu.com lucid-security/restricted Packages
  404  Not Found
Err http://old-releases.ubuntu.com lucid-security/universe Packages
  404  Not Found
Err http://old-releases.ubuntu.com lucid-security/multiverse Packages
  404  Not Found
W: Imposible obtener http://old-releases.ubuntu.com/ubuntu/dists/lucid/main/binary-amd64/Packages.gz  404  Not Found

W: Imposible obtener http://old-releases.ubuntu.com/ubuntu/dists/lucid/restricted/binary-amd64/Packages.gz  404  Not Found

W: Imposible obtener http://old-releases.ubuntu.com/ubuntu/dists/lucid/universe/binary-amd64/Packages.gz  404  Not Found

W: Imposible obtener http://old-releases.ubuntu.com/ubuntu/dists/lucid/multiverse/binary-amd64/Packages.gz  404  Not Found

W: Imposible obtener http://old-releases.ubuntu.com/ubuntu/dists/lucid-updates/main/binary-amd64/Packages.gz  404  Not Found

W: Imposible obtener http://old-releases.ubuntu.com/ubuntu/dists/lucid-updates/restricted/binary-amd64/Packages.gz  404  Not Found

W: Imposible obtener http://old-releases.ubuntu.com/ubuntu/dists/lucid-updates/universe/binary-amd64/Packages.gz  404  Not Found

W: Imposible obtener http://old-releases.ubuntu.com/ubuntu/dists/lucid-updates/multiverse/binary-amd64/Packages.gz  404  Not Found

W: Imposible obtener http://old-releases.ubuntu.com/ubuntu/dists/lucid-security/main/binary-amd64/Packages.gz  404  Not Found

W: Imposible obtener http://old-releases.ubuntu.com/ubuntu/dists/lucid-security/restricted/binary-amd64/Packages.gz  404  Not Found

W: Imposible obtener http://old-releases.ubuntu.com/ubuntu/dists/lucid-security/universe/binary-amd64/Packages.gz  404  Not Found

W: Imposible obtener http://old-releases.ubuntu.com/ubuntu/dists/lucid-security/multiverse/binary-amd64/Packages.gz  404  Not Found

E: Algunos archivos de índice no se han podido descargar, se han ignorado,
o se ha utilizado unos antiguos en su lugar.

Alguién puede echarnos un cable para salir de este problemilla que nos tiene atascado?
Saludos y gracias por adelantado.

Imagen de .doc
+1
0
-1

mi consejo es que pruebes instalar el Ubuntu 12.04, que es LTS, y pruebes a ver si ese producto funciona ahí. Pudiera ocurrir, simplemente, que cuando se diseñó ese producto la versión 'normal' era la 10.04, y el fabricante no se molestó en actualizar el dato.

Lo digo porque, dada la evolución de los Buntus, cambiando de versión cada 6 meses y retirando cada cierto tiempo el soporte, es poco normal tener que recurrir a mantener versiones obsoletas y soportes más o menos abandonados, aunque estén en old-releases.

De todas formas, mira a ver, también, si no ha sido un problema puntual de esos servidores. O escribe el comando habitual, con sudo
sudo apt-get update && sudo apt-get dist-upgrade

+1
0
-1
Imagen de drhalo
+1
0
-1

Gracias por tu comentario .doc, ya me gustaría usar 12.04 LTS, pero la 10.04 ha sido impuesta.
Con todo ya he encontrado la solución, y me extrañaba que no encontrara alguién por la red con el mismo problema.
He recuperado el archivo sources.list inicial y en lugar de sustituir es.archive.ubuntu.com por old-releases.ubuntu.com lo he sustituido por us.archive.ubuntu.com.
El apt-get ahora no me da problemas.
Conclusión: ¿Los servidores españoles no están correctamente actualizados?

+1
0
-1
Imagen de .doc
+1
0
-1

si, desgraciadamente los servidores españoles fallan más que una escopeta de feria. Yo suelo usar los franceses, que van infinitamente mejor.

+1
0
-1
Imagen de Alcruz
+1
0
-1

Tambien tuve problemas con los old-releases, sin embargo, probé con otros mirros y algunos todavía funcionan, ni idea hasta cuando, prueba con los mirros de Brasil, te paso mi sources.list

deb http://br.archive.ubuntu.com/ubuntu/ lucid main restricted
deb-src http://br.archive.ubuntu.com/ubuntu/ lucid main restricted
deb http://br.archive.ubuntu.com/ubuntu/ lucid-updates main restricted
deb-src http://br.archive.ubuntu.com/ubuntu/ lucid-updates main restricted
deb http://br.archive.ubuntu.com/ubuntu/ lucid universe multiverse
deb-src http://br.archive.ubuntu.com/ubuntu/ lucid universe multiverse
deb http://br.archive.ubuntu.com/ubuntu lucid-security main restricted
deb-src http://br.archive.ubuntu.com/ubuntu lucid-security main restricted
+1
0
-1
Imagen de drhalo
+1
0
-1

Gracias .doc y Alcruz por vuestros comentarios. Parece que usando servidores de otros paises funciona todo ok.
Alcruz me apunto los repositorios que has posteado por si en un futuro tuviera problemas.

Salu2

+1
0
-1