Solucionado - ubuntu 12.04 queda en login

Imagen de ic3man
0 puntos

hola, mi ubuntu 12.04 de 32 bits andaba de lujo hasta que quise actualizar el driver de video NVIDIA manualmente, desinstale los drivers antiguos y agregue archivos de nouveau a la blacklist. Luego apague el entorno gráfico e instale el driver por consola. Todo bien, hasta que reinicie y cuando me logueo quiere iniciar y vuelve a la página de login. Sí ingreso como invitado funciona ok sólo tengo el problema con mi usuario.

por favor, sí pueden ayudarme. gracias

Imagen de cuentos
+1
0
-1

Intenta "logearte" desde la terminal.
donde pones tu nombre y contraseña, presiona CTR+ALT+F1 (o F2,F3), y te manda a la terminal, hay pones tu nombre y contraseña. Si te reconoce y puedes entrar, trata de cargar el entorno gráfico con:
startx
En caso de que no puedes logearte o iniciar el entorno gráfico mira que tipo de error te da.

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de ic3man
+1
0
-1

Hola, hice como me dijiste y me informo algunos errores.

xauth: /home/usuario/ .Xauthority not writable, changes will be ignored

xinit: server error.

En realidad es mas completo, tengo una captura de pantalla pero no encuentro la forma de adjuntarla a este mensaje.

+1
0
-1
Imagen de cuentos
+1
0
-1

para poner imágenes, sube-las a internet (a cualquier servicio de fotos) y pones la liga aquí.y de paso ejecuta este comando para ver el error que dices, igual entras a la terminal y pones:
ls -l /home/alex/.Xauthority
es ls menos ele y la parte de /home/alex (alex es mi usuario, aquí pones el tuyo)/.Xauthority
y los permisos son algo como esto.
-rw------- 1 alex alex 52 may 1 07:07 /home/alex/.Xauthority

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de ic3man
+1
0
-1

Hola, agrego la primer captura de los errores que me informa el sistema
https://fbcdn-sphotos-c-a.akamaihd.net/hphotos-ak-prn1/1017088_497261027...

Y este es el resultado de ls -l /home/alex/.Xauthority
https://fbcdn-sphotos-g-a.akamaihd.net/hphotos-ak-ash4/379581_4972611039...

Desde ya agradezco tu ayuda.

+1
0
-1
Imagen de cuentos
+1
0
-1

Si miras el resultado del comando, el propietario es root. ??? y con permisos el grupo, y otros.
Algo hiciste para cambiar los permisos de este archivo, tal vez quisiste entrar al entorno gráfico con sudo.
Haber, para tratar de arreglar esto igual en la terminal te ubicas en tu home. y ejecutas estos comandos.
el primero es para quitar los permisos a el grupo y a otros usuarios:
sudo chmod 600 .Xauthority
Y luego cambiamos al propietario del archivo a tu usuario:
sudo chown alex:alex .Xauthority
Toma nota que alex:alex soy yo mi usuario aquí cambia al nombre de tu usuario.
Compruebas que ya este bien:
ls -l .Xauthority
y te saldra algo como esto:
-rw------- 1 alex alex 0 jun 13 09:49 .Xauthority
donde debe de ser -rw-------- y alex alex el propietario y el grupo.
Ya con esto prueba. Y como recomendación ten cuidado con ejecutar sudo

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de ic3man
+1
0
-1

Ya esta solucionado, era justamente como dijistes un problema de permisos.

Ahora esto se ocasiono por usar SUDO, como mencionaste. Sera cuestion de que averigüe cuando no debo usarlo.
Por otro lado el driver NVIDIA que descargue de la pagina oficial no funciono. Consulta, intento instalarlo nuevamente?

Desde ya agradezco tu tiempo, tu amabilidad y tu predisposicion.

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

O bueno, cuentos te dio la respuesta:

tal vez quisiste entrar al entorno gráfico con sudo.

sudo JAMAS lo vas a usar para abrir aplicaciones gráficas; gedit, rhythmbox, emesene, nautilus, etc.

para eso existen gksudo y gksu, para Unity/gnome. y kdesudo y kdesu para KDE.

Y tampoco trates de iniciar X de forma manual con sudo, por ejemplo:

sudo startx

para iniciar X como root, debes loguearte como root primero.

De hacer caso omiso, te va a pasar lo que te pasó, perderás los permisos del .Xauthority.

Y lo del driver de nvidia, si quieres abre un hilo nuevo especificando detalles. para usar el driver de nvidia, basicamente necesitas el driver driver y el driver de xorg y ambos tienen que coincidir en la versión y otros componentes que debes tomar en cuenta si quieres que el driver funcione, la documentación.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de cuentos
+1
0
-1

Editar el titulo del primer post y agregar (solucionado).
PD. y ten cuidado con la skynet, no vaya ser el fin de la humanidad

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos