"no se pudieron corregir los problemas, usted ha retenido paquetes rotos"

Imagen de Nalya
0 puntos

Hola que tal? Este fin de semana que paso desinstale el pidgin en mi maquina, y ahora quise volver a instalarlo pero no puedo hacerlo y no encuentro la manera de solucionarlo. Tengo el ubuntu 12.04. Para desinstalar el pidgin use primero

sudo apt-get remove pidgin y despues use sudo apt-get remove --purge pidgin

con eso se desinstalo, pero ahora que trato de instalarlo me dice esto

nalya@myprecious:~$ sudo apt-get install pidgin
[sudo] password for nalya:
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
pidgin : Depende: pidgin-data (< 1:2.10.3-z) pero 1:2.10.7-2ubuntu0+pidgin1.12.04 va a ser instalado
Recomienda: pidgin-libnotify pero no va a instalarse
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.

Si pruebo desde el aptitude no me lo instala, y desde el centro de software me dice lo siguiente

Las dependencias del paquete no se pueden resolver
Este error podría deberse a que se necesitan paquetes de software adicionales que faltan o que no son instalables. También podría ser un conflicto entre paquetes de software que no pueden instalarse juntos.

Los siguientes paquetes tienen dependencias incumplidas:

pidgin: Depends: perlapi-5.14.2 pero es un paquete virtual

La verdad no se como hacer para instalarlo, tal vez alguno me pueda ayudar.

Gracias!!!

Imagen de cuentos
+1
0
-1

No agregaste un ppa.
que te da este comando en la terminal:
ls /etc/apt/sources.list.d

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de Nalya
+1
0
-1

El ppa del pidgin figura en la lista, pero no se que tengo que hacer con eso. Es la primera vez que me salta un error así, siempre que tuve que desinstalar y volver a instalar lo hice sin ningún problema.

nalya@myprecious:~$ ls /etc/apt/sources.list.d
google-chrome.list
google-chrome.list.distUpgrade
google-chrome.list.save
google-talkplugin.list
google-talkplugin.list.save
jd-team-jdownloader-oneiric.list
jd-team-jdownloader-oneiric.list.distUpgrade
jd-team-jdownloader-oneiric.list.save
medibuntu.list
medibuntu.list.distUpgrade
medibuntu.list.save
pidgin-ppa.list.save
tualatrix-ppa-precise.list
tualatrix-ppa-precise.list.save
upubuntu-com-mobile-precise.list
upubuntu-com-mobile-precise.list.save
xbmc.list
xbmc.list.distUpgrade
xbmc.list.save
yannubuntu-boot-repair-precise.list
yannubuntu-boot-repair-precise.list.save

+1
0
-1
Imagen de cuentos
+1
0
-1

Pues tienes el sistema "roto", o sea se incumplen las dependencias, y no te dejara instalar nada.
Los ppa nunca los instalo solo los mínimos indispensables, como boot-repair (en una ocasión, pero fue en forma live, y no en el sistema). Y luego tienes repos de precise y de oneric.
Son los riesgos y consecuencias de querer tener lo ultimo.
Como te comente difícil, y tienes que tomar una decisión, tratar de recuperar la estabilidad del sistema o reinstalar.

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de Jose Luis 1320
+1
0
-1

A lo mucho que puede pasar es que no tengas problemas para instalar este programa, todo depende de que tantas dependencias hayan roto los repositorios que tienes.

luego remueves los ppa,

ppa-purge repositorio

, procura hacerlo en el orden que los hayas agregado.
No es bueno y nunca lo será abusar de los PPA.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de Nalya
+1
0
-1

Bueno instale el ppa-purge y probe lo siguiente (no se si estoy haciendolo bien)

nalya@myprecious:~$ sudo ppa-purge pidgin-ppa.list.save
Updating packages lists
PPA to be removed: pidgin-ppa.list.save ppa
Warning: Could not find package list for PPA: pidgin-ppa.list.save ppa

Pero aparentemente no pude eliminarlo.

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

es ppa-purge ppa:pidgin/ppa, según el nombre del respositorio, NO del archivo.

EL nombre del respositorio lo obtienes en la web del PPA, en las instrucciones de como agregarlo.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de rioport
+1
0
-1

Para poder eliminarlos con ppa-purge necesitas indicarle el nombre del repositorio PPA, no el nombre del archivo de fuentes de paquetes (el archivo .list). He encontrado un script que puede ayudar y lo he modificado un poquito para ayudar en este paso:

#! /bin/sh
# Script to get all the PPA installed on a system
for APT in `find /etc/apt/ -name \*.list`; do
    grep -Po "(?<=^deb\s).*?(?=#|$)" $APT | while read ENTRY ; do
        HOST=`echo $ENTRY | cut -d/ -f3`
        USER=`echo $ENTRY | cut -d/ -f4`
        PPA=`echo $ENTRY | cut -d/ -f5`
        if [ "ppa.launchpad.net" = "$HOST" ]; then
            echo sudo ppa-purge ppa:$USER/$PPA
        fi
    done
done

Lo guardas en un archivo con extensión sh le das permisos de ejecución y lo ejecutas en una terminal. Lo único que hace es mostrarte los comandos a ejecutar para remover cada PPA que tienes con ppa-purge.

+1
0
-1

-- GC --

Imagen de Nalya
+1
0
-1

Ahhh okok en cuanto llegue a casa voy a probarlo de esa manera. Es la primera vez que me toca usar un ppa. Esta noche voy a tratar de removerlo asi a ver si de alguna de las dos maneras a ver si puedo eliminarlo y volver a instalar.

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

No lo creo si tienes como 20.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro