LibreOffice se cierra sólo cuando doy al botón Vista Preliminar (Solucionado)

Imagen de aplicedu
0 puntos

Hola

En LibreOffice, cuando en cualquier documento con el que estoy trabajando doy al botón de "Vista preliminar" se me cierra el programa automáticamente.

Estoy usando lo siguiente:

- Kubuntu 12.04 LTS
- LibreOffice 3.5.7.2 Build ID: 350m1(Build:2)
- He probado con muchos documentos de varios tipos
- También me ocurre con LibreOffice Calc.
- cuando me se me cierra, se me cierran automáticamente todos los productos de tenga de LibreOffice (Writer, hojas de cálculo, etc).

He ejecutado LibreOffice desde la terminal, y veo que cuando doy a "Vista preliminar" me arroja este error:

libreoffice X Error: BadMatch (invalid parameter attributes) 8
Major opcode: 42 (X_SetInputFocus)
Resource id: 0x5600031 WARNING: gnome-keyring:: couldn't co
couldn't call /com/canonical/AppMenu/Registrar.UnregisterWindow

He estado buscando información al respecto, pero sólo veo información de bugs abiertos pero sin respuesta, y ni siquiera se si se refiere a lo mismo.

Os agradecería vuestra ayuda. Suelo necesitar usar bastante la vista preliminar.

gracias.

Imagen de Jose Luis 1320
+1
0
-1

Cuando abro sesión en Unity no pasa nada. Entonces es un bug en la versión de Libreoffice que empaqueta Ubuntu, ya sea por una dependencia mal hecha al appmenu de Unity.

Si no tienes Unity, entonces desinstalando el paquete lo-menubarel problema se podría solucionar, a mi ya no se me cierra Libreoffice después de haberlo purgado.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de Gabriel_M
+1
0
-1

Elimina el paquete instalado desde los repositorios.
Instala manualmente los paquetes descargados desde su sitio:
http://es.libreoffice.org/descarga/?nodetect

+1
0
-1
Imagen de aplicedu
+1
0
-1

Hola,

Pues al final, intentando hacer lo que me indicáis lo he solucionado pero por otra vía (bueno, en realidad no lo he solucionado, sino que he instalado otra versión y veo que ahí no me falla la vista preliminar; no es realmente solucionarlo, pero bueno, ha sido práctico).

he instalado LibreOffice vía PPA repositorios, por lo cual, me ha instalado la última versión (supongo que estable) de LibreOffice, es decir la Versión 4.0.4.2 (ID de compilación: 400m0(Build:2))

He seguido las instrucciones de este blog:
http://tranqui69.fluxers.com/?p=85

Muchísimas gracias a los dos por vuestro aporte.:-)

+1
0
-1