Problema con instalación de Postgresql 9.1

Imagen de joapenaca
0 puntos

Instale el postgresql 9.1 y no me podía conectar a la base de datos desde el pgadminIII.
Ley en algunos foros que se tenía que hacer una modificación el el archivo hba_conf, cambiando el
tipo de autenticación que se usaba para conectarse al localost cambiandola a md5.

El problema es que hice la modificación e igual no me pude conectar.
Decidi desintalar el postgresql y volverlo a instalar pero al momento de la instalación
me saca el siguiente error:

andres@andres-Aspire-4252:~$ sudo aptitude install postgresql-9.1
Se configurarán los siguientes paquetes que están ahora parcialmente instalados:
postgresql-9.1 postgresql-common
No se instalará, actualizará o eliminará ningún paquete.
0 paquetes actualizados, 0 nuevos instalados, 0 para eliminar y 276 sin actualizar.
Necesito descargar 0 B de archivos. Después de desempaquetar se usarán 0 B.
Configurando postgresql-common (129ubuntu1) ...
* Starting PostgreSQL 9.1 database server * The PostgreSQL server failed to start. Please check the log output:
2013-06-27 23:27:06 COT LOG: authentication option not in name=value format: md5
2013-06-27 23:27:06 COT CONTEXT: line 92 of configuration file "/etc/postgresql/9.1/main/pg_hba.conf"
2013-06-27 23:27:06 COT FATAL: could not load pg_hba.conf
[fail]
invoke-rc.d: initscript postgresql, action "start" failed.
dpkg: error al procesar postgresql-common (--configure):
el subproceso instalado el script post-installation devolvió el código de salida de error 1
No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
dpkg: problemas de dependencias impiden la configuración de postgresql-9.1:
postgresql-9.1 depende de postgresql-common (>= 115~); sin embargo:
El paquete `postgresql-common' no está configurado todavía.
dpkg: error al procesar postgresql-9.1 (--configure):
problemas de dependencias - se deja sin configurar
No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
Se encontraron errores al procesar:
postgresql-common
postgresql-9.1
E: Sub-process /usr/bin/dpkg returned an error code (1)
Un paquete no se pudo instalar. Intentado recuperarse:
Configurando postgresql-common (129ubuntu1) ...
* Starting PostgreSQL 9.1 database server * The PostgreSQL server failed to start. Please check the log output:
2013-06-27 23:27:08 COT LOG: authentication option not in name=value format: md5
2013-06-27 23:27:08 COT CONTEXT: line 92 of configuration file "/etc/postgresql/9.1/main/pg_hba.conf"
2013-06-27 23:27:08 COT FATAL: could not load pg_hba.conf
[fail]
invoke-rc.d: initscript postgresql, action "start" failed.
dpkg: error al procesar postgresql-common (--configure):
el subproceso instalado el script post-installation devolvió el código de salida de error 1
dpkg: problemas de dependencias impiden la configuración de postgresql-9.1:
postgresql-9.1 depende de postgresql-common (>= 115~); sin embargo:
El paquete `postgresql-common' no está configurado todavía.
dpkg: error al procesar postgresql-9.1 (--configure):
problemas de dependencias - se deja sin configurar
Se encontraron errores al procesar:
postgresql-common
postgresql-9.1

Pienso que para poder instalarlos el archivo hba_conf debería estar en su forma inicial
sin haberlo modificado. El problema es que cuando abro el archivo me sale en blanco.

Quisiera saber si puedo borrar todos los archivos del postgresql y descargarlos nuevamente,
porque cuando los desinstalo siguen hay y entonces el problema con el hba_conf persiste

Gracias por su ayuda

Imagen de alaverde
+1
0
-1

si lo que quiere es des-instalar completamente lo que necesita es el "gestor de paquetes synaptics" si no viene instalado por defecto, lo hará con facilidad en el centro de software, abre el programa, pone el nombre de lo que quiere des-instalar, selecciónelo, click derecho, marcar para des-instalar completamente y listo, debe cerciorarse de seleccionar todos los paquetes instalados que tengan que ver con el programa que busca. si se soluciona, editelo en el nombre.

+1
0
-1

Alexander Laverde

Imagen de joapenaca
+1
0
-1

Gracias por la información.
Al final decidí reinstalar el Ubuntu 12.04. En una próxima
ya se que puedo usar el synaptics

+1
0
-1