`GLIBCXX_3.4.15' not found

Imagen de apa
apa
0 puntos

Hola, estoy intentando correr Fritzing ( http://fritzing.org ) en mi ubuntu 10.04 y tengo este error al ejecutar ./Fritzing en la terminal, alguien sabe que podría hacer con esto?

desde ya muchas gracias y saludos

Agustin


alumno@Usuario:~/Escritorio/fritzing-0.7.12b.linux.i386$ ./Fritzing
/home/alumno/Escritorio/fritzing-0.7.12b.linux.i386/lib/Fritzing: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /home/alumno/Escritorio/fritzing-0.7.12b.linux.i386/lib/Fritzing)
/home/alumno/Escritorio/fritzing-0.7.12b.linux.i386/lib/Fritzing: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.15' not found (required by /home/alumno/Escritorio/fritzing-0.7.12b.linux.i386/lib/libQtGui.so.4)
/home/alumno/Escritorio/fritzing-0.7.12b.linux.i386/lib/Fritzing: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.15' not found (required by /home/alumno/Escritorio/fritzing-0.7.12b.linux.i386/lib/libQtNetwork.so.4)
/home/alumno/Escritorio/fritzing-0.7.12b.linux.i386/lib/Fritzing: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.15' not found (required by /home/alumno/Escritorio/fritzing-0.7.12b.linux.i386/lib/libQtCore.so.4)
alumno@Usuario:~/Escritorio/fritzing-0.7.12b.linux.i386$ sudo cp gcc/build/x86_64-unknown-linux-gnu/libstdc++-v3/src/.libs/libstdc++.so.6.0.15 /usr/lib/

Imagen de gato2707
+1
0
-1

Lo ideal siempre es hacerlo desde los repositorios de Ubuntu

Si lo hiciste descargando de algún otro lugar.

1) Elimínalo completamente
2) Usando el Centro de Software instala tu programa o bien desde una terminal:

sudo apt-get update && sudo apt-get install fritzing

Ese programa está disponible en los repositorios

https://apps.ubuntu.com/cat/search/?q=fritzing&op=

+1
0
-1

Saludos desde México
Mi Web: El Gato con Linux

Imagen de cuentos
+1
0
-1

ubuntu "paquetes".
Pero no esta en lucid (10.04)
precise (12.04LTS) si esta y para arriba.
http://packages.ubuntu.com/search?suite=lucid&searchon=names&keywords=Fr...

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de apa
+1
0
-1

Hola, gracias por responder, no es un software "instalable" en realidad es un ejecutable el que corre el programa. Te descargás un .tar que viene con el ejecutable ya compilado y lo corrés con doble click o desde terminal con ./
el paquete no esta para descargar desde repositorios en 10.04. Además cuando quiero instalar esas librerías (glibc / libstdc++) me dice que los paquetes no están y en synaptic no los puedo encontrar. Por otro lado, en /usr/lib encuentro un link y un archivo libstdc++

el comando ls -l /usr/lib | grep libstd* me devuelve esto:


alumno@Usuario:~$ ls -l /usr/lib | grep libstd*
lrwxrwxrwx 1 root root 34 2010-07-16 17:19 libstartup-notification-1.so.0 -> libstartup-notification-1.so.0.0.0
-rw-r--r-- 1 root root 30184 2010-03-07 02:30 libstartup-notification-1.so.0.0.0
lrwxrwxrwx 1 root root 19 2010-07-16 17:19 libstdc++.so.6 -> libstdc++.so.6.0.13
-rw-r--r-- 1 root root 975088 2010-03-26 19:43 libstdc++.so.6.0.13
-rw-r--r-- 1 root root 812064 2009-11-06 08:40 libstlport_gcc.so.4.6

alguna idea al respecto?

muchas gracias y saludos!

+1
0
-1
Imagen de cuentos
+1
0
-1

---gato2707, es que es preferible instalarlo desde los repositorios y ya no tienes problemas de dependencias.
pero al parecer no esta en 10.04 solamente en 12.04 y superior.
ahora si lo quieres en 10.04, al descomprimirlo debe traer un readme, o algo parecido con las instrucciones, o los requisitos del programa.

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de apa
+1
0
-1

en el readme dice:
----------------------------------------------------------------------
BUILDING FRITZING
This section is mostly for Linux users. Fritzing is built using the Qt Framework,
so build instructions follow the model for Qt applications. The easiest approach
is to download the QT SDK and use the QtCreator IDE. You can also build natively
using the following steps (qmake is a tool supplied by Qt):
qmake
make
make install

Fritzing requires Qt 4.6 and up, and the Qt-sqlite and Qt-jpeg plugins.
----------------------------------------------------------------------

busqué en synaptic y encontré libqt4-sql-sqlite y libqt4-sql-sqlite2
cuando los marco para instalar en ambos me dice:

libqt4-sql-sqlite:
Depende: libqt4-sql pero no va a ser instalado
Depende: libqtcore4 (=4:4.6.2-0ubuntu5) pero se va a instalar 4:4.6.2-0ubuntu5.1

no es la primera ves que me pasa con algún paquete, será un problema de otro tipo?

gracias!

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

Como PPAs, si quieres tener el sistema en orden deshazte de ellos.

Los repositorios externos los debes tener sólo para software que no exista en los repositorios de Ubuntu.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de apa
+1
0
-1

Hola, gracias por la aclaración, en synaptic me figuran estos repositorios:

achive.canonical.com/ubuntu lucid partner
http://debian.fusioninventory.org/debian/ stable main
http://archive.canonical.com/ubuntu lucid partner
http://linux.dropbox.com/ubuntu main

debería agregar o sacar alguno?

gracias y saludos

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

...'debes deshacerte de los repositorios extras'?.

fijate también en /etc/apt/sources.list.d/ si tienes archivos dentro.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de apa
+1
0
-1

gracias por contestar, en realidad no infiero nada, por eso pregunto,
en /etc/apt/sources.list.d me aparecen estos:


alumno@Usuario:/etc/apt/sources.list.d$ ls
dropbox.list lucid-partner.list medibuntu.list
dropbox.list.save lucid-partner.list.save medibuntu.list.save

alguien tiene alguna idea de que es lo que sería mejor hacer?

gracias y saludos!

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

por que tanto el compañero cuentos y yo ya te dijimos que es lo mejor que hay que hacer. Tienes 2 opciones.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de apa
+1
0
-1

con respecto a lo de cuentos: ese paquete no figura en mi distribución, así que infiero que esa opción está descartada, ya que en el README dice algo que no puedo hacer tampoco porque synaptic no me permite instalar los programas que necesito.

con respecto a lo de JoseLuis 1320: posteo lo que me devuelve la terminal porque no se cuales son los repositorios extras, por eso pregunto. Sino no preguntaría. No entiendo que repositorios extra tengo que borrar para que funcione,

gracias y saludos.

+1
0
-1
Imagen de Goyo
+1
0
-1

Para ejecutar ese programa necesitas una versión más reciente de Ubuntu (al menos 12.04 según creo) o compilarlo tú mismo. La advertencia en la página de descarga de que los binarios para Linux han sido construidos y probados en Ubuntu 10.04.2 parece estar obsoleta. Tal vez una versión más antigua del programa sí funcione.

Lo que debes hacer con los repositorios extra depende de quién los haya añadido y por qué razón.

En general yo diría que lo que sería mejor hacer es actualizar a una versión de Ubuntu más reciente, salvo que si todavía estás usando la 10.04 supongo que será por una buena razón que yo no conozco. Así que no sé qué será mejor hacer.

+1
0
-1