Problema instalación mysql-server

Imagen de qmjhdfg
0 puntos

Estoy intentando instalar el paquete de mysql-server en Ubuntu 12.10, pero estoy teniendo problemas.

Si hago esto:

sudo apt-get purge mysql*
sudo apt-get clean
sudo apt-get autoclean
sudo apt-get autoremove
sudo apt-get install mysql-server

se descarga los paquetes pero cuando los configura muestra lo siguiente:

Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Se instalarán los siguientes paquetes extras:
  libdbd-mysql-perl libmysqlclient18 mysql-client-5.5 mysql-client-core-5.5 mysql-common mysql-server-5.5 mysql-server-core-5.5
Paquetes sugeridos:
  tinyca mailx
Se instalarán los siguientes paquetes NUEVOS:
  libdbd-mysql-perl libmysqlclient18 mysql-client-5.5 mysql-client-core-5.5 mysql-common mysql-server mysql-server-5.5 mysql-server-core-5.5
0 actualizados, 8 se instalarán, 0 para eliminar y 0 no actualizados.
Se necesita descargar 26,1 MB de archivos.
Se utilizarán 94,2 MB de espacio de disco adicional después de esta operación.
¿Quiere continuar [S/n]? s
Des:1 http://es.archive.ubuntu.com/ubuntu/ quantal/main mysql-common all 5.5.27-0ubuntu2 [13,7 kB]
Des:2 http://es.archive.ubuntu.com/ubuntu/ quantal/main libmysqlclient18 amd64 5.5.27-0ubuntu2 [949 kB]
Des:3 http://es.archive.ubuntu.com/ubuntu/ quantal/main libdbd-mysql-perl amd64 4.021-1 [97,7 kB]
Des:4 http://es.archive.ubuntu.com/ubuntu/ quantal/main mysql-client-core-5.5 amd64 5.5.27-0ubuntu2 [1.922 kB]
Des:5 http://es.archive.ubuntu.com/ubuntu/ quantal/main mysql-client-5.5 amd64 5.5.27-0ubuntu2 [8.283 kB]                                             
Des:6 http://es.archive.ubuntu.com/ubuntu/ quantal/main mysql-server-core-5.5 amd64 5.5.27-0ubuntu2 [5.970 kB]                                        
Des:7 http://es.archive.ubuntu.com/ubuntu/ quantal/main mysql-server-5.5 amd64 5.5.27-0ubuntu2 [8.832 kB]                                             
Des:8 http://es.archive.ubuntu.com/ubuntu/ quantal/main mysql-server all 5.5.27-0ubuntu2 [11,8 kB]                                                    
Descargados 26,1 MB en 19seg. (1.312 kB/s)                                                                                                            
Preconfigurando paquetes ...
Seleccionando paquete mysql-common previamente no seleccionado
(Leyendo la base de datos ... 296787 ficheros o directorios instalados actualmente.)
Desempaquetando mysql-common (de .../mysql-common_5.5.27-0ubuntu2_all.deb) ...
Seleccionando paquete libmysqlclient18:amd64 previamente no seleccionado
Desempaquetando libmysqlclient18:amd64 (de .../libmysqlclient18_5.5.27-0ubuntu2_amd64.deb) ...
Seleccionando paquete libdbd-mysql-perl previamente no seleccionado
Desempaquetando libdbd-mysql-perl (de .../libdbd-mysql-perl_4.021-1_amd64.deb) ...
Seleccionando paquete mysql-client-core-5.5 previamente no seleccionado
Desempaquetando mysql-client-core-5.5 (de .../mysql-client-core-5.5_5.5.27-0ubuntu2_amd64.deb) ...
Seleccionando paquete mysql-client-5.5 previamente no seleccionado
Desempaquetando mysql-client-5.5 (de .../mysql-client-5.5_5.5.27-0ubuntu2_amd64.deb) ...
Seleccionando paquete mysql-server-core-5.5 previamente no seleccionado
Desempaquetando mysql-server-core-5.5 (de .../mysql-server-core-5.5_5.5.27-0ubuntu2_amd64.deb) ...
Procesando disparadores para man-db ...
Configurando mysql-common (5.5.27-0ubuntu2) ...
Seleccionando paquete mysql-server-5.5 previamente no seleccionado
(Leyendo la base de datos ... 296968 ficheros o directorios instalados actualmente.)
Desempaquetando mysql-server-5.5 (de .../mysql-server-5.5_5.5.27-0ubuntu2_amd64.deb) ...
Seleccionando paquete mysql-server previamente no seleccionado
Desempaquetando mysql-server (de .../mysql-server_5.5.27-0ubuntu2_all.deb) ...
Procesando disparadores para man-db ...
Procesando disparadores para ureadahead ...
Configurando libmysqlclient18:amd64 (5.5.27-0ubuntu2) ...
Configurando libdbd-mysql-perl (4.021-1) ...
Configurando mysql-client-core-5.5 (5.5.27-0ubuntu2) ...
Configurando mysql-client-5.5 (5.5.27-0ubuntu2) ...
Configurando mysql-server-core-5.5 (5.5.27-0ubuntu2) ...
Configurando mysql-server-5.5 (5.5.27-0ubuntu2) ...
mysql start/running, process 21526
/etc/init.d/mysql: 117: /etc/init.d/mysql: /usr/lib/hal/hal-system-smbios: not found
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: error al procesar mysql-server-5.5 (--configure):
 el subproceso instalado el script post-installation devolvió el código de salida de error 127
dpkg: dependency problems prevent configuration of mysql-server:
 mysql-server depende de mysql-server-5.5; sin embargo:
 El paquete `mysql-server-5.5' no está configurado todavía.

dpkg: error al procesar mysql-server (--configure):
 problemas de dependencias - se deja sin configurar
Procesando disparadores para libc-bin ...
No se escribió un informe «apport» porque el mensaje de error indica que es un mensaje de error asociado a un fallo previo.
                                                                                                                           ldconfig deferred processing now taking place
Procesando disparadores para ureadahead ...
Se encontraron errores al procesar:
 mysql-server-5.5
 mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

Parece que los descarga y extrae bien, pero que tiene algún problema al configurar el paquete mysql-server-5.5, y eso no le deja continuar.

He estado buscando y, aunque he encontrado gente con este problema (o parecido), las soluciones que se les proponían no me han funcionado.

Por ejemplo, una de ellas era instalar primero el paquete mysql-common, luego el mysql-server-5.5 y más tarde el resto de paquetes de mysql-server, pero como digo no me ha funcionado.

¿Sabéis qué puede estar pasando y cómo lo puedo solucionar?

Gracias!

Imagen de Goyo
+1
0
-1

¿MariaDB?

+1
0
-1