Problema al cambiar home de partición (solucionado)

Imagen de dreyesg
0 puntos

Hola Ubunteros:
Tengo un P4 con 4 discos duros y 1 GB de RAM y Ubuntu 12.04 32 bits, en un disco tengo una partición para /home de tipo ext4, otra de SWAPT, y otra NTFS, hace entorno a un mes Ubuntu me daba continuos mensajes de:

“Fallo inminente del disco duro”

Busqué en Google “Cambiar home de partición” me salieron múltiples enlaces, incluido uno de este foro
http://doc.ubuntu-es.org/index.php?title=Mover_home_a_partici%C3%B3n_dis...

Que seguí, cree otra partición en otro disco duro y copie en ella con “ sudo cp –a origen destino” el /home, modifiqué “fstab” para que al reiniciar montase el home que había copiado en la otra partición.

Al reiniciar, sale la pantalla donde se introduce la contraseña, la pongo, me da un mensaje en modo texto, que no me da tiempo a leer y sale otra vez la pantalla donde se pone la contraseña y así indefinidamente.

Sin embargo si pulso CONTROL+ALT+F1 pongo el nombre de usuario y el password y entro en modo texto sin problemas.

¿Cuál puede ser la causa que no pueda entrar en modo grafico, con el home de la nueva partición?, ¿me podríais indicar la secuencia de ejecución desde que se inicia el GRUB2 hasta después de colocar el password, en modo gráfico?, Y comenzar a utilizar el sistema, para intentar localizar la causa del problema.

Aquí tenéis mi “fstab”
……………………FSTAB……………………………
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
#
proc /proc proc nodev,noexec,nosuid 0 0
# / was on /dev/sda5 during installation
UUID=2608c091-47f7-46a0-99cc-408744c1a9de / ext3 errors=remount-ro 0 1
# /boot was on /dev/sda3 during installation
UUID=87b89544-afa5-4643-ba16-07db050ad6f7 /boot reiserfs notail 0 2
# /home was on /dev/sdc5 during installation
UUID=243576f4-daec-45a8-beba-911276851f02 /home ext4 defaults 0 2
# /home esta en /dev/sdd3
# /dev/sdd3 /home ext4 defaults 0 2
# UUID=da25ce9c-6a96-4495-aeb8-e0ad8e7fe853 /home ext4 defaults 0 2
# swap was on /dev/sdc2 during installation
# UUID=4079f71d-9070-48d5-8e8c-b213457c99f0 none swap sw 0 0
# swap esta en /dev/sdd2 UUID=160c7de2-da41-4f56-95a9-53f553f56d6b none swap sw 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0

….............BLKID ..........................................................
/dev/sda1: UUID="11932EB467CD73F1" TYPE="ntfs"
/dev/sda2: UUID="8626-E252" TYPE="vfat"
/dev/sda3: UUID="87b89544-afa5-4643-ba16-07db050ad6f7" TYPE="reiserfs"
/dev/sda5: UUID="2608c091-47f7-46a0-99cc-408744c1a9de" TYPE="ext3"
/dev/sdb1: UUID="c5beb2be-b625-41c6-a467-f5da02f203cc" SEC_TYPE="ext2" TYPE="ext3"
/dev/sdc1: UUID="9E2CAB7D90B4B001" TYPE="ntfs"
/dev/sdc2: UUID="4079f71d-9070-48d5-8e8c-b213457c99f0" TYPE="swap"
/dev/sdc5: UUID="243576f4-daec-45a8-beba-911276851f02" TYPE="ext4"
/dev/sdd1: UUID="1061edbe-b4e6-4780-bf4c-b83849efbd74" TYPE="ext4"
/dev/sdd2: LABEL="swap" UUID="160c7de2-da41-4f56-95a9-53f553f56d6b" TYPE="swap"
/dev/sdd3: UUID="da25ce9c-6a96-4495-aeb8-e0ad8e7fe853" TYPE="ext4"

Imagen de Gabriel_M
+1
0
-1

... el problema sea debido a que la orden para copiar es:

sudo su
cd /home
cp -ax . /alnuevohome
+1
0
-1
Imagen de cuentos
+1
0
-1

Que partición de home, quieres que sea la buena. la que esta activa o sea la sdc5.
Y alguna razón para desactivar la swap. Tienes dos y ninguna montada.
Y por ultimo, se ve que tienes 4 discos, y al parecer un verdadero desastre en las particiones, si solo tienes dos sistemas, win y ubuntu. O algún motivo por tener estas particiones.
En cuanto a la home, posiblemente te falto poner tu home, como propietario.
Inicia como tices en la terminal, y ejecuta este comando, y pon lo que te sale aquí.
ls -l /home
(te lo deletreo: ele ese menos ele)

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de rioport
+1
0
-1

Cuando entras en modo texto ¿puedes ver tus archivos ( ls -l )? Si la respuesta es sí, pega el contenido del archivo .xsession-errors. Debido a que puede ser mucho texto es mejor que lo pegues en http://paste.ubuntu.com/ .

De paso también pega la salida del comando df.

¿Cuál es el disco que falla, sdd?

+1
0
-1

-- GC --

Imagen de dreyesg
+1
0
-1

Puedo ver (ls -l) este es el contenido de .xsession-errors

http://paste.ubuntu.com/5873450/

+1
0
-1
Imagen de dreyesg
+1
0
-1

Perdon, me he equivocado al usar paste bin, este es cl completo
http://paste.ubuntu.com/5873497/

+1
0
-1
Imagen de cuentos
+1
0
-1

Tu puedes:

Puedo ver (ls -l) este es el contenido de .xsession-errors

Pero nosotros no tenemos bola de cristal magica. Y no vemos nada.

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de dreyesg
+1
0
-1

ls -l

total 20
drwxr-xr-x 40 david david 4096 jul 14 19:20 david
drwx------ 2 root root 16384 oct 30 2010 lost+found

salida de "df"

S.ficheros 1K-bloques Usados Disponibles Uso% Montado en
/dev/sda5 43761984 6436384 35102608 16% /
udev 504868 12 504856 1% /dev
tmpfs 204872 852 204020 1% /run
none 5120 0 5120 0% /run/lock
none 512176 176 512000 1% /run/shm
/dev/sda3 1052184 367016 685168 35% /boot
/dev/sdd3 38434288 3210048 33271884 9% /home
/dev/sr0 718124 718124 0 100% /media/Ubuntu 12.04 LTS i386
/dev/sdc5 106364508 37298000 63663452 37% /media/243576f4-daec-45a8-beba-911276851f02

+1
0
-1
Imagen de cuentos
+1
0
-1

a lo primero que comentaste era de que
/dev/sda5 era la /home,
y en el listado que das la partición esta esta en /media24.....
Y el usuario con el que estas es david, o es otro.

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de dreyesg
+1
0
-1

Hola Ubunteros:
El problema que tenia de que no podía entrar cuando la partición “/home” se encontraba en “/dev/sdd3” se ha solucionado sin saber la causa del error que me daba con anterioridad, después de copiar en múltiples ocasiones el contenido de “/dev/sdc5” a “/dev/sdd3” y modificar el “fstab” para que la carpeta “/home” la montase con “/dev/sdd3” se ha montado correctamente y he entrado en modo grafico sin ningún problema, y siempre he copiado el contenido de una partición en otra con la misma orden/comando.

El motivo de cambiar el “/home” de disco duro era que Ubuntu durante unos días me estuvo dando continuos mensajes de “Fallo inminente del disco duro sdc”

Desde que he estado intentando cambiar el home de disco duro ha dejado de darme ese mensaje, ¿podría ser un fallo de Ubuntu ese mensaje? O ¿creéis que ese disco duro va a fallar en breve?

El disco sdc tiene 7 u 8 años, aquí me daba Ubuntu el mensaje de erros, paro ahora no
El disco sdd tiene casi 3 años

¿Dónde me aconsejáis dejar el /home en sdc5 o en sdd3?

Un saludo
David

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Si funciona así, no toques nada más.

+1
0
-1
Imagen de dreyesg
+1
0
-1

Hola Ubunteros:
Ya he descubierto la causa del fallo al montar ‘/dev/sdd3’ como ‘/home’, el fallo era que yo ejecuté el siguiente orden una sola vez.

Sudo blkid > lista_uuid.txt

Y por lo visto el “blkid” produjo un “uuid” erróneo para la partición “/dev/sdd3” y claro así fallaba al intentar montar esa partición, ha sido volver a ejecutar el “blkid” y copiar el nuevo “uuid” en el “fstab” y problema solucionado.

El disco que tenía inicialmente el home era “/dev/sdc5” y durante varios días me daba un mensaje de:
“Fallo inminente del disco /dev/sdc”
Hace entorno a 10 días que ha dejado de dar ese mensaje, he ejecutado el siguiente comando:
Smartctl –H /dev/sdc

Y he obtenido el siguiente resultado
smartctl 5.41 2011-06-09 r3365 [i686-linux-3.2.0-49-generic-pae] (local build)
Copyright (C) 2002-11 by Bruce Allen, http://smartmontools.sourceforge.net

=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED
Please note the following marginal Attributes:
ID# ATTRIBUTE_NAME FLAG VALUE WORST THRESH TYPE UPDATED WHEN_FAILED RAW_VALUE
10 Spin_Retry_Count 0x0013 100 091 097 Pre-fail Always In_the_past 0

Pero no se muy bien interpretar el resultado:
“Tipo” dice “pre-fallo”
“Cuando falló” dice “en el pasado”

Esto que quiere decir “Que el disco fallo en el pasado, pero que actualmente ha dejado de fallar y está en perfectas condiciones”

¿Que grado de confianza os merece ese disco?, teniendo en cuenta que tiene 7 u 8 años

+1
0
-1