PC no arranca-fallo en grub. (solucionado)

Imagen de fmoreno94
0 puntos

Bueno, abro este hilo porque he instalado hoy kubuntu junto a windows 7 en mi pc y resulta que no me arranca.
Como comenté en un hilo llamado cambio de SO, me he puesto con la instalación, y se ve que algo he hecho mal, pues al arrancar me da el mensaje:

error: unknown filesystem
grub rescue>

Os explico lo que hecho:

La siguiente imagen era mi tabla de particiones antes de la instalación:

http://img856.imageshack.us/img856/4563/wyzv.jpg

Bueno, de las cuatro particiones que se ven en la imagen, borré la de 100gb y las 98mb (ubuntu y la otra la swap).
Se me quedaron unos 100gb de espacio libre, cogí una nueva partición de 4gb, para el swap, sin punto de montaje y seleccionando como área de intercambio.

El resto (unos 96gb) con punto de montaje /, y de di a que formateara esta ultima.
En una opción que me daba, escogí situarlas ambas al principio.

Parta el bootloader escogí /dev/sda

Éso es todo.

A ver si alguien me puede ayudar.

Gracias de antemano.

Imagen de fmoreno94
+1
0
-1

Adjunto una iagen de como ha quedado la tabla de particiones

http://img708.imageshack.us/img708/4320/4to9.png

A ver si me podeis ayudar.

Gracias.

+1
0
-1
Imagen de .doc
+1
0
-1

yo no se si windows debe estar en la primera partición primaria...

De todas formas, prueba reinstalar el Grub, hay mucha info al respecto (lo puedes hacer desde un LiveCD de Ubuntu, o mediante la herramienta 'Supergrub2', para arrancar tu Ubuntu y luego hacer, desde consola, un
sudo update-grub && sudo grub-install /dev/sda

+1
0
-1
Imagen de fmoreno94
+1
0
-1

Creo que he podido solucionarlo, os explico lo que he hecho por si a alguien le sirve de ayuda.

Con un usb de instalación de kubuntu he accedido a la opción de probar el SO.
Desde ahí he descargado la herramienta llamada boot repair, con los siguientes comandos:

sudo add-apt-repository ppa:yannubuntu/boot-repair

sudo apt-get update

sudo apt-get install boot-repair

Accedéis a ella, y a partir de ahí ha sido muy intuitivo, a mí me ha funcionado la opción de "recuperación recomendada", la opción fácil por así decirlo, que te guía por todo el proceso, además en español.

Espero que le ayude a alguien con los mismos problemas.

Eso sí, me ha quedado una última duda, en el grub, me das opciones para el arranque de windows, dev/sda3 y dev/sda4, ¿puedo acceder libremente con cualquiera de las dos?

Saludos.

+1
0
-1
Imagen de .doc
+1
0
-1

eso es cuestión de que lo pruebes. Al parecer en una partición tienes el Windows y en otra (la 'booteable'), pequeña. de 100 MB, el bootloader. Yo ya no me acuerdo de Windows, y no se si eso del bootloader es necesario, o no, o depende de la versión de Windows que tengas para tener que usarlo (desde luego, en WinXP, no eran necesarias esas historias del bootloader, y tal)

+1
0
-1
Imagen de fmoreno94
+1
0
-1

Hola, he porbado con ambos arranques y en los dos parece eue accede a windows 7 sin problemas, mi duda es si es más recomendable una u otra, o si alguna puede acabar dando problemas.

Saludos.

+1
0
-1