Fallo al instalar las actualizaciones del Gestor de Ubuntu 12.04 (Solucionado)

Imagen de UnoNuevo
0 puntos

Hoy al encender el ordenador he intentado instalar las actualizaciones, pero tras descargarlas, y casi al final de todo me dice que ha habido un error, que las actualizaciones se han descargado pero no se han instalado. Más tarde este mismo día, he intentado instalarlas nueamente (a ver si sonaba la flauta) pero no ha habido suerte. ¿Cual puede ser el problema, y como lo soluciono?

Imagen de cuentos
+1
0
-1

Un ppa que te este dando problemas de dependencias....
Ejecuta estos dos comando en la terminal, pero como la salida es grande se pide que lo pongas en paste.bin o sea aquí: http://paste.ubuntu.com/
y pones la liga aquí para ver lo que te sale. los camandos son:
sudo apt-get update
sudo apt-get upgrade
Editado.
Trata de editar el titulo del hilo, ya que de acuerdo a las normas debe ser un titulo que exprese el problema, y no problema, (o sea palabras como problema, ayuda, etc,)

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de Jose Luis 1320
+1
0
-1

He cambiado el título a algo más descriptivo por ti, lo más que se pudo, puesto que la descripción que das del tema sigue siendo muy pobre...

Por favor te encargo que edites tu hilo, y expliques con más detalle tu problema ¿Agregaste un PPA? ¿Que "error" te sale al actualizar? ¿Como actualizas? dado a que de otra manera, tu hilo se tendría que ir a la papelera.

Saludos!.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de UnoNuevo
+1
0
-1

Antes de nada, gracias por vuestra ayuda y comprensión.
Y perdón por los errores (la verdad, no estoy muy puesto en esto de Ubuntu, ni en informática).
He probado a introducir esas dos lineas de comandos en la terminal. Al principio pareció funcionar y me preguntó si quería continuar, pero al responder que sí, poco después salió el siguiente mensaje:

Configurando apt (0.8.16~exp12ubuntu10.11) ...
ERROR: Can't find the archive-keyring
Is the ubuntu-keyring package installed?
dpkg: error al procesar apt (--configure):
el subproceso instalado el script post-installation devolvió el código de salida de error 1
Se encontraron errores al procesar:

¿Alguna sugerencia, por favor?

+1
0
-1
Imagen de cuentos
+1
0
-1

bien. como te comete pon todo lo que te sale en http://paste.ubuntu.com/
Y el sitio te da un liga y pones esta aquí.
o bien intenta a instalar el paquete que te pide, (raro que no lo tengas). en la terminal ejecuta:
sudo apt-get update ubuntu-keyring

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de UnoNuevo
+1
0
-1

He intentado ejecutar la 2ª opción: sudo apt-get update ubuntu-keyring. Esta es la respuesta:

E: El comando de actualización no toma argumentos

En cuanto al enlace que me das: ¿Qué es lo que debo de pegar en él? ¿Todo el texto que me salga en Terminal al intentar ejecutar los comandos?

+1
0
-1
Imagen de cuentos
+1
0
-1

lo correcto es:
sudo apt-get install ubuntu-keyring

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de UnoNuevo
+1
0
-1

Gracias por la corrección, pero da más o menos la misma respuesta

ERROR: Can't find the archive-keyring
Is the ubuntu-keyring package installed?
dpkg: error al procesar apt (--configure):
el subproceso instalado el script post-installation devolvió el código de salida de error 1
No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
Se encontraron errores al procesar:
apt
E: Sub-process /usr/bin/dpkg returned an error code (1)

Según un amigo (mucho más puesto en estas cosas que yo) al que he consultado, la única solución sería actualizar ubuntu con un disco de arranque, ya que al parecer, ese error no me permite ni actualizar ni instalar aplicaciones nuevas.

+1
0
-1
Imagen de UnoNuevo
+1
0
-1

Al final logré solucionar el problema, aunque tuve que recurrir a la solución más drástica: reinstalar Ubunto. Gracias por toda la ayuda, aunque ahora tengo una duda: aunque el problema al final está solucionado, ¿se considera el haberlo reinstalado como una solución? Lo pregunto por lo de añadir el (Solucionado) al 1º hilo.

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

Igual y tenías el sistema de dependencias ya totalmente destruido y no habría otra forma de solucionar el problema, más que reinstalando.

Hay que cuidar mucho de usar PPAs y repositorios externos (como Getdeb) y usarlos solo para programas que no estén presentes en los repositorios main, universe y multiverse de Ubuntu.

Y cuidar también que programas instalas desde código fuente, también pueden crear problemas.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro