(SOLUCIONADO) Instalar Plugin de Java para Google Chrome

Imagen de Joa Lencinas
0 puntos

Hola!
Tengo un problema con el plugin de java, y es que no lo puedo instalar. Tengo ubuntu 13.04
El fichero es un .tar.gz, que lo saque de la pagina: http://java.com/es/download/manual.jsp?locale=es
El tema es que lo baje, y trate de instalarlo como se instala la mayoria de los .tar.gz, que es haciendo lo de

./configure
make
make install

pero me tira el siguiente error:

joa@Joa:~/java7/jre1.7.0_25$ ./configure
bash: ./configure: No existe el archivo o el directorio

y si lo intento como superusuario,

joa@Joa:~/java7/jre1.7.0_25$ sudo ./configure
sudo: ./configure: orden no encontrada

ahora bien, tambien intente abrir el fichero configure, o sea intente esto:

joa@Joa:~/java7/jre1.7.0_25$ sh configure
sh: 0: Can't open configure

claramente es porque no hay ningun configure, pero en ese caso no tengo idea de como se instala esto..
el java que estoy instalando es el 7u25, si lo quieren ver esta en la pagina, es el que dice Linux. Para colmo, en las instrucciones de la pagina dice "desempaquete el tarball e instale java", y muestra el siguiente comando:

tar zxvf jre-7u7-linux-i586.tar.gz

que tambien lo intente y lo unico que hace es desempaquetar el tarball y nada mas..
Por favor que alguien me de una mano porque necesito el plugin para ver peliculas online en cuevana, y tuve que usar Winbug para ver una peli, y no quisiera hacerlo nunca mas.. Si tengo que cambiarme a firefox no hay problema.

Gracias!!!

El problema se soluciona instalando el paquete icedtea-plugin directamente de los repositorios:

sudo aptitude install icedtea-plugin

Imagen de Jose Luis 1320
+1
+1
-1

En lugar de usar Chrome, yo uso Chromium (que diferencia hay entre estos 2 navegadores, muy simples, que uno es closed source y otro es open source y el color del icono).

En lugar de instalar Java de esa manera, yo instalo el paquete icedtea-plugin.

Y cuevana... yo no se pero igual y terminas regalando tu información a 1000 trackers y adios privacidad...

+1
+1
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de Joa Lencinas
+1
0
-1

Gracias hermano, el paquete icedtea-plugin que me recomendaste me funciono a la perfeccion!! Y por otro lado, averigüe sobre chromium y lo probe, es muy parecido pero anda ligeramente mas rapido! Gracias!!

+1
0
-1
Imagen de Alcruz
+1
+1
-1

No es para compilar, si te descargas el jdk-7u25-linux-i586.tar.gz te puedo dar los pasos exactos , cuando lo descargues, arrástralo al terminal y muestra lo que te aparece en este, es para saber la ruta exacta en donde lo has descargado
http://www.oracle.com/technetwork/es/java/javase/downloads/jdk7-download...

+1
+1
-1
Imagen de Joa Lencinas
+1
0
-1

No se si es lo mismo el Java Development Kit o el JRE que supongo que debe significar Java Runtime Enviroment. Creo tener el JDK, porque he programado en java y nunca tuve problemas. De todas formas descargue el jre en
/home/joa/Descargas

+1
0
-1
Imagen de Joa Lencinas
+1
0
-1

He solucionado el problema del plugin, instalando el paquete icedtea-plugin, pero de todas maneras es muy flojo por parte de oracle no dar instrucciones detalladas de como instalar su software, pero supongo que es parte de las "dificultades" de linux. Gracias amigo!!

+1
0
-1
Imagen de Alcruz
+1
+1
-1

Si aún estás interesado en instalar el JRE y los plugins tanto a FF como a Google-CHrome, sigue estos pasos
Abre un terminal y pones
gedit $HOME/Descargas/jre7
se abrirá un archivo de texto vacío de nombre jre7 y allí pones lo siguiente

#!/bin/sh
sudo tar zxvf jre-7u7-linux-i586.tar.gz -C /usr/lib/jvm/
sudo update-alternatives --install /usr/bin/java java /usr/lib/jvm/jre1.7.0_7/bin/java 2700
sudo update-alternatives --config java
sudo ln -fs /usr/lib/jvm/jre1.7.0_7/lib/i386/libnpjp2.so /usr/lib/mozilla/plugins
sudo mkdir /opt/google/chrome/plugins
sudo ln -fs /usr/lib/jvm/jre1.7.0_7/lib/i386/libnpjp2.so /opt/google/chrome/plugins

guardas, cierras y cierras terminal
abre itro terminal y pones
cd $HOME/Descargas
bash jre7
eso seróa todo, solo agrego que durante el proceso vas a tener que elegir manulmente la versión de Java que quieres que sea la activa.

+1
+1
-1