Krita no instala y no pude hacer una actualizacion parcial por PPAs que agruegé.

Imagen de As de picas
0 puntos

Hola gente,
tuve un problema tras una actualización parcial que me hizo esto con Krita y ahora no me quiere volver a instalar el programa pues dice que hay paquetes rotos o que le faltan.
Intento en Synaptic y me dice que depende de krita-data pero que no va a ser instalado, luego instalo primero krita-data y cuando le doy a Krita, me dice que para instalarlo ha de ser eliminado krita-data, pero aún así al final no me hace nada con la excusa de que depende de krita-data y que tiene "dependencias no resolubles".

Cuando lo intento desde Centro de software de Ubuntu, me sale esto:

Las dependencias del paquete no se pueden resolver

Este error podría deberse a que se necesitan paquetes de software adicionales que faltan o que no son instalables. También podría ser un conflicto entre paquetes de software que no pueden instalarse juntos.

Detalles:
Los siguientes paquetes tienen dependencias incumplidas:

krita: Depends: calligra-libs (= 1:2.6.1-0ubuntu5~ubuntu12.04.2~ppa2) pero 1:2.6.1-0ubuntu5~ubuntu12.04.2~ppa2 no está instalado
Depends: libgcc1 (>= 1:4.1.1) pero 1:4.6.3-1ubuntu5 no está instalado
Depends: libqt4-opengl (>= 4:4.5.3) pero 4:4.8.2+dfsg-2ubuntu1~precise1~ppa3 no está instalado
Depends: libqt4-svg (>= 4:4.5.3) pero 4:4.8.2+dfsg-2ubuntu1~precise1~ppa3 no está instalado
Depends: libqt4-xml (>= 4:4.5.3) pero 4:4.8.2+dfsg-2ubuntu1~precise1~ppa3 no está instalado
Depends: libqtcore4 (>= 4:4.8.0) pero 4:4.8.2+dfsg-2ubuntu1~precise1~ppa3 no está instalado
Depends: libqtgui4 (>= 4:4.8.0) pero 4:4.8.2+dfsg-2ubuntu1~precise1~ppa3 no está instalado
Depends: krita-data (>= 1:2.6.1-0ubuntu5~ubuntu12.04.2~ppa2) pero 1:2.7.0-0ubuntu1~ubuntu12.04~ppa2 no está instalado

¿Alguien me puede aclarar como solucionar esto?
¿Debo volver a instalar todo eso o además hacerle algo más antes?

Imagen de cuentos
+1
0
-1

con dependencias, no es que te falte un programa, Lo que te falta es la versión del programa.
Y esto suele ser por un ppa.
Mientras no se resuelvan las dependencias, difícilmente podrás instalar algo.
También habría que ver si actualizaste de una versión anterior de ubuntu, con estos ppa.
Lo que puedes hacer es des-instalar todos los ppa, hacer una actualización para ver si ya esta el sistema de dependencias bien. Y luego instalar un ppa, los mínimos que se puedan para que no rompan las dependencias. La recomendación es solo ppa de programas que no estén en los repositorios.
Para borrar los ppa mira aquí:
http://diversidadyunpocodetodo.blogspot.mx/2013/02/ppa-purge-eliminar-ag...

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de Jose Luis 1320
+1
0
-1

Solo por esta ocasion he editado el título a algo más descriptivo... la próxima vez que pongas en tu pregunta un título ambiguo (problemas con X) es un hilo que se irá a la papelera directamente.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro