(solucionado)particion conveniente y memoria insuficiente

Imagen de nmaikol
0 puntos

Hola a todos!!
Voy a empezar disculpándome. Sé que quizás existe algún comentario acerca de mi problema pero he leído pocos que no me han ayudado.
Mi problema es el siguiente
Soy usuario de ubuntu linux desde ,,,bueno, desde que estoy en este foro. El primero fue el ub12,04
y ahora el 13.04 y he tenido muy pocos problemas con el 1ro y muy muchos, muchísimos con este último.
Un problema constante es el mensaje de memoria insuficiente en casi todo lo que hago. Estoy sin poder abrir unos tiff esta mañana. El visor de imáagenes me dice No se pudo cargar la imagen «003.tif». No hay memoria suficiente para abrir el archivo TIFF. A veces aparece lo del “eog” y que no puedo mandar el informe de fallos a los desarrolladores, el shotwell me apareció el mensaje de error, se cerró después y ahora no me muestra la imagen solo un fondo negro.
El gimp se queda colgado y debo resetear muy seguido lo he reinstalado varias veces y nada. Creí que era que agregué muchos pinceles patrones y fuentes pero sigue pasando aún después de las reinstalaciones. (esto además de lo de la memoria. no sé si se relacionan)
Pensé que el problema era la partición que hice al principio (inline:partic.png) y lo sigo pensando xq no sé que puede más puede ser.
Por eso les escribo a ver si pueden recomendarme (aparte de lo que se les ocurra acerca de estos problemas (algo puntual, digo)) una partición más adecuada a lo que tengo …
mi disco rígido es uno solo de 500GB y una memoria RAM de 2GB.
Creo que por ahora es todo. Solo agradecerles a los que puedan responderme y a todos en el foro.
(Por favor que sea lo más gráfico posible...x ej en cada comentario que he leído existe una swap que en mis particiones no existe y dudo de cual es en la mía. supongo que la de 4GB pero no quiero ni tocarla.)
Graciaaaaaaaaaaaas!

Imagen de cuentos
+1
0
-1

Que te dice esto en la terminal. ejecútalo y pon lo que te sale aquí:
swapon
Y que procesador tienes. y tarjeta gráfica. Para la gráfica ejecuta esto e igual pon lo que te sale aquí;
lspci | grep VGA
EDITADO: de una vez vemos cuanta ram tienes, en el sistema:
cat /proc/meminfo | grep MemTotal

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de nmaikol
+1
0
-1

uyyyyyyyyy sabes que me olvide de poner la descripcion de las particiones!! ya lo hago.
igual voy viendo esto que me comentas. gracias!!

+1
0
-1
Imagen de nmaikol
+1
0
-1

ok! usando df-h esto es lo que obtengo
S.ficheros Tamaño Usados Disp Uso% Montado en
/dev/sda3 201G 47G 145G 25% /
none 4,0K 0 4,0K 0% /sys/fs/cgroup
udev 994M 4,0K 994M 1% /dev
tmpfs 202M 832K 201M 1% /run
none 5,0M 0 5,0M 0% /run/lock
none 1009M 80K 1008M 1% /run/shm
none 100M 32K 100M 1% /run/user
/dev/sda1 1,1G 34M 967M 4% /ver
pero en gparted me muestra otras cosas subiré la imagen a un server y subo el link

+1
0
-1
Imagen de nmaikol
+1
0
-1

con swapon no obtengo nada (o, solo la ayuda opciones etc)
con lspci | grep VGA
02:00.0 VGA compatible controller: NVIDIA Corporation G98 [GeForce 8400 GS Rev. 2] (rev a1)
con cat /proc/meminfo | grep MemTotal
MemTotal: 2064528 kB

+1
0
-1
Imagen de nmaikol
+1
0
-1

el link de la imagen como se ve en el gparted http://www.freeimagehosting.net/9xhee

gracias otra vez!!

+1
0
-1
Imagen de cuentos
+1
0
-1

El error que te aparece es que no tienes memoria virtual, la swap.
Desde el mismo gparted trata primero a dar formato a la partición /dev/sda2, como swap.
seleccionas la partición, click derecho del ratón seleccionas:
formatear como:
y aquí seleccionas linux-swap.
Ya que este formateada, se edita el archivo fstab, y se agrega para que la monte en cada inicio.
Vamos por partes, primero esto y luego vemos lo del fstab.

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de Alcruz
+1
0
-1

Abre un terminal y pomes
gedit 111aaa
se abrirá un archivo de texto vacío y en este pegas lo siguiente

#!/bin/sh
sudo rm -Rf /home/*/.local/share/Trash
sudo rm -Rf /root/.local/share/Trash
sudo rm -Rf /.Trash*
 rm -Rf /home/*/.thumbnails/*/*
 rm -Rf /home/*/.wine/dosdevices/c:/windows/temp/*
rm -Rf /home/*/.macromedia/Flash_Player/#SharedObjects/*
sudo rm -Rf /media/*/.Trash*
sudo rm -Rf /media/$SUDO_USER/*/.Trash*
rm -Rf /home/*/.mozilla/firefox/*.default/Cache/*

Gardas, cierras y cierras terminal
en otro terminal ejecuta
bash 111aaa
Con esto harás una limpieza de todas las papelera y otras cosas mas
Si lo anterior no resuelve el problema, reinicia el equipo y selecciona en el grub " memtest" , este es un proceso sin fin que tiene por objeto revisar la ram, estimo que debes dejarlo por lo menos unas 2 horas , en caso que que de un error, solo tienes una solución, cambiar la memoria ram.

+1
0
-1
Imagen de nmaikol
+1
0
-1

gracias a los dos, cuentos y Alcruz!

+1
0
-1
Imagen de nmaikol
+1
0
-1

hola cuentos! ya he formateado la particion como swap (he podido ver las imagenes que antes no!)como edito el fstab etc etc?? gracias

+1
0
-1
Imagen de cuentos
+1
0
-1

formas mas usuales:
a: con el nombre de la partición. de acuerdo ala imagen es; /dev/sda2,
b: es mas recomendable con la uiid. ejecutas en la terminal
sudo blkid
y te arrojara algo como esto:
/dev/sda2: UUID="5f5edab9-8f98-48cb-84dc-7de1327b5591" TYPE="swap"
Te pongo la swap que me sale. Y en este caso la uiid de swap es 5fe..... copias este dato y editas el fstab, (prueba haber si te admite con gedit:

gksudo gedit /etc/fstab

y agregas estas linea:

# swap was on /dev/sda2
UUID=5f5edab9-8f98-48cb-84dc-7de1327b5591 none swap sw 0 0

O bien si es con la primera forma
/dev/sda2 none swap sw 0 0
Toma nota que la uiid es en este caso la mía, aquí va el valor que te de.guardas, y reinicias
y miras si la swap ya esta montada en gparted.

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de nmaikol
+1
0
-1

he seguido paso a paso a cuentos y es correcta la solucion...como puse antes he podido ver las imagenes que antes no podía. no he intentado nada aún con el gimp pero pronto lo haré.

gracias a cuentos y a alcruz!

+1
0
-1
Imagen de nmaikol
+1
0
-1

bueno...usé el gimp y sigue cerrándose y apareciendo el mensaje de memoria insuficiente para mandar el informe a los desarrolladores.

+1
0
-1
Imagen de cuentos
+1
0
-1

swap en uso u bien montada ejecuta este comando y pones lo que te sale.
cat /proc/swaps

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de nmaikol
+1
0
-1

hola cuentos! perdon x la demora...lo que sale es
Filename Type Size Used Priority
/dev/sda2 partition 4621208 87896 -1

+1
0
-1
Imagen de cuentos
+1
0
-1

si estas utilizando la memoria virtual,
al parecer necesitas mas memoria ram. para ver cuanta memoria libre tienes igual en la terminal:
ejecuta, primero sin ningun programa cargado,
cat /proc/meminfo | grep MemFree
y luego ejecuta gimp y vuelve a ejecutar para ver cuanta memoria libre tienes con solo abierto gimp

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de nmaikol
+1
0
-1

hola ota vz!
al principio me daba +1000000 de mem pero he reiniciado y obtengo esto
fsalto@fsalto:~$ cat /proc/meminfo | grep MemFree
MemFree: 745036 kB
estas dos siguientes me da sin abrir absolutamente nada sin hacer nada solo copié y pegué en terminal
fsalto@fsalto:~$ cat /proc/meminfo | grep MemFree
MemFree: 744928 kB
fsalto@fsalto:~$ cat /proc/meminfo | grep MemFree
MemFree: 744904 kB
finalmente abrí gimp y obtengo esto
fsalto@fsalto:~$ cat /proc/meminfo | grep MemFree
MemFree: 132940 kB

+1
0
-1