Actualizar librerías y paquetes en Ubuntu 10.10 Maverick Meerkat en el año 2013 SOLUCIONADO

Imagen de pills
0 puntos

¡ Hola ubunteros !

Buenas como verán lo que quiero es actualizar al máximo posible mis librerias y paquetes, ya que me supone un problema a la hora de instalar programas más actualizados, puesto que estoy con la versión 10.10 maverick meerkat y de la que estoy muy satisfecho y no tengo pensado cambiarla. El caso es que soy un gran personalizador de mi SO y no me va pasarme a las diferentes distros que van saliendo, si bien si quiero ir quedándome con las mejoras que vayan saliendo y vea convenientes para mi equipo ... ¿qué pasos me recomendáis dar para ir en esta línea y así ir actualizando paquetes, librerías y demás sin poder recurrir a los repositorios que como ya sabréis no puedo acceder?

GRACIASSS !!!!! SALUDOSSSS !!!!!

solución :
"solo cambias los repositorios de archive.ubuntu.com a old-releases.ubuntu.com en el archivo /etc/apt/sources.list.

Pero esos repositorios no reciben actualizaciones, es decir están ahí solo para el software que necesites instalar con las mismas versiones del software que había en octubre del 2010.

EL software nuevo que desees instalar, si dependen de librerías cuyas versiones son modernas... debes compilar esas librerías desde código fuente y este código fuente también tienen sus dependencias... es decir tienes un proceso muy largo para hacer funcionar un solo programa.
"

Imagen de cuentos
+1
0
-1

al no tener soporte ya no puedes actualizar programas y librerías, Puedes instalar programas, pero actualizaciones difícil. Para instalar nuevos programas con cambiar tus repositorios que apunten a old......
Pero actualizaciones de seguridad y de programas, no creo posible.
Para estos casos mejor utiliza versiones lts, (largo soporte). como:
12.04 que termina por abril 2017

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de Jose Luis 1320
+1
0
-1

solo cambias los repositorios de archive.ubuntu.com a old-releases.ubuntu.com en el archivo /etc/apt/sources.list.

Pero esos repositorios no reciben actualizaciones, es decir están ahí solo para el software que necesites instalar con las mismas versiones del software que había en octubre del 2010.

EL software nuevo que desees instalar, si dependen de librerías cuyas versiones son modernas... debes compilar esas librerías desde código fuente y este código fuente también tienen sus dependencias... es decir tienes un proceso muy largo para hacer funcionar un solo programa.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de pills
+1
0
-1

Hoooooola

Bueno bueno estoy comprobando vuestras recomendaciones, es decir que he cambiado mi archivo y me ha quedado así :

deb cdrom:[Ubuntu 10.10 _Maverick Meerkat_ - Release i386 (20101007)]/ maverick main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

deb http://old-releases.ubuntu.com/ubuntu/ maverick main restricted
deb-src http://old-releases.ubuntu.com/ubuntu/ maverick main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://old-releases.ubuntu.com/ubuntu/ maverick-updates main restricted
deb-src http://old-releases.ubuntu.com/ubuntu/ maverick-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://old-releases.ubuntu.com/ubuntu/ maverick universe
deb-src http://old-releases.ubuntu.com/ubuntu/ maverick universe
deb http://old-releases.ubuntu.com/ubuntu/ maverick-updates universe
deb-src http://old-releases.ubuntu.com/ubuntu/ maverick-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://old-releases.ubuntu.com/ubuntu/ maverick multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ maverick multiverse
deb http://old-releases.ubuntu.com/ubuntu/ maverick-updates multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ maverick-updates multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://es.archive.ubuntu.com/ubuntu/ maverick-backports main restricted universe multiverse
# deb-src http://es.archive.ubuntu.com/ubuntu/ maverick-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu maverick partner
# deb-src http://archive.canonical.com/ubuntu maverick partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu maverick main
deb-src http://extras.ubuntu.com/ubuntu maverick main

deb http://security.ubuntu.com/ubuntu maverick-security main restricted
deb-src http://security.ubuntu.com/ubuntu maverick-security main restricted
deb http://security.ubuntu.com/ubuntu maverick-security universe
deb-src http://security.ubuntu.com/ubuntu maverick-security universe
deb http://security.ubuntu.com/ubuntu maverick-security multiverse
deb-src http://security.ubuntu.com/ubuntu maverick-security multiverse

Vamos que he cambiado únicamente los que estaba activados (ya sabéis sin el #) y tocando sólo los que empezaban por archive.ubuntu, o sea que aquellos como archive, security, extras y demás no los he tocado

¿de momento va bien la cosa o he de modificar algo más?

+1
0
-1
Imagen de pills
+1
0
-1

Vale pues ya de momento os digo como me ha quedado

he hecho lo siguiente :

~$ sudo apt-get update && upgrade
Ign cdrom://Ubuntu 10.10 _Maverick Meerkat_ - Release i386 (20101007)/ maverick/main Translation-en
Ign cdrom://Ubuntu 10.10 _Maverick Meerkat_ - Release i386 (20101007)/ maverick/main Translation-es
Ign cdrom://Ubuntu 10.10 _Maverick Meerkat_ - Release i386 (20101007)/ maverick/restricted Translation-en
Ign cdrom://Ubuntu 10.10 _Maverick Meerkat_ - Release i386 (20101007)/ maverick/restricted Translation-es
Obj http://old-releases.ubuntu.com maverick Release.gpg
Ign http://old-releases.ubuntu.com/ubuntu/ maverick/main Translation-en
Obj http://old-releases.ubuntu.com/ubuntu/ maverick/main Translation-es
Ign http://old-releases.ubuntu.com/ubuntu/ maverick/multiverse Translation-en
Obj http://old-releases.ubuntu.com/ubuntu/ maverick/multiverse Translation-es
Ign http://old-releases.ubuntu.com/ubuntu/ maverick/restricted Translation-en
Obj http://old-releases.ubuntu.com/ubuntu/ maverick/restricted Translation-es
Ign http://old-releases.ubuntu.com/ubuntu/ maverick/universe Translation-en
Obj http://old-releases.ubuntu.com/ubuntu/ maverick/universe Translation-es
Obj http://old-releases.ubuntu.com maverick-updates Release.gpg
Obj http://dl.google.com stable Release.gpg
Ign http://extras.ubuntu.com maverick Release.gpg
Ign http://extras.ubuntu.com/ubuntu/ maverick/main Translation-en
Ign http://extras.ubuntu.com/ubuntu/ maverick/main Translation-es
Ign http://security.ubuntu.com maverick-security Release.gpg
Ign http://security.ubuntu.com/ubuntu/ maverick-security/main Translation-en
Ign http://security.ubuntu.com/ubuntu/ maverick-security/main Translation-es
Ign http://security.ubuntu.com/ubuntu/ maverick-security/multiverse Translation-en
Ign http://security.ubuntu.com/ubuntu/ maverick-security/multiverse Translation-es
Ign http://security.ubuntu.com/ubuntu/ maverick-security/restricted Translation-en
Ign http://security.ubuntu.com/ubuntu/ maverick-security/restricted Translation-es
Ign http://security.ubuntu.com/ubuntu/ maverick-security/universe Translation-en
Ign http://security.ubuntu.com/ubuntu/ maverick-security/universe Translation-es
Obj http://archive.canonical.com maverick Release.gpg
Ign http://archive.canonical.com/ubuntu/ maverick/partner Translation-en
Ign http://archive.canonical.com/ubuntu/ maverick/partner Translation-es
Ign http://dl.google.com/linux/chrome/deb/ stable/main Translation-en
Ign http://old-releases.ubuntu.com/ubuntu/ maverick-updates/main Translation-en
Obj http://old-releases.ubuntu.com/ubuntu/ maverick-updates/main Translation-es
Ign http://old-releases.ubuntu.com/ubuntu/ maverick-updates/multiverse Translation-en
Obj http://old-releases.ubuntu.com/ubuntu/ maverick-updates/multiverse Translation-es
Ign http://old-releases.ubuntu.com/ubuntu/ maverick-updates/restricted Translation-en
Obj http://old-releases.ubuntu.com/ubuntu/ maverick-updates/restricted Translation-es
Ign http://old-releases.ubuntu.com/ubuntu/ maverick-updates/universe Translation-en
Obj http://old-releases.ubuntu.com/ubuntu/ maverick-updates/universe Translation-es
Obj http://old-releases.ubuntu.com maverick Release
Ign http://extras.ubuntu.com maverick Release
Ign http://dl.google.com/linux/chrome/deb/ stable/main Translation-es
Ign http://security.ubuntu.com maverick-security Release
Obj http://archive.canonical.com maverick Release
Obj http://dl.google.com stable Release
Obj http://old-releases.ubuntu.com maverick-updates Release
Ign http://extras.ubuntu.com maverick/main Sources
Ign http://security.ubuntu.com maverick-security/main Sources
Obj http://archive.canonical.com maverick/partner i386 Packages
Obj http://old-releases.ubuntu.com maverick/main Sources
Obj http://old-releases.ubuntu.com maverick/restricted Sources
Obj http://old-releases.ubuntu.com maverick/universe Sources
Obj http://old-releases.ubuntu.com maverick/multiverse Sources
Obj http://old-releases.ubuntu.com maverick/main i386 Packages
Obj http://old-releases.ubuntu.com maverick/restricted i386 Packages
Obj http://old-releases.ubuntu.com maverick/universe i386 Packages
Obj http://old-releases.ubuntu.com maverick/multiverse i386 Packages
Obj http://dl.google.com stable/main i386 Packages
Ign http://extras.ubuntu.com maverick/main i386 Packages
Ign http://security.ubuntu.com maverick-security/restricted Sources
Ign http://security.ubuntu.com maverick-security/universe Sources
Ign http://security.ubuntu.com maverick-security/multiverse Sources
Ign http://security.ubuntu.com maverick-security/main i386 Packages
Ign http://security.ubuntu.com maverick-security/restricted i386 Packages
Ign http://security.ubuntu.com maverick-security/universe i386 Packages
Ign http://security.ubuntu.com maverick-security/multiverse i386 Packages
Obj http://old-releases.ubuntu.com maverick-updates/main Sources
Obj http://old-releases.ubuntu.com maverick-updates/restricted Sources
Obj http://old-releases.ubuntu.com maverick-updates/universe Sources
Obj http://old-releases.ubuntu.com maverick-updates/multiverse Sources
Obj http://old-releases.ubuntu.com maverick-updates/main i386 Packages
Obj http://old-releases.ubuntu.com maverick-updates/restricted i386 Packages
Obj http://old-releases.ubuntu.com maverick-updates/universe i386 Packages
Ign http://extras.ubuntu.com maverick/main Sources
Ign http://security.ubuntu.com maverick-security/main Sources
Obj http://old-releases.ubuntu.com maverick-updates/multiverse i386 Packages
Ign http://extras.ubuntu.com maverick/main i386 Packages
Ign http://security.ubuntu.com maverick-security/restricted Sources
Ign http://security.ubuntu.com maverick-security/universe Sources
Ign http://security.ubuntu.com maverick-security/multiverse Sources
Ign http://security.ubuntu.com maverick-security/main i386 Packages
Ign http://security.ubuntu.com maverick-security/restricted i386 Packages
Ign http://security.ubuntu.com maverick-security/universe i386 Packages
Err http://extras.ubuntu.com maverick/main Sources
404 Not Found
Ign http://security.ubuntu.com maverick-security/multiverse i386 Packages
Err http://extras.ubuntu.com maverick/main i386 Packages
404 Not Found
Err http://security.ubuntu.com maverick-security/main Sources
404 Not Found [IP: 91.189.92.181 80]
Err http://security.ubuntu.com maverick-security/restricted Sources
404 Not Found [IP: 91.189.92.181 80]
Err http://security.ubuntu.com maverick-security/universe Sources
404 Not Found [IP: 91.189.92.181 80]
Err http://security.ubuntu.com maverick-security/multiverse Sources
404 Not Found [IP: 91.189.92.181 80]
Err http://security.ubuntu.com maverick-security/main i386 Packages
404 Not Found [IP: 91.189.92.181 80]
Err http://security.ubuntu.com maverick-security/restricted i386 Packages
404 Not Found [IP: 91.189.92.181 80]
Err http://security.ubuntu.com maverick-security/universe i386 Packages
404 Not Found [IP: 91.189.92.181 80]
Err http://security.ubuntu.com maverick-security/multiverse i386 Packages
404 Not Found [IP: 91.189.92.181 80]
W: Imposible obtener http://extras.ubuntu.com/ubuntu/dists/maverick/main/source/Sources.gz 404 Not Found

W: Imposible obtener http://security.ubuntu.com/ubuntu/dists/maverick-security/main/source/So... 404 Not Found [IP: 91.189.92.181 80]

W: Imposible obtener http://extras.ubuntu.com/ubuntu/dists/maverick/main/binary-i386/Packages.gz 404 Not Found

W: Imposible obtener http://security.ubuntu.com/ubuntu/dists/maverick-security/restricted/sou... 404 Not Found [IP: 91.189.92.181 80]

W: Imposible obtener http://security.ubuntu.com/ubuntu/dists/maverick-security/universe/sourc... 404 Not Found [IP: 91.189.92.181 80]

W: Imposible obtener http://security.ubuntu.com/ubuntu/dists/maverick-security/multiverse/sou... 404 Not Found [IP: 91.189.92.181 80]

W: Imposible obtener http://security.ubuntu.com/ubuntu/dists/maverick-security/main/binary-i3... 404 Not Found [IP: 91.189.92.181 80]

W: Imposible obtener http://security.ubuntu.com/ubuntu/dists/maverick-security/restricted/bin... 404 Not Found [IP: 91.189.92.181 80]

W: Imposible obtener http://security.ubuntu.com/ubuntu/dists/maverick-security/universe/binar... 404 Not Found [IP: 91.189.92.181 80]

W: Imposible obtener http://security.ubuntu.com/ubuntu/dists/maverick-security/multiverse/bin... 404 Not Found [IP: 91.189.92.181 80]

E: Algunos archivos de índice no se han podido descargar, se han ignorado,
o se ha utilizado unos antiguos en su lugar.

Vale lo he hecho en la terminal a través del cd que bueno leyendo el archivo sources.list al principio hace referencia al cd de Maverick asi que por eso supongo que me ha pedido que insertase el cd en el transcurso del 85% del proceso de apt-get update && upgrade .... el caso es que ya una vez con el cd (insertado y montado) el proceso en un pricipio iba bien desencaminado hasta que me ha dado error sobre todo en los apartados de security y extras, por lo que supongo que he de cambiar algo en esos repositorios, pero no se lo que es.

Pistasss XDD

+1
0
-1
Imagen de cuentos
+1
0
-1

Y lo mas probable. Es por que como te habíamos dicho:
No hay actualizaciones de seguridad.
Mira aquí:
http://rm-rf.es/como-usar-apt-o-synaptic-en-versiones-antiguas-de-ubuntu...

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de pills
+1
0
-1

Lo reconozco está la cosa chunga, aún así ¿podría optar por otro tipo de técnicas como conseguir en un cd los paquetes o bibliotecas que me interesasen, por ejemplo de ubuntu 12.04 y con una simple transferencia de archivos trasldarlos a mi disco duro?

+1
0
-1
Imagen de cuentos
+1
0
-1

Lo que te puso José Luis:

Pero esos repositorios no reciben actualizaciones, es decir están ahí solo para el software que necesites instalar con las mismas versiones del software que había en octubre del 2010.

EL software nuevo que desees instalar, si dependen de librerías cuyas versiones son modernas... debes compilar esas librerías desde código fuente y este código fuente también tienen sus dependencias... es decir tienes un proceso muy largo para hacer funcionar un solo programa.

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de Alcruz
+1
-1
-1

No vas a poder actualizar a nuevas versiones de las librerías, pero por lo general, esas librerías son suficientes para poder compilar nuevas versiones de programas , por ejemplo si pones
sudo apt-get build-dep wine
vas a descargar todas las librerías y librerías de desarrollo para compilar la última versión de wine que hoy es la 1.6
Por otra parte, los principales programas, como se Libreoffice, Firefox, Thunderbird, Calibre, etc, etc, puedes instalar el binario desde su sitio oficial
Yo uso la versión 10.04 que LTS y que supuestamente ya venció su soporte, sin embargo sigo recibiendo actualzaciones y siguen vivos los repos mirrors , seguramente decidieron eso ante la infamia de Gnome3 que no hace mas que ir a peor ante cada actualización.
En definitiva, no vale la pena actualizar, desde que salió Unity y Gnome3, todo funciona peor, no solo el sistema, sino los programas descargados desde los repositorios, un desastre que no se en que va a terminar .

+1
-1
-1
Imagen de rioport
+1
0
-1

Yo uso la versión 10.04 que LTS y que supuestamente ya venció su soporte, sin embargo sigo recibiendo actualzaciones y siguen vivos los repos mirrors , seguramente decidieron eso ante la infamia de Gnome3 que no hace mas que ir a peor ante cada actualización.

No es supuestamente, es que ya venció su soporte. Permanecerá en los servidores oficiales mientras Ubuntu Server 10.04 tenga soporte. Recibes actualizaciones solo de los paquetes que comparten las 2 ediciones (server y desktop) y no de aquellos que solo estuvieron soportados por la versión Desktop. Si creías que la infamia de Gnome3 los iba a detener a pensar en extender el ciclo de vida de la versión 10.04 te equivocaste.

+1
0
-1

-- GC --

Imagen de Jose Luis 1320
+1
0
-1

Recibes actualizaciones por que estas usando la versión de servidor.

Y eso que dices sobre Unity y gnome 3 es solo tu opinión... mas no algo de facto, hay personas que les funciona muy bien tanto Unity como Gnome 3.

Y no, no hay ningún soporte extendido solo por "la infamia de gnome 3 y unity".

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de sisprotec
+1
-1
-1

Err http://security.ubuntu.com breezy-security/main Sources
404 Not Found [IP: 91.189.88.153 80]
Err http://security.ubuntu.com breezy-security/restricted Sources
404 Not Found [IP: 91.189.88.153 80]
Err http://security.ubuntu.com breezy-security/universe Sources
404 Not Found [IP: 91.189.88.153 80]
Err http://security.ubuntu.com breezy-security/multiverse Sources
404 Not Found [IP: 91.189.88.153 80]
Err http://security.ubuntu.com breezy-security/main i386 Packages
404 Not Found [IP: 91.189.88.153 80]
Err http://security.ubuntu.com breezy-security/restricted i386 Packages
404 Not Found [IP: 91.189.88.153 80]
Err http://security.ubuntu.com breezy-security/universe i386 Packages
404 Not Found [IP: 91.189.88.153 80]
Err http://security.ubuntu.com breezy-security/multiverse i386 Packages
404 Not Found [IP: 91.189.88.153 80]

+1
-1
-1