[SOLUCIONADO] Inconvenientes con mi tarjeta de red inalambrica (Broadcom BCM4318)

Imagen de Milena
0 puntos

Hola a tod@s, mi nombre es Milena (espero estar publicando el post en el lugar adecuado, de lo contario por favor me indican, he leido las reglas del foro, he consultado -no se imaginan cuanto-) y tengo algunos inconvenientes con mi tarjeta de red inalambrica.

He leido muchas paginas y seguido varios manuales pero mi conocimiento en Linux es muy limitado (hasta el momento), me gustaria pedirles orientación al respecto, les cuento...

Habia instalado antes ubuntu sin mayores inconvenientes, por cuestiones de la Universidad he decidido cambiar el sistema operativo, pero aun asi, basado en Ubuntu (instale BackBox Linux 3.05 - i386 [Release: 22.05.2013]). Todo hasta el momento funciona bien, pero la tarjeta inalambrica no. Instale ndiswrapper, descarge un archivo .inf y .sys correspondiente a mi tarjeta wifi y he llegado a un punto en el cual no se como seguir, no se que pasa.

Tengo un HP Special Edition L2000 Notebook PC, eso es a ciencia cierta lo que se, el resto de datos los he obtenido con algunos comandos.

La información es como sigue:

$ uname -r
3.2.0-51-generic

$ echo $(lsb_release -cs)
precise

# lspci | grep Wireless
05:02.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)

# ifconfig
eth0 Link encap:Ethernet direcciónHW XX:XX:XX:XX:XX:XX <-- Las equis las he puesto yo
Direc. inet:192.168.0.12 Difus.:192.168.0.255 Másc:255.255.255.0
Dirección inet6: XXXX::XXX:XXXX:XXXX:XXXX/64 Alcance:Enlace <-- Aqui tambien he puesto equis
ACTIVO DIFUSIÓN FUNCIONANDO MULTICAST MTU:1500 Métrica:1
Paquetes RX:187490 errores:0 perdidos:0 overruns:0 frame:0
Paquetes TX:134273 errores:0 perdidos:0 overruns:0 carrier:0
colisiones:0 long.colaTX:1000
Bytes RX:248035548 (248.0 MB) TX bytes:13879426 (13.8 MB)
Interrupción:18 Dirección base: 0xa000

lo Link encap:Bucle local
Direc. inet:127.0.0.1 Másc:255.0.0.0
Dirección inet6: ::1/128 Alcance:Anfitrión
ACTIVO BUCLE FUNCIONANDO MTU:16436 Métrica:1
Paquetes RX:905 errores:0 perdidos:0 overruns:0 frame:0
Paquetes TX:905 errores:0 perdidos:0 overruns:0 carrier:0
colisiones:0 long.colaTX:0
Bytes RX:272033 (272.0 KB) TX bytes:272033 (272.0 KB)

# iwconfig
lo no wireless extensions.
eth0 no wireless extensions.

# cat /etc/network/interfaces
auto lo
iface lo inet loopback

Partiendo de aqui instale ndiswarpper y ndisgtk sin ningun inconveniente...

Tengo los contralodores originales de la laptop que funcionaban con el S.O. Windows, asi que busque en el CD los controladores WLan y pude encontrar los siguientes archivos:
bcmwl5.inf
bcmwl5a.inf
bcmwl5.sys

Encontre en alguna receta sobre controladores broadcom bcm43xx algo de una lista negra, asi que ejecute lo siguiente...
# echo -e "blacklist bcm43xx\nblacklist b43\nblacklist b43legacy\nblacklist ssb" | sudo tee -a /etc/modprobe.d/blacklist

Reinicie como sugerian, y la verifique

# cat /etc/modprobe.d/blacklist
#Driver nativo para bcm43xx\nblacklist b43\nblacklist b43legacy
blacklist bcm43xx
blacklist b43
blacklist b43legacy
blacklist ssb

Instale los controladores con ndiswrapper
# ndiswrapper -i bcmwl5.inf
# ndiswrapper -i bcmwl5a.inf

Alli se presentaba un error (no lo recuerdo -como si los archivos no correspondieran con la tarjeta-), asi que los desinstale.
# ndiswrapper -e bcmwl5.inf
# ndiswrapper -e bcmwl5a.inf

Encontre la siguiente pagina...
http://sourceforge.net/apps/mediawiki/ndiswrapper/index.php?title=Catego...

Y de ella descarge los controladores correspondientes (bcmwl5a.inf y bcmwl5.sys), volvi a instalarlos (los anteriores .inf y .sys los habia borrado antes de instalar el nuevo)
# ndiswrapper -e bcmwl5a.inf

# ndiswrapper -l
WARNING: All config files need .conf: /etc/modprobe.d/blacklist, it will be ignored in a future release.
bcmwl5a : driver installed
device (14E4:4318) present (alternate driver: ssb)

No estoy segura pero lo de driver installed no aparecia anteriormente, y con estos nuevos archivos si, asi que supuse que iba bien.

Despues de eso intente lo siguiente...
sudo depmod -a

Sin obtener respuesta alguna y tambien...
modprobe ndiswrapper
WARNING: All config files need .conf: /etc/modprobe.d/blacklist, it will be ignored in a future release.
FATAL: Module ndiswrapper not found.

Aqui no se que pasa...

Sugerian ejecutar
tail /var/log/messages

Pero yo no tengo el archivo "messages", tengo "jockey.log.1" y su resultado es:
tail /var/log/jockey.log.1
2013-08-02 13:16:54,753 DEBUG: querying driver db about HardwareID('modalias', 'pci:v00001022d00001103sv00000000sd00000000bc06sc00i00')
2013-08-02 13:16:54,753 DEBUG: querying driver db about HardwareID('modalias', 'serio:ty01pr00id00ex00')
2013-08-02 13:16:54,753 DEBUG: querying driver db about HardwareID('modalias', 'pci:v0000104Cd00008031sv0000103Csd00003091bc06sc07i00')
2013-08-02 13:16:54,753 DEBUG: querying driver db about HardwareID('modalias', 'input:b0019v0000p0003e0000-e0,1,k8E,ramlsfw')
2013-08-02 13:16:54,753 DEBUG: querying driver db about HardwareID('modalias', 'acpi:PNP0C02:')
2013-08-02 13:16:54,968 DEBUG: BroadcomWLHandler enabled(): kmod enabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted
2013-08-02 13:16:55,608 DEBUG: BroadcomWLHandler enabled(): kmod enabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted
2013-08-02 13:16:55,803 DEBUG: BroadcomWLHandler enabled(): kmod enabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted
2013-08-02 13:17:00,183 DEBUG: BroadcomWLHandler enabled(): kmod enabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted
2013-08-02 13:17:16,209 DEBUG: Shutting down

# ip addr
1: lo: mtu 16436 qdisc noqueue state UNKNOWN
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever

2: eth0: mtu 1500 qdisc pfifo_fast state UNKNOWN qlen 1000
link/ether XX:XX:XX:XX:XX:XX brd ff:ff:ff:ff:ff:ff <-- Las equis las he puesto yo
inet 192.168.0.12/24 brd 192.168.0.255 scope global eth0
inet6 XXXX::XXX:XXXX:XXXX:XXXX/64 scope link <-- Aqui tambien he puesto yo las equis
valid_lft forever preferred_lft forever

Ejecutando iwconfig me aparece:
iwconfig
lo no wireless extensions.
eth0 no wireless extensions.

Me dice que montar la tarjeta, pero no se si esto sea montar la tarjeta...
ifconfig wlan0 down
wlan0: ERROR mientras se obtenían las banderas de interfaz: No existe el dispositivo

Luego
sudo ifconfig wlan0 up
wlan0: ERROR mientras se obtenían las banderas de interfaz: No existe el dispositivo

Tambien intente:
# airmon-ng start wlan0
Found 4 processes that could cause trouble.
If airodump-ng, aireplay-ng or airtun-ng stops working after
a short period of time, you may want to kill (some of) them!

PID Name
604 avahi-daemon
605 avahi-daemon
855 NetworkManager
914 dhclient

Interface Chipset Driver

lsmod me dice lo siguiente...
lsmod
Module Size Used by
joydev 17393 0
hp_wmi 13652 0
sparse_keymap 13658 1 hp_wmi
snd_atiixp 19337 3
snd_seq_midi 13132 0
snd_rawmidi 25424 1 snd_seq_midi
pcmcia 39826 0
snd_seq_midi_event 14475 1 snd_seq_midi
snd_atiixp_modem 18604 6
snd_ac97_codec 110213 2 snd_atiixp,snd_atiixp_modem
ac97_bus 12642 1 snd_ac97_codec
snd_seq 51592 2 snd_seq_midi,snd_seq_midi_event
snd_pcm 80916 5 snd_atiixp,snd_atiixp_modem,snd_ac97_codec
snd_seq_device 14172 3 snd_seq_midi,snd_rawmidi,snd_seq
snd_timer 28931 2 snd_seq,snd_pcm
tifm_7xx1 12937 0
psmouse 96718 0
tifm_core 15040 1 tifm_7xx1
yenta_socket 27428 0
pcmcia_rsrc 18367 1 yenta_socket
k8temp 12905 0
serio_raw 13027 0
snd 62218 24 snd_atiixp,snd_rawmidi,snd_atiixp_modem,snd_ac97_codec,snd_seq,snd_pcm,snd_seq_device,snd_timer
pcmcia_core 21511 3 pcmcia,yenta_socket,pcmcia_rsrc
soundcore 14635 1 snd
i2c_piix4 13093 0
snd_page_alloc 14115 3 snd_atiixp,snd_atiixp_modem,snd_pcm
shpchp 32265 0
rfcomm 38139 0
bnep 17830 2
bluetooth 158447 10 rfcomm,bnep
parport_pc 32114 0
ppdev 12849 0
binfmt_misc 17292 1
mac_hid 13077 0
lp 17455 0
parport 40930 3 parport_pc,ppdev,lp
radeon 733914 2
firewire_ohci 40180 0
ttm 65344 1 radeon
firewire_core 56940 1 firewire_ohci
drm_kms_helper 45466 1 radeon
8139too 23283 0
sdhci_pci 18324 0
drm 197641 4 radeon,ttm,drm_kms_helper
crc_itu_t 12627 1 firewire_core
8139cp 22633 0
sdhci 28241 1 sdhci_pci
video 19115 0
i2c_algo_bit 13199 1 radeon
wmi 18744 1 hp_wmi
pata_atiixp 12999 3
ati_agp 13242 0
zram 18193 1

Despues de estos dias en esto no se que hacer, tambien me reuso a estar sin WiFi, la versión de este S.O. me gusta y no quisiera quitarlo solo por esto, se que habra alguna forma u otro metodo para poder instalar los contraladores de esta tarjeta de red inalambrica.

Me gustaria saber si alguno de ustedes me puede orientar al respecto, ya no se que o como preguntarle al todo sapiente google, igual creo que debe estar cansado de mi, agradesco sus comentarios.

Gracias, Milena!

Imagen de Gabriel_M
+1
0
-1

Abre una terminal.
Ejecuta en ella:

sudo su
apt-get update
apt-get install linux-headers-generic 
apt-get install --reinstall bcmwl-kernel-source
modprobe wl

Presta atención a que los linux-headers-generic sean los de tu kernel 3.2.0-51-generic

+1
0
-1
Imagen de Milena
+1
0
-1

Hola Gabriel (Gabriel_M), muchas gracias por tu respuesta, he podido ejecutar los comandos, el primero (apt-get install linux-headers-generic) no presenta inconveniente alguno, pero al reinstalar bcmwl-kernel-source y ejecutar modprobe, presenta los siguientes errores.

apt-get install --reinstall bcmwl-kernel-source
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
0 actualizados, 0 se instalarán, 1 reinstalados, 0 para eliminar y 0 no actualizados.
Se necesita descargar 0 B/1.301 kB de archivos.
Se utilizarán 0 B de espacio de disco adicional después de esta operación.
(Leyendo la base de datos ... 164800 ficheros o directorios instalados actualmente.)
Preparando para reemplazar bcmwl-kernel-source 6.20.155.1+bdcom-0ubuntu0.0.1 (usando .../bcmwl-kernel-source_6.20.155.1+bdcom-0ubuntu0.0.1_i386.deb) ...
Removing all DKMS Modules
Done.
Desempaquetando el reemplazo de bcmwl-kernel-source ...
Configurando bcmwl-kernel-source (6.20.155.1+bdcom-0ubuntu0.0.1) ...
Loading new bcmwl-6.20.155.1+bdcom DKMS files...
Building only for 3.2.0-51-generic-pae
Building for architecture i686
Module build for the currently running kernel was skipped since the
kernel source for this kernel does not seem to be installed.
WARNING: All config files need .conf: /etc/modprobe.d/blacklist, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/blacklist, it will be ignored in a future release.
FATAL: Module wl not found.
FATAL: Error running install command for wl

update-initramfs: deferring update (trigger activated)
Procesando disparadores para initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.2.0-51-generic-pae

modprobe wl
WARNING: All config files need .conf: /etc/modprobe.d/blacklist, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/blacklist, it will be ignored in a future release.
FATAL: Module wl not found.
FATAL: Error running install command for wl

+1
0
-1
Imagen de Gabriel_M
+1
+1
-1

sudo su
modprobe -r b43 ssb wl
apt-get remove bcmwl-kernel-source 
apt-get install build-essential dkms linux-headers-generic
apt-get install bcmwl-kernel-source
+1
+1
-1
Imagen de Milena
+1
0
-1

Hola Gabriel, he ejecutado los comandos que me dices y los resultados son los siguientes...

modprobe -r b43 ssb wl
WARNING: All config files need .conf: /etc/modprobe.d/blacklist, it will be ignored in a future release.
FATAL: Module off not found.

apt-get remove bcmwl-kernel-source y apt-get install build-essential dkms linux-headers-generic sin inconvenientes...

apt-get install bcmwl-kernel-source
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Se instalarán los siguientes paquetes NUEVOS:
bcmwl-kernel-source
0 actualizados, 1 se instalarán, 0 para eliminar y 0 no actualizados.
Se necesita descargar 0 B/1.301 kB de archivos.
Se utilizarán 3.656 kB de espacio de disco adicional después de esta operación.
Seleccionando paquete bcmwl-kernel-source previamente no seleccionado
(Leyendo la base de datos ... 164734 ficheros o directorios instalados actualmente.)
Desempaquetando bcmwl-kernel-source (de .../bcmwl-kernel-source_6.20.155.1+bdcom-0ubuntu0.0.1_i386.deb) ...
Configurando bcmwl-kernel-source (6.20.155.1+bdcom-0ubuntu0.0.1) ...
Loading new bcmwl-6.20.155.1+bdcom DKMS files...
Building only for 3.2.0-51-generic-pae
Building for architecture i686
Module build for the currently running kernel was skipped since the
kernel source for this kernel does not seem to be installed.
WARNING: All config files need .conf: /etc/modprobe.d/blacklist, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/blacklist, it will be ignored in a future release.
FATAL: Module wl not found.
FATAL: Error running install command for wl

update-initramfs: deferring update (trigger activated)
Procesando disparadores para initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.2.0-51-generic-pae

+1
0
-1
Imagen de Gabriel_M
+1
+1
-1

... que te falta el kernel source del kernel en uso:

Module build for the currently running kernel was skipped since the
kernel source for this kernel does not seem to be installed.

Asi que ejecuta:

sudo su
apt-get install kernel-source
apt-get install --reinstall bcmwl-kernel-source
modprobe wl
+1
+1
-1
Imagen de Milena
+1
0
-1

Hola, Grabiel... gracias por estar atento a mi inconveniente; he ejecutado las instrucciones y el resultado no es para nada satisfactorio...

apt-get install kernel-source
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
El paquete kernel-source no está disponible, pero algún otro paquete hace referencia
a él. Esto puede significar que el paquete falta, está obsoleto o sólo se
encuentra disponible desde alguna otra fuente
E: El paquete «kernel-source» no tiene un candidato para la instalación

apt-get install --reinstall bcmwl-kernel-source
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
0 actualizados, 0 se instalarán, 1 reinstalados, 0 para eliminar y 0 no actualizados.
Se necesita descargar 0 B/1.301 kB de archivos.
Se utilizarán 0 B de espacio de disco adicional después de esta operación.
(Leyendo la base de datos ... 164800 ficheros o directorios instalados actualmente.)
Preparando para reemplazar bcmwl-kernel-source 6.20.155.1+bdcom-0ubuntu0.0.1 (usando .../bcmwl-kernel-source_6.20.155.1+bdcom-0ubuntu0.0.1_i386.deb) ...
Removing all DKMS Modules
Done.
Desempaquetando el reemplazo de bcmwl-kernel-source ...
Configurando bcmwl-kernel-source (6.20.155.1+bdcom-0ubuntu0.0.1) ...
Loading new bcmwl-6.20.155.1+bdcom DKMS files...
Building only for 3.2.0-51-generic-pae
Building for architecture i686
Module build for the currently running kernel was skipped since the
kernel source for this kernel does not seem to be installed.
WARNING: All config files need .conf: /etc/modprobe.d/blacklist, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/blacklist, it will be ignored in a future release.
FATAL: Module wl not found.
FATAL: Error running install command for wl
update-initramfs: deferring update (trigger activated)
Procesando disparadores para initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.2.0-51-generic-pae

modprobe wl
WARNING: All config files need .conf: /etc/modprobe.d/blacklist, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/blacklist, it will be ignored in a future release.
FATAL: Module wl not found.
FATAL: Error running install command for wl

Crees que el hecho que sea de 32 bits o 64 bits, afecte en algo?
uname -a
Linux Back-Box 3.2.0-51-generic-pae #77-Ubuntu SMP Wed Jul 24 20:40:32 UTC 2013 i686 athlon i386 GNU/Linux

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.2 LTS
Release: 12.04
Codename: precise

La verdad no se que pensar, o que puede ser lo que este afectando, mis prespositorios son los siguientes...

cat /etc/apt/sources.list
# deb cdrom:[BackBox Linux 3.05]/ precise main multiverse restricted universe

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://co.archive.ubuntu.com/ubuntu/ precise main restricted
deb-src http://co.archive.ubuntu.com/ubuntu/ precise main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://co.archive.ubuntu.com/ubuntu/ precise-updates main restricted
deb-src http://co.archive.ubuntu.com/ubuntu/ precise-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://co.archive.ubuntu.com/ubuntu/ precise universe
deb-src http://co.archive.ubuntu.com/ubuntu/ precise universe
deb http://co.archive.ubuntu.com/ubuntu/ precise-updates universe
deb-src http://co.archive.ubuntu.com/ubuntu/ precise-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://co.archive.ubuntu.com/ubuntu/ precise multiverse
deb-src http://co.archive.ubuntu.com/ubuntu/ precise multiverse
deb http://co.archive.ubuntu.com/ubuntu/ precise-updates multiverse
deb-src http://co.archive.ubuntu.com/ubuntu/ precise-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://co.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse
deb-src http://co.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu precise-security main restricted
deb-src http://security.ubuntu.com/ubuntu precise-security main restricted
deb http://security.ubuntu.com/ubuntu precise-security universe
deb-src http://security.ubuntu.com/ubuntu precise-security universe
deb http://security.ubuntu.com/ubuntu precise-security multiverse
deb-src http://security.ubuntu.com/ubuntu precise-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu precise partner
# deb-src http://archive.canonical.com/ubuntu precise partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu precise main
deb-src http://extras.ubuntu.com/ubuntu precise main

Esta version al parecer esta basada en Precise Pangolin, crees que al no tenerla actualizada (a Raring Ringtail) influya en algo?

Con agradecimientos, Milena!

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

.... y esto es resultado de una visita al ppa de Backbox
https://launchpad.net/~backbox/+archive/three/+packages
Es que no existe el archivo con el kernel-source
Podrias probar cambiar el kernel, desde Synaptic, instalando uno original de Precise con sus sources y headers e iniciar con él, para luego repetir los procedimientos.

+1
0
-1
Imagen de Milena
+1
0
-1

Gabriel, ¡muchas gracias por tu ayuda!, sin ti no habria podido solventar este inconveniente; he aprendido mucho.

Formatee un par de veces, y en cada una de ellas algo sucedia, hasta que por fin!... ahora todo funciona correctamente. Habia instalado muchas cosas y a la final no sabia que servia y que no, asi que decidi partir de cero; con el BackBox recien instalado y sin ningun paquete adicional, actualice y actualice... desde 3.2.0-51-generic hasta tener 3.8.0-27-generic

Use: sudo update-manager -d

Despues de esto instale los siguientes paquetes, a saber...

  • firmware-b43-installer (version 1:015-14)
  • b43-fwcutter (version 1:015-14)
  • ndiswrapper-source (version 1.58-0ubuntu1)
  • ndiswrapper-dkms (version 1.58-0ubuntu1)
  • ndiswrapper-utils-1.9 (version 1.58-0ubuntu1)
  • ndiswrapper-common (version 1.58-0ubuntu1)

El firmware-b43-installer instala el firmware necesario para usar el controlador del núcleo b43.
Los chipsets que admite son:

  • BCM4306/3
  • BCM4311
  • BCM4318 <-- Este es el chip de mi tarjeta de red inalambrica
  • BCM4321
  • BCM4322 (sólo 14e4:432b)

Lo anterior fueron los pre-requisitos... encontre el siguiente enlace:

Descarge el script, lo ejecute...
sudo sh install_bcm43xx_firmware_5.100.138.sh

Y... voilà tout, ahora mi tarjeta de red inalambrica funciona de maravilla.

Gabriel, agradesco tu tiempo y toda la ayuda que me brindaste, eres muy amable; Gracias... ¡TOTALES! ;)

Un abrazo.

+1
0
-1