No puedo actualizar mi Ubuntu 10.04 (Problema con el Gestor de Actualizaciones)

Imagen de llavebulacio
0 puntos

Primero que nada, hola, y, segundo, soy el dsesafortunado poseedor de una netbook exomate del gobierno argentino, que viene con Ubuntu 10.04 y Windows 7 Professional preinstalados, la falta de RAM y la lentitud de Windows han conseguido decantarme por Linux a la hora del uso diario y, hasta ahora, no he tenido problemas.
Hace poco, y por motivos que no vienen al caso, me ví visto a actualizar mi Ubuntu a la versión 13.04. Así que abrí el gestor de actualizaciones y... me apareció "Esta disponible la versión 10.10 de Ubuntu". "De acuerdo, pefecto", pensé yo. Actualizaba a la 10.10 y luego a la 13.04, pero.. Al intentar actualizar, y tras el cartel de notas de la versión (al que también le hice click en actualizar) no pasa nada por un momento y, unos segundos despues, sale un cartel con lo siguiente:

Error al descargar
Ha fallado la descarga de la actualización. Puede haber un problema con la red.

Ahora bien, mi internet me anda perfecto, así que lo doy por descartado... ¿Cuál puede ser el problema?

Aprovecharé para hacer otra pregunta tonta...
¿Perderé archivos al actualizar Ubuntu de esta manera?

ATTE,
Llavebulacio

Imagen de cuentos
+1
0
-1

el error es que ya no tiene soporte 10.10
no te da opción a una versión mas nueva.
En cuanto a los archivos, si tienes la home en una partición aparte. Se salvan los archivos en caso de una perdida del sistema.
Se puede brincar a una versión mas actualizada cambiando en tu sources.list los repositorios.

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de Goyo
+1
0
-1

Oficialmente está (estaba) soportada la actualización a 12.04:
https://help.ubuntu.com/community/PreciseUpgrades#Upgrade_from_11.10_to_...

No tiene por qué pasarle nada a tus archivos.

+1
0
-1
Imagen de cuentos
+1
0
-1

que necesites modificar tu sources.list
http://www.ubuntu-es.org/node/180661#.UhEny6ygPyg

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de llavebulacio
+1
0
-1

No tengo nada en mi sources.list, no me aparece nada.

+1
0
-1
Imagen de cuentos
+1
0
-1

tienes que tener hay tus repositorios, si te aparece en blanco, es que escribiste mal el nombre, para ver el sources.list:
nano /etc/apt/sources.list

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de llavebulacio
+1
0
-1

¡No escribí mal el nombre! xD Realmente, no me aparece nada en el sources.list

...

Mierda que la tengo jodida...

+1
0
-1
Imagen de cuentos
+1
0
-1

Ejecuta estos dos comandos en la terminal, y pones lo que te sale aquí:
ls /etc/apt
ls /etc/apt/sources.list.d

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de Alcruz
+1
0
-1

Al menos algunos mirros siguen activos, por ejemplo el de Brasil
Ejecuta
gksudo gedit /etc/apt/sources.list
borra todo y pega lo suguiente

deb http://br.archive.ubuntu.com/ubuntu/ lucid main restricted
deb-src http://br.archive.ubuntu.com/ubuntu/ lucid main restricted
deb http://br.archive.ubuntu.com/ubuntu/ lucid-updates main restricted
deb-src http://br.archive.ubuntu.com/ubuntu/ lucid-updates main restricted
deb http://br.archive.ubuntu.com/ubuntu/ lucid universe multiverse
deb-src http://br.archive.ubuntu.com/ubuntu/ lucid universe multiverse
deb http://br.archive.ubuntu.com/ubuntu lucid-security main restricted
deb-src http://br.archive.ubuntu.com/ubuntu lucid-security main restricted

Luego
sudo apt-get update
sudo apt-get upgrade

+1
0
-1
Imagen de llavebulacio
+1
0
-1

alumno@EXO1078d200206e:~$ ls /etc/apt
apt.conf.d sources.list.bkp sources.list.save trusted.gpg~
preferences.d sources.list.d sources.list.save.1 trusted.gpg.d
secring.gpg sources.list.exo trustdb.gpg
sources.list sources.list.final trusted.gpg
alumno@EXO1078d200206e:~$ ls /etc/apt/sources.list.d
cairo-dock-team-ppa-lucid.list
cairo-dock-team-ppa-lucid.list.save
google-talkplugin.list
google-talkplugin.list.save
hizo-mkv-extractor-gui-lucid.list
hizo-mkv-extractor-gui-lucid.list.save
jd-team-jdownloader-lucid.list
jd-team-jdownloader-lucid.list.save
lucid-partner.list
lucid-partner.list.save
nanny-ppa-lucid.list
nanny-ppa-lucid.list.save
pinta-maintainers-pinta-stable-lucid.list
pinta-maintainers-pinta-stable-lucid.list.save
transmissionbt-ppa-lucid.list
transmissionbt-ppa-lucid.list.save
ubuntu-wine-ppa-lucid.list
ubuntu-wine-ppa-lucid.list.save
wallch-wallch-ppa-lucid.list
wallch-wallch-ppa-lucid.list.save

Eso, en definitiva.

+1
0
-1
Imagen de cuentos
+1
0
-1

posiblemente al querer actualizar de versión te cambio el sources.list a uno de estos:
sources.list.save
sources.list.save.1
Pero, tienes varios ppa, que no es recomendable actualizar, tendrias que borrarlos con ppa-purge,
Primero mira en los save y puedes renombrar uno de estos a:
sources.list
Y mira aquí para los ppa:
http://www.ubuntu-es.org/node/179430#.UhFXEYB5beQ
y este articulo sobre borrar ppa
http://diversidadyunpocodetodo.blogspot.mx/2013/02/ppa-purge-eliminar-ag...

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos