errores al colocar un repositorio especifico para precise

Imagen de fhuvu
0 puntos

hola no sabia muy bien donde colocar el post ya que no compagina, mi problema esque actualice de 11.4 a 12.4 64 bit para poder colocar un repositorio que se supone solo funciona con esa version, el problema esue se me actualiza a 12.4.2 precise pangolin, coloco el repositorio aparentemente lo acepta pero actualizo la lista de paquetes y tachannnnnnn me dice que no se puede obtener, reviso la info y esta todo correcto pero por si las dudas coloco precise pangolin como distribucion ya que es esa pero entonces nisiquiera conecta, ¿sera porque es para precise? quisiera saber como podria saltarme esto y usar los repo de precise con pangolin, he descartado fallos de servidor porque lleva 1 mes fallando

Imagen de caneparamiro
+1
0
-1

pone una imagen del error por favor para ver que es lo que realmente esta pasando.

+1
0
-1
Imagen de cuentos
+1
0
-1

no te entendí bien. 12.04 Y 12.04.2 seria lo mismo,
Posiblemente tienes el sistema de dependencias roto, si actualizaste de versión y tenias repos (ppa) de la versión anterior.
mira que te da este comando para ver los ppa,(pon lo que te sale aquí para ver)
ls /etc/apt/sources.list.d

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de fhuvu
+1
-1
-1

de forma mas clara para que entendais agrego este repo

deb http://dl.hiphop-php.com/ubuntu precise main
es el de la maquina para php de facebook y no se obtiene

+1
-1
-1
Imagen de caneparamiro
+1
0
-1

mira, no me parece tan claro, pero a la dir le faltaria .... http://dl.hiphop-php.com/ubuntu/dists/precise/main/ y fijate si lo agarra ahi, sino hay que agregarle la ruta completa que faltaria /binary-amd64/Packages.gz

+1
0
-1
Imagen de fhuvu
+1
0
-1

yo pongo la url que pone en guithub pero probare lo que dices y cuento

+1
0
-1
Imagen de fhuvu
+1
-1
-1

con tu url no agarra no lo acepta como repo, con la mia si pero no lo baja tendre que bajar amano el paquete descomprimirlo e instalarlo

+1
-1
-1
Imagen de cuentos
+1
0
-1

de acuerdo a la pagina:
https://www.facebook.com/hphp/posts/10151141397869326
agregas el repo. ejecutas, para actualizar la lista de programas:
sudo apt-get update
y para instalar:
sudo apt-get install hiphop-php
lo que se me hace raro es que no te pida la llave de seguridad.

EDITADO.
Como agregas el repositorio, editas bien el sorces.list como administrador.

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de fhuvu
+1
0
-1

lo hago de dos formas
1 desde origenes del software
2 editando el archivo de lista y en ninguno de ambos casos funciona

+1
0
-1
Imagen de cuentos
+1
0
-1

agregas el repositorio, desde la terminal:
sudo nano /etc/apt/sources.list.d/hphp-list

y agregas la linea que recomiendan.

deb http://dl.hiphop-php.com/ubuntu/ precise main

guardas y sales con:
CTRL-o
CTRl+x
luego ejecutas:
sudo apt-get update
sudo apt-get install hiphop-php
y pon aquí si te sale un error. para ver.

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de fhuvu
+1
0
-1

por finnnnnnnnnnnnnnnn lo raro esque no funciono con nano sino que tube que usar gedit osea si abro nautilus con root y abro el archivo no funciona pero si abro el gedit con root y navego y abro si funciona, editare el hilo como solucionadoo pero una cosita mas se podria usar los repos de precise en la 11.4? importando las firmas claro

+1
0
-1
Imagen de cuentos
+1
0
-1

te puse con nano, y se me olvido comentar que seria un archivo nuevo, o sea que saldría en blanco.
Mi intención era crear un repo nuevo y ponerlo en el directorio /sources.list.d, para que luego sepas que repositorios externos tienes. Como sea si están dentro de tu sources.list, o en un uno aparte funciona.
no creo que te funcione en otra versión ya que las versiones de los programas son distintas y te puede dar error de dependencias.

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de fhuvu
+1
0
-1

los repos que recomiendan estan añadidos pero pone que no se puede instalar porque se requere fuentes no confiables pero eso es normal no es un paquete creado por canonical

+1
0
-1