Partición ext4 se monta con diferentes nombres cada vez (Solucionado)

Imagen de gragry
0 puntos

Hola, estoy teniendo problemas para montar una de las particiones de mi disco.
Es un disco Seagate de 1Tb que tiene una partición llamada VyM, además de la home y la de sistema.
Pues resulta que en un momento me dijo que no la encontraba cuando le indiqué que quería acceder a una de sus carpetas, en el menú de unity aparece la partición, le hago click y me la muestra sin problemas.

Voy a la carpeta /media y veo que el árbol de directorio es así

/media
/familia
/familia/VyM
/familia/VyM1
/familia/VyM2 (acceso directo, con una flechita)
/familia/VyM3

Si en dolphin hago click en VyM3 me muestra mi partición (pero con el label VyM) si señalo cualquiera de las otras carpetas (VyM, VyM1 o VyM2) me dice que no existe. Aparentemente agrega un VyM en cada booteo.

¿Por qué empezó a numerar las particiones? ¿Qué hago para que empiece a comportarse como siempre?

Imagen de cuentos
+1
0
-1

Lo tienes configurado para que lo monte al arrancar con el fstab.
Que te dan estos comandos (ponlo aquí para ver)
cat /etc/fstab
sudo blkid

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de gragry
+1
0
-1

Nunca configuré nada al respecto. Es algo que siempre dejé que hiciera el sistema. Ahí va.

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
#
# / was on /dev/sda3 during installation
UUID=7824e41a-51ce-415d-9fb2-ddef68f33c3f / ext4 errors=remount-ro 0 1
# /home was on /dev/sda2 during installation
UUID=ac079b07-b330-461f-abc3-f74ea02f0e5c /home ext4 defaults 0 2
# swap was on /dev/sda4 during installation
UUID=499a98c7-35fe-4e00-ad8c-797fb6b93eb2 none swap sw 0 0

+1
0
-1
Imagen de Alcruz
+1
0
-1

Pone lo que te sale al ejecutar
sodo blkid

+1
0
-1
Imagen de gragry
+1
0
-1

/dev/sda2: LABEL="Lulu" UUID="ac079b07-b330-461f-abc3-f74ea02f0e5c" TYPE="ext4"
/dev/sda3: UUID="7824e41a-51ce-415d-9fb2-ddef68f33c3f" TYPE="ext4"
/dev/sda4: UUID="499a98c7-35fe-4e00-ad8c-797fb6b93eb2" TYPE="swap"
/dev/sda5: LABEL="VyM" UUID="be665488-1bc3-4987-a6a5-25f5e8ebd8df" TYPE="ext4"
/dev/sdb1: LABEL="De todo" UUID="aa192883-529f-4b1d-a56f-2d77af88db3c" TYPE="ext4"

+1
0
-1
Imagen de cuentos
+1
0
-1

crea el punto de montaje en tu fstab, en la terminal ejecuta;
gksudo gedit /etc/fstab
y agregas esta linea, que me imagino que es la /sda5 la que tiene como nombre , VyM:
UUID=be665488-1bc3-4987-a6a5-25f5e8ebd8d /media/VyM ext4 defaults 0 2
.
Guardas y reinicias. Con esto te montara la partición en /media/VyM
Una duda si nombras unity, pero tambien nombras a dolphin , uno es ubuntu y el otro de kubuntu. Si estas en ubuntu tienes gedit, que es el comando que te puse.

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de gragry
+1
0
-1

porque dolphin me gusta más que nautilus. Por eso la confusión.

Muchas gracias, ya mismo lo estoy haciendo.

Una última pregunta, ¿por qué no la montaba automáticamente, como en las instalaciones anteriores que hice en este disco?

+1
0
-1
Imagen de gragry
+1
0
-1

así que hice sudo gedit

y, además de abrirme el gedit, me escribió esto en la terminal

(gedit:6901): IBUS-WARNING **: The owner of /home/familia/.config/ibus/bus is not root!

¿Qué quiere decir? Otra vez muchas gracias.

+1
0
-1
Imagen de cuentos
+1
0
-1

no se recomienda sudo gedit, o en general abrir un programa del entorno gráfico con sudo ya que pueden cambiar de propietario uno o varios archivos de tu home, necesarios para iniciar sesión.

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de cuentos
+1
0
-1

En cuanto al montaje, e notado que va cambiando el punto de montaje, Antes se montaba en mnt, y cambio a /media, ahora en ubuntu 13.04 me monta en /media/alex/dispositivo, o sea en /media/usuario/usb.
Y otras distros ya descontinuaron /media y se monta en /run/usuario/dispositivo.

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de Alcruz
+1
0
-1

Te falta crear la carpeta de montaje, ejecuta
sudo mkdir /media/VyM
reinicia
Por otra parte, si quieres que las particiones se monten desde nautilus y seguramente desde dophin como antes, o sea en /media/etiqueta, ejecuta estos pasos
sudo su
pones tu pass

gedit /etc/udev/rules.d/99-correct-media-mount-point.rules

a ese documento de texto que seguramente está vacío, le agregas esta linea

ENV{ID_FS_USAGE}=="filesystem|other|crypto", ENV{UDISKS_FILESYSTEM_SHARED}="1"

Guardas, cierras y cierras terminal, a partir de ahora las unidades montadas manualmente lo harán en /media/etiqueta

+1
0
-1
Imagen de gragry
+1
0
-1

La carpeta que existe es /media/familia/VyM (la partición está dentro del nombre de usuario.

Hice lo que me dijo: (entre otras cosas)

kvm disable by bios

Filesystem check or mount failed

Le dí a no montar y entré. Luego hice click en el icono del volumen VyM y me lo montó sin problemas, en VyM3.

Parece que no es la gran cosa, pero con los torrent (que los guardo ahí) es todo un problema ya que con cada sesión de ktorrent tengo que redefinir la ubicación de los archivos uno por uno. (Y tengo muuuuuuchos archivos compartidos por torrent)

+1
0
-1
Imagen de Alcruz
+1
0
-1

A ver, ejecuta
sudo su
pones tu contraseña y puisa Enter
lugo en ese terminal pones
gedit /etc/fstab
pulsa enter y borra la entrada que pusiste
cierras todo y en otro terminal pones

gedit 111aaa

Se abrirá un archovo de texto vacío en el cual pegas lo siguiente

#!/bin/sh
mkdir /media/VyM
chown $SUDO_USER:$SUDO_USER -R /media/VyM
echo -e '# Entry for /dev/sda5 : \n UUID=be665488-1bc3-4987-a6a5-25f5e8ebd8df \t /media/VyM \t ext4 \t defaults \t 0 \t 1' >> /etc/fstab
init 6

Guaedas , cierras y cieeras terminal
Abre otro terminal y pones
sudo su
pones pu contraseña y en ese terminal y pones

bash 111aaa

Eso seróa todo , solo espera a que reinicie y ya debería montar es partición al inicio

+1
0
-1
Imagen de gragry
+1
0
-1

Hice lo que dijiste y lo monta al comienzo.
Lo malo es que encontró un error en el disco, así que ahora estoy verificando y reparando con gparted.

Muchas gracias.

+1
0
-1