Problema con XAMPP

Imagen de eduardo2013
0 puntos

Hola,
Supuestamente he instalado el XAMPP con éxito en UBUNTU.
Lo malo es que cuando abro el navegador y escribo LOCALHOST me aparece este mensaje:

It works!
This is the default web page for this server.
The web server software is running but no content has been added, yet.

Debo resaltar que, nunca me había pasado esto; antes ya instalé XAMPP en UBUNTU y cuando ponía LOCALHOST automáticamente era dirigido a una página donde salían varias opciones de XAMPP como el STATUS, SECURITY, PHPMYADMIN, ETC. Cuando pongo en la TERMINAL los códigos para arrancar el XAMPP me aparece lo siguiente:

Starting XAMPP for Linux 1.8.3-1...
XAMPP: Starting Apache...fail.
XAMPP: Starting diagnose...
XAMPP: Sorry, I've no idea what's going wrong.
XAMPP: Please contact our forum http://www.apachefriends.org/f/
Last 10 lines of "/opt/lampp/logs/error_log":
tail: no se puede abrir «/opt/lampp/logs/error.log» para lectura: No existe el archivo o el directorio
XAMPP: Starting MySQL...already running.
XAMPP: Starting ProFTPD...already running.

Luego si pongo algo como LOCALHOST/xampp/index.php sale esto:

Not Found
The requested URL /xampp/index.php/ was not found on this server.
Apache/2.2.22 (Ubuntu) Server at localhost Port 80

Como pueden notar, el servidor APACHE falla, no sé que pueda ser, pero antes de intentar actualizar PHPMYADMIN no pasaba esto ¿Alguien me puede ayudar?

POSDATA: Disculpen que esté preguntando mucho pero UBUNTU se pasa, o sea no facilita las cosas solo complica la vida; lo malo es que no puedo cambiar de sistema porque mi laptop sólo tiene 1,5 gb de ram y WINDOWS pesa 2gb, en cambio con los 700 m de UBUNTU mi máquina va mas ligera...

Imagen de cuentos
+1
0
-1

Ubuntu no se pasa, los sistemas linux al ser realmente multi-usuario tiene un verdadero control de permisos, para la propia seguridad del sistema.
Mira esta guía
http://www.ubuntu-guia.com/2011/07/instalar-xampp-en-ubuntu.html

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de Fanni.Coconut
+1
0
-1

que llega casi 3 años tarde pero como no lo veo solucionado comparto lo que me ha funcionado a mi.

Diferencias: tengo la última version de XAMPP y Ubuntu GNOME 16.04.

Fuente: https://community.apachefriends.org/f/viewtopic.php?f=17&t=51179

Código:
root@coconut-PC:/home/coconut# sudo /etc/init.d/apache2 stop
[ ok ] Stopping apache2 (via systemctl): apache2.service.
root@coconut-PC:/home/coconut# sudo /opt/lampp/lampp restart
Restarting XAMPP for Linux 5.6.23-0...
XAMPP: Stopping Apache...not running.
XAMPP: Stopping MySQL...not running.
XAMPP: Stopping ProFTPD...ok.
XAMPP: Starting Apache...ok.
XAMPP: Starting MySQL...ok.
XAMPP: Starting ProFTPD...ok.

Entiendo que esto haya podido ser un problema de puertos, que al iniciar xampp si tenia apache corriendo diese el error dado que en error_log aparece esto:

(98)Address already in use: AH00073: make_sock: unable to listen for connections on address 0.0.0.0:80
no listening sockets available, shutting down
AH00015: Unable to open logs

Aunque tampoco entiendo por qué coge la dirección 0.0.0.0:80, al menos corre.

+1
0
-1

no soporto los BiC capados.