No puedo instalar/desinstalar paquetes (Solucionado)

Imagen de DaNxMaKiNa
0 puntos

Resulta que estaba actualizando flightgear cuando se fué la luz, volví a encender el portátil y al intentar reanudar la actualización me da error.

Trasteé un poco por Google y no encontré nada, y al intentar instalar algo desde la terminal, me suelta este mensaje:

"danx@danx-HP-Compaq-6720s:~$ sudo apt-get install the-powder-toy
S'està llegint la llista de paquets… Fet 0%
S'està construint l'arbre de dependències
S'està llegint la informació de l'estat… Fet%
the-powder-toy ja es troba en la versió més recent.
Potser voldreu executar «apt-get -f install» per corregir-ho:
Els següents paquets tenen dependències sense satisfer:
fgfs-models-base : Trenca: fgfs-base (< 2.10.0) però s'instaŀlarà 2.6.0-1.1
flightgear : Depèn: fgfs-base (>= 2.10.0) però s'instaŀlarà 2.6.0-1.1
E: Dependències insatisfetes. Proveu amb «apt-get -f install» sense paquets (o especifiqueu una solució)."

Está en catalán, la traducción sería:

danx@danx-HP-Compaq-6720s: ~ $ sudo apt-get install the-powder-toy
Leyendo lista de paquetes ... Hecho 0%
Se está construyendo el árbol de dependencias
Leyendo la información del estado ... Hecho%
the-powder-toy ya se encuentra en la versión más reciente.
Tal vez quiera ejecutar «apt-get -f install» para corregirlo:
Los siguientes paquetes tienen dependencias sin satisfacer:
fgfs-models-base: Rompe: fgfs-base (<2.10.0) pero se instalará 2.6.0-1.1
flightgear: Depende: fgfs-base (> = 2.10.0) pero se instalará 2.6.0-1.1
E: Dependencias insatisfechas. Pruebe con «apt-get -f install» sin paquetes (o especifique una solución).

Entonces ejecuto "apt-get -f install" y me suelta:

"danx@danx-HP-Compaq-6720s:~$ apt-get -f install
E: No es pot resoldre el fitxer de blocat /var/lib/dpkg/lock - open (13: S’ha denegat el permís)
E: No es pot blocar el directori d'administració (/var/lib/dpkg/), sou root?"

Traducción:

"danx @ danx-HP-Compaq-6720s: ~ $ apt-get -f install
E: No se puede resolver el archivo de bloqueo /var/lib/dpkg/lock - open (13: Se ha denegado el permiso)
E: No se puede bloquear el directorio de administración (/var/lib/dpkg/), eres root?"

Me pongo en root, vuelvo a ejecutar "apt-get install" y:

"root@danx-HP-Compaq-6720s:/home/danx# apt-get -f install
S'està llegint la llista de paquets… Fet 0%
S'està construint l'arbre de dependències
S'està llegint la informació de l'estat… Fet%
S'estan corregint les dependències… Fet
Els paquets següents s'han instaŀlat automàticament i ja no són necessaris:
fgfs-scenery-base libalut0 simgear2.6.0
Empreu «apt-get autoremove» per a suprimir-los.
S'instaŀlaran els següents paquets extres:
fgfs-base
S'actualitzaran els paquets següents:
fgfs-base
1 actualitzats, 0 nous a instaŀlar, 0 a suprimir i 101 no actualitzats.
1 no instaŀlats o suprimits completament.
S'ha d'obtenir 550 MB d'arxius.
Després d'aquesta operació s'empraran 189 MB d'espai en disc addicional.
Voleu continuar [S/n]? s
Bai:1 http://archive.getdeb.net/ubuntu/ raring-getdeb/games fgfs-base all 2.10.0-1~getdeb1 [550 MB]
S'ha baixat 550 MB en 20min 29s (447 kB/s)
(S'està llegint la base de dades… hi ha 319978 fitxers i directoris instaŀlats actualment.)
S'està preparant per a reemplaçar fgfs-base 2.6.0-1.1 (emprant …/fgfs-base_2.10.0-1~getdeb1_all.deb)…
S'està desempaquetant el reemplaçament de fgfs-base…
dpkg: s'ha produït un error en processar /var/cache/apt/archives/fgfs-base_2.10.0-1~getdeb1_all.deb (--unpack):
s'està intentant sobreescriure «/usr/share/games/flightgear/Scenery/Airports/8/Q/1/8Q1.threshold.xml», que també està en el paquet fgfs-scenery-base 2.6.0-1.1
dpkg-deb: s'ha produït un error: el subprocés enganxa ha estat finalitzat pel senyal (La canonada s’ha trencat)
S'han trobat errors en processar:
/var/cache/apt/archives/fgfs-base_2.10.0-1~getdeb1_all.deb
S'ha produït un error: S'ha esgotat el temps d'espera
E: Sub-process /usr/bin/dpkg returned an error code (1)"

Traducción:

"root @ danx-HP-Compaq-6720s :/home/danx # apt-get -f install
Leyendo lista de paquetes ... Hecho 0%
Se está construyendo el árbol de dependencias
Leyendo la información del estado ... Hecho%
Se están corrigiendo las dependencias ... Hecho
Los siguientes paquetes se han instalado automáticamente y ya no son necesarios:
fgfs-scenery-base libalut0 simgear2.6.0
Utilice «apt-get autoremove» para suprimirlos.
Se instalarán los siguientes paquetes extras:
fgfs-base
Se actualizarán los siguientes paquetes:
fgfs-base
1 actualizados, 0 nuevos a instalar, 0 para eliminar y 101 no actualizados.
1 no instalados o suprimidos completamente.
Se debe obtener 550 MB de archivos.
Tras esta operación se emplearán 189 MB de espacio en disco adicional.
¿Desea continuar [S / n]? s
Bai: 1 http://archive.getdeb.net/ubuntu/raring-getdeb/games fgfs-base all 2.10.0-1 ~ getdeb1 [550 MB]
Se ha bajado 550 MB en 20min 29s (447 kB / s)
(Leyendo la base de datos ... hay 319.978 ficheros y directorios instalados actualmente.)
Se está preparando para reemplazar fgfs-base 2.6.0-1.1 (empleando ... /fgfs-base_2.10.0-1 ~ getdeb1_all.deb) ...
Desempaquetando el reemplazo de fgfs-base ...
dpkg: error al procesar /var/cache/apt/archives/fgfs-base_2.10.0-1 ~ getdeb1_all.deb (- unpack):
se está intentando sobrescribir «/usr/share/games/flightgear/Scenery/Airports/8/Q/1/8Q1.threshold.xml», que también está en el paquete fgfs-scenery-base 2.6.0-1.1
dpkg-deb: se ha producido un error: el subproceso pega ha sido finalizado por la señal (La tubería se ha roto)
Se encontraron errores al procesar:
/var/cache/apt/archives/fgfs-base_2.10.0-1 ~ getdeb1_all.deb
Se ha producido un error: Se ha agotado el tiempo de espera
E: Sub-process /usr/bin/dpkg returned an error code (1)"

Y nada, he intentado eliminar el paquete con "apt-get remove flightgear" tanto en danx como en root y me dice lo del primer texto. También he intentado borrar los paquetes uno a uno manualmente y tampoco ha servido. Ya no se qué hacer, ayuda :'C

P.D.: Mi versión de Ubuntu es 13.04 Raring Ringtail

Imagen de cuentos
+1
0
-1

también traes un problema mas anterior ya que como te dice:
101 no actualizados.
Prueba con :
sudo apt-get dist-upgrade

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de cuentos
+1
0
-1

Que se me olvido comentar, lo de los paquetes retenidos, puede ser un problema de dependencias.
Un posible repositorio externo que agregaste, o sea ppa, etc...

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de DaNxMaKiNa
+1
0
-1

Muchas gracias Cuentos, efectivamente era un problema de una ppa, la he desactivado, he desinstalado el paquete y he actualizado con el sudo apt-get dist-upgrade. Problema solucionado, gracias!

+1
0
-1