No funciona capturadora de video Easycap

Imagen de PabloCordova22
0 puntos

Buenas, me he comprado una easycap para poder obtener el video de una camara analogica via USB, para utilizarlo con una libreria(opencv). Pero primero quiero hacerlo funcionar independientemente en ubuntu.

Compre la easycap de 4 canales de video(driver syntek) porque lei que su driver es soportado en ubuntu.
tenia el ubuntu 11.04 con kernel 2.6 lo conecte pero no me reconocio, asi que actualice todo, el ubuntu a 12.04 LTS y el kernel al 3.9, ahora si me reconoce el driver ya que cuando coloco "lsusb" me aparece el driver reconocido, ademas cada ves que lo conecto en "dev" aparece "video0" pero cuando intento ver el video me aparece una pantalla de color verde, ya me leido bastantes paginas pero sin encontrar la solucion.

Datos adicionales:

lsusb:
Bus 005 Device 003: ID 05e1:0408 Syntek Semiconductor Co., Ltd STK1160 Video Capture Device

para ver el video(lo ejecuto sin sonido porque este easycap vino sin chip de sonido),(tambien aqui he variado las entradas "input", intentando con los 4 canales),(ademas tambien he variado la norma a "PAL"):
mplayer tv:// -tv driver=v4l2:width=720:height=480:outfmt=uyvy:norm=NTSC_M:device=/dev/video0:input=1:fps=25 -vo sdl -nosound

Lo intente correr en Windows Xp, windows 7 y windows 8 instalando el driver que viene en su cd pero tampoco funciona.(en Xp funciona de forma muy distorcionada).

Lo he probado con 2 tipos de camaras , con los mismos resultados de la pantalla verde.

Espero que me puedan ayudar o me puedan dar algun consejo.
Gracias.