Problema con la instalación de la Canon MP495

Imagen de Lelo
0 puntos

Hola.
He hecho lo siguiente:
Bajo el fichero de la página de Canon ( http://www.canon.es/Support/Consumer_Products/products/Fax__Multifunctio... ), que es un tar.gz, lo descomprimo (hai dentro otros 3 paquetes: rpm, deb y una ayuda), descomprimo también el deb. Entro en el directorio que se crea, donde están el install.sh y dos subdirectorios: packages y resources.
Una vez dentro (desde la consola), ejecuto el install.sh:

~/cnijfilter-mp495series-3.40-1-deb$ sudo ./install.sh

Y entonces me da el siguiente error:
==================================================

Canon Inkjet Printer Driver Ver.3.40-1 for Linux
Copyright CANON INC. 2001-2010
All Rights Reserved.

==================================================
An error occurred. The package management system cannot be identified.

Y de aquí no paso. También he intentado (pero no entiendo una palabra de esto y a lo mejor es una barbaridad) entrar en el subdirectorio packages e intentar instalar (aquí ya no por consola sino con doble clic en el modo gráfico) los dos paquetes deb correspondientes a i386. Lo que ocurre es que abre el gestor de instalaciones y cuando le doy al botón de instalar -como si instalase algo del repositorio- hace como que instala pero al terminar vuelve a aparecer el botón instalar como si no hubiese instalado.

La impresora desde el principio es detectada por ubuntu, pero aparece en gris en la lista de impresoras y, por supuesto, no imprime. En Windows, en otro portátil, si funciona.

Gracias adelantadas a quien me pueda dar alguna pista de por donde seguir.

Muchas gracias a todos.

Saludos,