Dpkg no configura linux-generic

Imagen de YourHero26
0 puntos

Buenas, queria pedir ayuda pues cada vez que instalo o desintalo cualquier cosa, al final de la instalación siempre me aparece esto (Pego el texto de la terminal):

yourhero26@yourhero26-Aspire-5755G:~$ sudo apt-get -f install
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
0 actualizados, 0 se instalarán, 0 para eliminar y 0 no actualizados.
4 no instalados del todo o eliminados.
Se utilizarán 0 B de espacio de disco adicional después de esta operación.
Configurando linux-image-3.8.0-31-generic (3.8.0-31.46) ...
Running depmod.
update-initramfs: deferring update (hook will be called later)
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 3.8.0-31-generic /boot/vmlinuz-3.8.0-31-generic
run-parts: executing /etc/kernel/postinst.d/dkms 3.8.0-31-generic /boot/vmlinuz-3.8.0-31-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.8.0-31-generic /boot/vmlinuz-3.8.0-31-generic
update-initramfs: Generating /boot/initrd.img-3.8.0-31-generic
run-parts: executing /etc/kernel/postinst.d/pm-utils 3.8.0-31-generic /boot/vmlinuz-3.8.0-31-generic
run-parts: executing /etc/kernel/postinst.d/update-notifier 3.8.0-31-generic /boot/vmlinuz-3.8.0-31-generic
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 3.8.0-31-generic /boot/vmlinuz-3.8.0-31-generic
/usr/sbin/grub-mkconfig: 35: /etc/default/grub: Syntax error: EOF in backquote substitution
run-parts: /etc/kernel/postinst.d/zz-update-grub exited with return code 2
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-3.8.0-31-generic.postinst line 1010.
dpkg: error al procesar linux-image-3.8.0-31-generic (--configure):
el subproceso instalado el script post-installation devolvió el código de salida de error 2
dpkg: problemas de dependencias impiden la configuración de linux-image-extra-3.8.0-31-generic:
linux-image-extra-3.8.0-31-generic depende de linux-image-3.8.0-31-generic; sin embargo:
El paquete `linux-image-3.8.0-31-generic' no está configurado todavía.

dpkg: error al procesar linux-image-extra-3.8.0-31-generic (--configure):
problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de linux-image-generic:
linux-image-generic depende de linux-image-3.8.0-31-generic; sin embargo:
El paquete `linux-image-3.8.0-31-generic' no está configurado todavía.
linux-image-generic depende de linux-image-extra-3.8.0-31-generic; sin embargo:
El paquete `linux-image-extra-3.8.0-31-generic' no está configurado todavía.

dpkg: error al procesar linux-image-generic (--configure):
problNo se escribió un informe «apport» porque el mensaje de error indica que es un mensaje de error asociado a un fallo previo.
No se escribió un informe «apport» porque el mensaje de error indica que es un mensaje de error asociado a un fallo previo.
No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
emas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de linux-generic:
linux-generic depende de linux-image-generic (= 3.8.0.31.49); sin embargo:
El paquete `linux-image-generic' no está configurado todavía.

dpkg: error al procesar linux-generic (--configure):
problemas de dependencias - se deja sin configurar
Se encontraron errores al procesar:
linux-image-3.8.0-31-generic
linux-image-extra-3.8.0-31-generic
linux-image-generic
linux-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)

Antes esto no me salia nunca, ¿Alguien sabe cual puede ser la solución?
Gracias de antemano.

Imagen de cuentos
+1
0
-1

A actualizar el sistema, con:
sudo apt-get full-upgrade

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de YourHero26
+1
0
-1

Gracias por contestar cuentos, he hecho lo que me dices pero al final sigue diciendome que no ha podido procesar esos paquetes. ¿Alguna otra idea?

+1
0
-1
Imagen de cuentos
+1
0
-1

traes el problema con dependencias mas "anterior".
pon lo que te sale al actualizar la lista de programas y el sistema, pero como la lista es grande se pide que lo pongas en paste, http://paste.ubuntu.com/
Es fácil pones un nombre, pegas el texto, y presionas paste, y nla pagina te crea una liga (link). lo pones aquí para ver.
los comandos serian:
sudo apt-get update
sudo apt-get dist-upgrade
ls -l /etc/apt/sources.list.d

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos