configurar wifi (empezando en ubuntu)

Imagen de Matelot
0 puntos

Hola a ver amigos, me estoy metiendo en esto del ubunto con muchas ganas y también mucho dolor de cabeza, lo que vais a leer ahora igual os parecen tonterías, pero por favor no os rías mucho de mi, por que estoy completamente perdido

se supone que tengo que aprender a programar en C, y para ello en mis clases usamos kubuntu, su terminal y el programa vim, así que he decidido pasarme a ubuntu para hacerme un hacker o lo que surja

me he instalado mediante el instalador automático el ubunto 12, y una vez dentro me surgen varias dudas;

1. Tengo que bajar vim para linux para hacerlo funcionar en ubuntu? la terminal ya viene instalada?

2. No se como configurar el wifi, mi máximo conocimiento sobre como hacer esto es poner la contraseña en windows donde me sale el icono de orange, así que cuando veo en otros post de soluciones cosas sobre la DNS o datos raros me pierdo mucho, se que se supone que en la página principal pone que ejecutemos estos comandos->

sudo su
lspci
lspci | grep -i ethernet
lspci | grep -i network
lsusb
lsusb | grep -i ethernet
lsusb | grep -i network
lsmod | grep iwl
ifconfig
iwconfig

bueno hasta donde ha llegado mi inteligencia es a ponerlo en el cmd de windows y solo me de incoherencias

bueno eso es todo por ahora, agradecería mucho una ayuda

un saludo

Imagen de cuentos
+1
0
-1

probando en la terminal y mirar si esta instalado (normalmente en todas las distros viene por defecto).
al igual que la terminal viene por defecto en la mayoría de las distros. (por no decir que en todas). En kde, se llama konsole.
En cuanto a la wifi si pusieras el modelo de esta para ver, los comandos que nombras son para que pongas lo que te sale (o sea información) para ver que modelo es y que se te puede recomendar).
De paso lee las normas del foro ya que se permite un problema por hilo, ya que que se hace un verdadero desbarajuste al tratar varios problemas a la vez.

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de Matelot
+1
0
-1

ok, esto es lo que me da en la terminal

00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b4)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b4)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM65 Express Chipset Family LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 04)
02:00.0 Ethernet controller: Broadcom Corporation NetLink BCM57785 Gigabit Ethernet PCIe (rev 10)
02:00.1 SD Host controller: Broadcom Corporation NetXtreme BCM57765 Memory Card Reader (rev 10)
02:00.2 System peripheral: Broadcom Corporation Device 16be (rev 10)
02:00.3 System peripheral: Broadcom Corporation Device 16bf (rev 10)
03:00.0 Network controller: Broadcom Corporation BCM43227 802.11b/g/n
matelote@ubuntu:~$
matelote@ubuntu:~$ lspci | grep -i ethernet
02:00.0 Ethernet controller: Broadcom Corporation NetLink BCM57785 Gigabit Ethernet PCIe (rev 10)
matelote@ubuntu:~$
matelote@ubuntu:~$ lspci | grep -i network
03:00.0 Network controller: Broadcom Corporation BCM43227 802.11b/g/n
matelote@ubuntu:~$
matelote@ubuntu:~$ lsusb
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 04fc:2801 Sunplus Technology Co., Ltd
Bus 002 Device 003: ID 0781:556b SanDisk Corp.
matelote@ubuntu:~$
matelote@ubuntu:~$ lsusb | grep -i ethernet
matelote@ubuntu:~$
matelote@ubuntu:~$ lsusb | grep -i network
matelote@ubuntu:~$
matelote@ubuntu:~$ lsmod | grep iwl
matelote@ubuntu:~$
matelote@ubuntu:~$ ifconfig
eth0 Link encap:Ethernet HWaddr b8:70:f4:fa:41:83
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:16

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:48 errors:0 dropped:0 overruns:0 frame:0
TX packets:48 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3936 (3.9 KB) TX bytes:3936 (3.9 KB)

+1
0
-1
Imagen de cuentos
+1
0
-1

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de Matelot
+1
0
-1

ok, dime si es correcto, lo que tengo que hacer es, poner esto en mi terminal;

lspci -vvnn | grep 14e4

y según lo que me de buscar unos drivers?

osea tengo que reiniciar entrar en ubuntu, hacer eso, volver a windows bajar drivers y ir a ubuntu a instalarlos y ya funcionará?

+1
0
-1
Imagen de cuentos
+1
0
-1

a la tarjeta que tienes , en el primer hilo te dan lo que tienes que hacer, seria, en la terminal ejecutar estos comandos:
------------------------------------------
sudo apt-get install --reinstall bcmwl-kernel-source
sudo modprobe wl
--------------------------------
si en el segundo comando no te da error reinicias y listo.

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de Matelot
+1
0
-1

bueno de momento copio lo que me acaba de dar con esto->
lspci -vvnn | grep 14e4

->

02:00.0 Ethernet controller [0200]: Broadcom Corporation NetLink BCM57785 Gigabit Ethernet PCIe [14e4:16b5] (rev 10)
02:00.1 SD Host controller [0805]: Broadcom Corporation NetXtreme BCM57765 Memory Card Reader [14e4:16bc] (rev 10) (prog-if 01)
02:00.2 System peripheral [0880]: Broadcom Corporation Device [14e4:16be] (rev 10)
02:00.3 System peripheral [0880]: Broadcom Corporation Device [14e4:16bf] (rev 10)
03:00.0 Network controller [0280]: Broadcom Corporation BCM43227 802.11b/g/n [14e4:4358]

ahora pondré los que me has dicho, tengo que ir reiniciando para entrar en ubuntu, por eso tardo en hacerlo

+1
0
-1
Imagen de Matelot
+1
0
-1

hola al poner esto

sudo apt-get install --reinstall bcmwl-kernel-source
sudo modprobe wl

me sale esto otro

matelote@ubuntu:~$ sudo apt-get install --reinstall bcmwl-kernel-source
[sudo] password for matelote:

cuando intento poner el password no me deja completarlo o cuando lo completo sigue sin darme como valido

+1
0
-1
Imagen de cuentos
+1
+1
-1

que la clave de administrador te la reconozca, si no no podrás hacer nada en el sistema, debe de ser la misma con la que te registras,
prueba con:
---------------------------
sudo su
---------------------------
pones tu contraseña y te manda como administrador (root). y luego ejecutas:
---------------------------
apt-get install --reinstall bcmwl-kernel-source
modprobe wl
-------------------------
lo de sudo su es para que solo puedas entrar como administrador.

+1
+1
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de Matelot
+1
0
-1

ok ya lo he hecho, me sale esto

root@ubuntu:/home/matelote# apt-get install --reinstall bcmwl-kernel-source
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Se instalarán los siguientes paquetes extras:
dkms fakeroot
Se instalarán los siguientes paquetes NUEVOS:
bcmwl-kernel-source dkms fakeroot
0 actualizados, 3 se instalarán, 0 para eliminar y 0 no actualizados.
Necesito descargar 1.312 kB de archivos.
Se utilizarán 4.182 kB de espacio de disco adicional después de esta operación.
¿Desea continuar [S/n]? n
Abortado.
root@ubuntu:/home/matelote# apt-get install --reinstall bcmwl-kernel-source
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Se instalarán los siguientes paquetes extras:
dkms fakeroot
Se instalarán los siguientes paquetes NUEVOS:
bcmwl-kernel-source dkms fakeroot
0 actualizados, 3 se instalarán, 0 para eliminar y 0 no actualizados.
Necesito descargar 1.312 kB de archivos.
Se utilizarán 4.182 kB de espacio de disco adicional después de esta operación.
¿Desea continuar [S/n]? s
Abortado.

tanto si le doy al "s" como al "n" me sale "Abortado"

+1
0
-1
Imagen de Goyo
+1
+1
-1

Intenta con 'S', 'y', 'Y' o simplemente enter sin escribir nada.

+1
+1
-1
Imagen de Matelot
+1
0
-1

no me funciona tampoco con ninguna de esas tres opciones

+1
0
-1