Problema con el gestor de actualizaciones. Ubuntu 12.04 LTS

Imagen de skacookie
0 puntos

El problema es que cuando intento actualizar con gestor de actualizaciones, me sale el error:
"Una instalación previa no se completó. La instalación pudo haber fallado por un error en los paquetes correspondientes de software o se canceló de una manera incorrecta. Debe reparar esto antes de poder instalar o eliminar cualquier otro software.
Detalles
E:The package index files are corrupted. No Filename: field for package ubuntu-keyring."

Entonces, después de leer sobre problemas similares, encuentro que con los siguientes comandos en la terminal, se puede solucionar:
sudo su
apt-get update
apt-get install -f
dpkg --configure -a
apt-get autoremove
apt-get dist-upgrade
apt-get clean

Pero entonces, despues de "apt-get dist-upgrade" me aparece de nuevo el mensaje "E: Los archivos de índice de paquetes están dañados. No existe un campo «Filename:» para el paquete ubuntu-keyring."
Así que la solución que encuentro googleando (http://askubuntu.com/questions/216273/problems-updating-system-with-apt-get) es que debo borrar este indice y despues actualizar otra vez (sudo rm /var/lib/apt/lists/* , sudo apt-get update), pero no asegura mucho y no confirman si ha funcionado, así que mi duda es si debo o no borrar todo y actualizar ?? o sino, que me pueden recomendar??
gracias y saludos.

Imagen de Goyo
+1
0
-1

No entiendo bien. ¿Si te digo yo que debes hacer eso me crees más que si te lo dice otro en askubuntu?
Yo en caso de duda hago copias de seguridad antes de eliminar o modificar archivos.

+1
0
-1
Imagen de skacookie
+1
0
-1

es mas bien que si a alguien le ha pasado lo mismo, me pueda confirmar que funcione.
Pero supongo que como dices, lo mejor será hacer copias de seguridad y probar.

+1
0
-1
Imagen de Goyo
+1
0
-1

A mí no me ha ocurrido pero hay varios sitios en los que se recomienda esta solución y también algunas confirmaciones de que ha funcionado.

+1
0
-1