Partición de swap bloqueada

Imagen de Litio.yo
0 puntos

Hola a todos, a ver si alguien puede ayudarme.

En principio tenía instalada una versión 12.04 de UBUNTU y cambié la tarjeta gráfica a una nvidia ge-force 210 al instalar los drivers de la tarjeta (por error instalé la versión 173) el equipo se quedó colgado después de reiniciarlo y los monitores se quedaron en "negro". Como tenía intención de instalar la versión 13.04 y tenía copia de seguridad de todos los datos, en principio no me importó y decidí hacer una instalación desde cero de la 13.04. Como tenía las pantallas en "negro" hice un reset al equipo y a partir de aquí empezaron todos los problemas, como el apagado del equipo no fue correcto al intentar instalar la nueva versión me sale tozudamente el mismo error cuando se va a particionar el disco duro "No puedo acceder a la partición de swap sda5". Tengo un disco duro de un TB y aparentemente la partición de swap que había con la versión 12.04 se ha quedado marcada como en uso exclusivo por algún proceso y cuando miro el tamaño del disco veo que faltan los 10Gb que tenía asignados de swap originalmente. Me he descargado el CD-Live de GParted, pero soy incapaz de regenerar el disco.

He probado a crear una nueva tabla de particiones con gparted, pero sigue faltandome el espacio que asigné originalmente a swap y he visto por los foros el uso del comando "dd if=/dev/zero of=/dev/sda1" pero sinceramente, me da miedo aplicarlo a un disco de 1TB a parte de que no se si será efectivo para corregir el problema, pues gparted dice que sda1 tiene un tamaño de 931000 Mb.

¿Alguien puede echarme una mano sobre como proceder?.

Gracias anticipadas.

Imagen de .doc
+1
0
-1

lo primero que tienes que hacer es, con el GParted Live, es 'desmontar' la partición swap. Con Partición - Desmontar, claro.

+1
0
-1
Imagen de Litio.yo
+1
-1
-1

El problema es que esa partición no me aparece en gparted .... al menos en el entorno gráfico ... en modo consola no se hacerlo ... he probado con testdisk, pero no me aclaro.
Para la unidad sda1 gparted me dice que tiene un tamaño 1000000 / 931000 pero solo me muestra un espacio no particionado de 931000 Mb

+1
-1
-1
Imagen de Litio.yo
+1
-1
-1

Cuando ejecuto testdisk me aparecen estos cinco comentarios:
- Hiden sectors are present
- size 1953523055 sectors
- user_max 1953523055 sectors
- native_max 1953525168 sectors
- Host Protected Area (HPA) present.

+1
-1
-1
Imagen de .doc
+1
+1
-1

a ver, no compliquemos la cosa... detállanos, primero, cómo tienes particionado el disco. Para eso abre una consola (terminal) y copia y pega esto:
sudo fdisk -l
(es 'fdisk' espacio 'signo menos' y 'ele') y pegas el resultado aquí

+1
+1
-1
Imagen de Litio.yo
+1
0
-1

No podré responder hasta el lunes ... estoy fuera de casa y no tengo acceso a mi ordenador.

+1
0
-1
Imagen de Litio.yo
+1
0
-1

Bien, despues de pasar el fdisk -l me sale esto:
Disk /dev/sda: 1000.2 GB, 1000203804160 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953523055 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x00000000

Disk /dev/sda doesn't contain a valid partition table

+1
0
-1
Imagen de .doc
+1
0
-1

¿eso es todo lo que te dice el sudo fdisk -l...? y ¿que no contiene una tabla de particiones válida? pues si es así, algo has hecho que 'la has cagado' y tendrás que crear una nueva tabla de particiones. Con GParted, en modo LiveCD. Te borrará todos los archivos, claro.

(yo te sugeriría hacerla del tipo MsDOS, que es el tipo de particionado clásico ('el de de toda la vida'), fijar antes, pensándolo bien, tu 'estrategia de particionado' (qué particiones quieres tener, y su tamaño y tipo) y empezar a instalar todo, de nuevo).

+1
0
-1
Imagen de Litio.yo
+1
0
-1

No, si mi problema no es rescatar nada, el problema es que cuando trato de instalar "desde cero" la versión 13.04 de ubuntu, cuando llega al punto de particionar el disco duro me manda un mensaje que dice que no puede escribir en el swap, que es por lo que pienso que se la antigua partición de swap se ha quedado pillada, pues me hace referencia a la partición sda5 que es donde tenía montado el swap originalmente y he intentado instalar el ubuntu desde 3 CD's distintos (por si ubiera algún error de grabación) y con dos lectores de DVD diferentes.

Lo que me llama la atención es que cuando arranco gparted me informa de un espacio de 931 Gb mientras que Fdisk dice que tiene 1000,2 Gb

+1
0
-1
Imagen de Goyo
+1
0
-1

Aunque no lo creas, el pelma de tu profesor de ciencias tenía razón y las unidades son importantes. fdisk da el tamaño del disco en GB y gparted en GiB (en ningún caso Gb).

+1
0
-1
Imagen de .doc
+1
+1
-1

pues crea una nueva tabla de particiones, con GParted en modo Live, y solucionado ¿no?.

Sobre esas diferencias de Gb mejor que no te fijes en ellas, y te evitas comerte el coco con algo que solo es cuestión de cómo está medida esa capacidad, o qué se considera. Yo también tengo ese 7% de diferencia entre lo que dice GParted y lo que dice fdisk -l

+1
+1
-1
Imagen de Litio.yo
+1
0
-1

Ya me permite montar el swap y tengo instalado UBUNTU 13.04. Finalmente ejecuté "dd if=/dev/zero of=/dev/sda" y dejó de darme el problema de acceso a la partición swap. Eso sí, se tiró todo el día y toda la noche en ejecutar el comando pero hoy poco antes de las ocho ha termiado. Muchas gracias por el interés

+1
0
-1