VirtualBox error

Imagen de seya1984
0 puntos

Saludos
instale VirtualBox del repositorio sin ningun problema, cree una maquina virtual con Xp y funciono perfectamente por varios dias, sin embargo, de repente, cuando voy a iniciar cualquier maquina virtual en VirtualBox me sale el siguiente error:
----------
Fallo al abrir una sesión para la máquina virtual.
Failed to load VMMR0.r0 (VERR_SUPLIB_OWNER_NOT_ROOT).

Código Resultado: NS_ERROR_FAILURE (0x80004005)
Componente: Console
Interfaz: IConsole {db7ab4ca-2a3f-4183-9243-c1208da92392}
----------
he probado de todo, desinstalar VBox, reinstalarlo, borrar las maquinas virtuales, crear nuevas, diferentes versiones de VBox, las de Oracle y la de la distro y nada... siempre el mismo error, por lo que me queda pensar que es un error del SO?

No entiendo como un software de funcionar bien, paso, de repente y sin hacer nada, a malfuncionar...eso nunca me sucedio en windows. El tiempo que he perdido tratando de dar con una solucion a esto es lo que me hace pensar dos veces si vale la pena usar linux para trabajar. El SO no esta ahi para ser bello, ni poder toquetearlo o jugar con el por horas, esta para ser invisible, transparente al usuario y que no se entrometa entre las aplicaciones y el. Si aun trato de hayar la solucion es porque prefiero creer que es por ignorancia mia.
Agradeceria cualquier ayuda.

Imagen de .doc
+1
0
-1

verás, lo principal es mantener actitud positiva, y analítica, para tratar de resolver tus problemas. Los sistemas operativos no estropean las cosas ellos solos, quizás deban conocerse mejor, y no juzgarlos por un caso particular con una aplicación instalada.

Así que no te preocupes, vuelve a tu windows, con el que dices que nunca te ha pasado nada raro, que nadie se va a molestar por eso. Por cierto, cualdo dices que has probado todo, incluso desinstalar y reinstalar varias veces esa aplicación... ¿borrabas todo rastro de la aplicación, incluyendo los archivos ocultos que aparecerían en tu /home?

+1
0
-1
Imagen de seya1984
+1
0
-1

Bueno, finalmente encontre la solucion, y si se debia a ignorancia mia en parte y a algun mal disenno de software:
por alguna razon algun programa le cambio los permisos a /usr/lib , y los restaure a root.
Ahora carga nuevamete la maquina virtual...pero la duda que me surge ahora es porque sucede esto?
tip: Para los que no les gusta usar la consola, porque en un SO mainstream la consola seria una mala palabra, sencillamente abren el administrador de ficheros como root y manipulan los permisos desde ahi.

+1
0
-1
Imagen de seya1984
+1
0
-1

Gracias por tu comentario. de ninguna forma pienso volver a windows. por eso persisto aqui, pero lo chocante es que esas cosas no deben pasar si queremos que Ubuntu acapare a ese gran sector que es el desktop.
Si es chocante que mientras hay aplicaciones bien enpaquetadas en .deb, rpm, etc hayan otras que los desarrolladores las tengan tan "primitivas" y desorganizadas: -copia estos archivos a esta carpeta, edita este de configuracion, ejecuta este script ... vamos que es un desastre.
No me doy por vencido y estoy seguro de que pronto los sistemas linux deberan converger en facilidad de uso y calidad de la distribucion del software, por eso me quedo y porque windows cada vez da mas bandazos a lo torpe y tira por el vater todo el tiempo y conocimiento invertidos en el con cada nueva version.

+1
0
-1
Imagen de .doc
+1
0
-1

bueno, uno de los principales 'consejos de toda la vida' es el de instalar siempre desde los repositorios oficiales, y entonces no pasa todo lo que dices. En una palabra, instalar 'al estilo Linux', y no al estilo Windows.

+1
0
-1