Error al instalar qt y libreria freeglut (solucionado)

Imagen de tobillas92
0 puntos

Antes de nada, estoy en la versión Ubuntu 11.04.

Deseaba instalar qt y la librería freeglut, con los comandos:
sudo apt-get install qt-sdk
sudo apt-get install qt-creator
pero me devuelve un error:

cristobal@cristobal-Aspire-5741G:~/Escritorio/practica1$ sudo apt-get install qt-creator
[sudo] password for cristobal:
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
E: No se ha podido localizar el paquete qt-creator

y para la biblioteca:
sudo apt-get install freeglut3 freeglut3-dev
sudo apt-get install binutils-gold

al ejecutar "sudo apt-get install freeglut3 freeglut3-dev" los ultimos mensajes que me devuelve son:
[...]
Imposible obtener http://es.archive.ubuntu.com/ubuntu/pool/main/libs/libsm/libsm-dev_1.2.0... 404 Not Found
Imposible obtener http://es.archive.ubuntu.com/ubuntu/pool/main/libx/libxt/libxt-dev_1.0.9... 404 Not Found
E: No se pudieron obtener algunos archivos, ¿quizás deba ejecutar «apt-get update» o deba intentarlo de nuevo con --fix-missing?

con el comando "sudo apt-get install binutils-gold" me devuelve:

eyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios.
linux-headers-2.6.38-8 linux-headers-2.6.38-8-generic
Utilice «apt-get autoremove» para eliminarlos.
Se instalarán los siguientes paquetes NUEVOS:
binutils-gold
0 actualizados, 1 se instalarán, 0 para eliminar y 0 no actualizados.
Necesito descargar 1444 B de archivos.
Se utilizarán 45,1 kB de espacio de disco adicional después de esta operación.
AVISO: ¡No se han podido autenticar los siguientes paquetes!
binutils-gold
¿Instalar estos paquetes sin verificación [s/N]? s
Err http://es.archive.ubuntu.com/ubuntu/ natty-updates/universe binutils-gold i386 2.21.0.20110327-2ubuntu3
404 Not Found
Imposible obtener http://es.archive.ubuntu.com/ubuntu/pool/universe/b/binutils/binutils-go... 404 Not Found
E: No se pudieron obtener algunos archivos, ¿quizás deba ejecutar «apt-get update» o deba intentarlo de nuevo con --fix-missing?

Agradecería que me ayudasen, no tengo mucha idea con respecto a estos problemas.
Gracias de antemano!

Imagen de Goyo
+1
+1
-1

Es debido a que tu lista de paquetes disponibles está obsoleta y contiene paquetes que en realidad ya no existen. Al intentar descargar un archivo que no existe se produce el error.

Por otro lado si tratas de actualizar la lista de paquetes también obtendrás un error porque el soporte para tu versión de Ubuntu terminó hace tiempo, así que ya no hay listas actualizadas disponibles.

Debes actualizar a una versión soportada de Ubuntu.

+1
+1
-1
Imagen de tobillas92
+1
0
-1

Hablando con un compañero descubrió el problema, que era el que comentaba Goyo.
Me metí en el post para cambiarlo a "solucionado", y me a sorprendido que me lo solucionen tan pronto, asique solo puedo decir que gracias a usuarios así y enhorabuena a la página!
Intentaré aportar y aprender todo lo que pueda.

+1
0
-1