Un portatil, Dos discos Duros; En uno win8.1 y en el otro Ubuntu. Problema con Grub

Imagen de Brunozq
0 puntos

A ver chicos, tengo un lio en el portatil...
El portatil tiene windows8.1 original Con UEFI. No me aclaro con windows 8.1 es muy poco intuitivo. Pero lo necesito por cuestiones de programas.

Como no, win8 ocupa las 4 particiones primarias. Asi que para instalar ubuntu me compro un adaptador de Disco duro SATA que va en la ranura de la unidad optica. Genial ya tengo dos discos duros independientes en el portatil.

Instalo ubuntu 13.10 en el nuevo HDD previa desactivación del sistema UEFI. Hasta aqui prefecto, ahora el problema:

Ubuntu me pregunta donde instalar GRUB. Yo le digo que en el HDD donde esta Win8.1, me salta error fatal.
Luego lo intento instalandolo en el otro HDD, me deja y termina la instalación.
Resulta que me inicia ubuntu perfectamente pero no aparece grub, si quiero entrar en windos tengo que volver a activar UEFI y decir que arranque primero el HDD de windows. Vamos que no es nada practico. Porfavor echarme un cable, lo agradeceré muchisimo

Imagen de Gabriel_M
+1
+1
-1

1- Los sistemas U/Efi no usan particionamiento msdos, usan particionamiento gpt, así que no existe el límite de las 4 particiones primarias.
2- Ubuntu para poder ser instalado en sistemas U/Efi, requiere de la versión 13.04 - 13.10 de 64 bits y ser instalado en particiones gpt.
3- El Grub en sistemas U/Efi es un grub especial y va instalado en la partición boot del primer disco o en una partición grub-boot nueva.

Particularmente me intesaría saber: ¿Qué programa no puede correr en Windows 7 (que se puede instalar con particionamiento msdos) y requiere de Windows 8.1?

+1
+1
-1
Imagen de Brunozq
+1
+1
-1

muchas gracias pro la aclaración!
entonces, Puedo hacer una partición primaria aunque hayan 4 particiones preinstaladas, perfecto me pondré en ello cuando pueda.

sobre tu curiosidad; quizás me he explicado mal, cuando he dicho windows 8.1, me refería a "Windows" en general, no esa versión en concreto, pero ya que he pegada lo licencia de windows 8.1 al comprar el portátil pues me quedo con esta versión. De otra forma tendría que ir pirateando o pagar otra licencia y va a ser que no.

Saludos y gracias!

+1
+1
-1
Imagen de Gabriel_M
+1
+1
-1

1- Desde Windows, libera espacio suficiente como para instalar Ubuntu.
2- Desactiva Fastboot - Security - Secure Boot Control desde la Bios.
3- Inicia con un live-dvd/usb de ubuntu 13.10 64 bits.
4- Una vez terminada la carga, abre una terminal y ejecuta en ella:

sudo su
gparted

Gparted debe mostrar un disco con tabla de particiones gpt, con:
Una partición de unos 200 megas
Otras particiones ntfs de Windows
Espacio libre (que has liberado previamente desde Windows)

Si no existe la partición de 200 megas, crea una primaria en sistema fat32, y crea además las que quieras para Ubuntu, al menos una de 2 gigas, sistema de archivos intercambio, otra de 30 sistema de archivos ext4 para / y otra de 40, 50, 100, lo que quieras para /home.

Aplica los cambios y sin cerrar, verifica en las opciones de la partición, si la has creado de 200 megas fat32, que se reconozca como Efi system.

Cierra gparted e inicia la instalación.

Al llegar a particionamiento elige personalizado/manual e instala seleccionando las particiones previamente creadas para / y /home que se formateen en ext4, las otras se toman por defecto y el Grub se instala por defecto en /dev/sda.

+1
+1
-1
Imagen de Brunozq
+1
0
-1

Ok. he conseguido instalar ubuntu en el mismo disco duro que windows 8.1 pero no me aparece windows en el grub...
No lo consigo ver tampoco en grub customizer.
:'(

+1
0
-1
Imagen de cuentos
+1
+1
-1

En primer lugar para ver que no borraste win. puedes sacar una imagen de gparted y subirla a internet y poner la liga aquí para ver.
O bien abre la terminal en ubuntu y ejecutas:
sudo fdisk -l
Igual pones aquí lo que te sale. (es mejor la imagen para ver las particiones como las tienes).

+1
+1
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de Brunozq
+1
0
-1

No he perdido windows, volver a instalar UEFI y secureboot me arrancó de windows directamente.

El comando sudo fdisk -l me dice esto:

AVISO: GPT (Tabla de partición GUID) detectado en '/dev/sda'! La utilidad fdisk no soporta GPT. Use GNU Parted.

Disco /dev/sda: 500.1 GB, 500107862016 bytes
255 cabezas, 63 sectores/pista, 60801 cilindros, 976773168 sectores en total
Unidades = sectores de 1 * 512 = 512 bytes
Tamaño de sector (lógico / físico): 512 bytes / 4096 bytes
Tamaño E/S (mínimo/óptimo): 4096 bytes / 4096 bytes
Identificador del disco: 0x6c50e9e9

Disposit. Inicio Comienzo Fin Bloques Id Sistema
/dev/sda1 1 976773167 488386583+ ee GPT
La partición 1 no se inició en el limite físico del sector

Esta es una captura de pantalla del GPARTED
http://subefotos.com/ver/?dbf96388ee4041150cfdbd4724406631o.png

muchas gracias chicos..

+1
0
-1
Imagen de Brunozq
+1
0
-1

Bueno comento también que estuve peleándome con el ordenador, reinstalando ubuntu, reinstalndo grub etc...
porque me iniciaba ubuntu directamente sin pasar por grub.
Por casualidad toqueteé un poco la bios y resulta que me apareció GRUB si cambiaba el orden de booteo
https://www.dropbox.com/s/zy29akn79uzg67l/2013-11-04%2012.37.25.jpg

Tal cual aparece en la foto, se inicia directamente ubuntu, en cambio si pongo HDD0 el primero, me arranca el GRUB pero no aparece windows en él..

Gracias de nuevo, pedir toda la información que queráis y os la daré.

+1
0
-1