nvidia-96 en ubuntu 13.10

Imagen de BloqMayus
0 puntos

Hola,

Llevo unos días intentando resolver un problema, pero no consigo aclararme con la información que encuentro por internet. Quizás alguien aquí pueda ayudarme.

Tengo un ordenador algo viejo con una GeForce 4 MX 440, al que sólo me puedo conectar por ssh. Éste tenía ubuntu 12.04 y todo funcionaba bien. Al pasar a 13.10, el programa de actualización cambió los drivers de Nvidia 96 por los de Nvidia 304 y desde entonces el pc arranca con una pantalla negra.
Buceando por /var/log pude ver que el kernel se queja de los drivers de video y dice que el paquete nvidia-304 está instalado pero que la gpu necesita nvidia-96. El problema es que el paquete nvidia-96 no se incluye en los repositorios desde ubuntu 12.10 por una incompatibilidad con el nuevo X.org.
La versión actual de estos drivers es la 96.43.23 y creo que ese problema está resuelto, pero siguen sin estar disponibles en los repositorios, lo que me hace dudar si de verdad funcionan.
No consigo instalarlos manualmente porque me devuelve este error:

ERROR: If you are using a Linux 2.4 kernel, please make sure
you either have configured kernel sources matching your
kernel or the correct set of kernel headers installed
on your system.

If you are using a Linux 2.6 kernel, please make sure
you have configured kernel sources matching your kernel
installed on your system. If you specified a separate
output directory using either the "KBUILD_OUTPUT" or
the "O" KBUILD parameter, make sure to specify this
directory with the SYSOUT environment variable or with
the equivalent nvidia-installer command line option.

Depending on where and how the kernel sources (or the
kernel headers) were installed, you may need to specify
their location with the SYSSRC environment variable or
the equivalent nvidia-installer command line option.

Ahora está installado el kernel 3.11, con headers y sources incluidos.

Por otro lado, cuando desinstalo nvidia-304, el sistema debería pasar a usar nouveau, que tendría que funcionar bien aunque sea con un menor rendimiento. Pero entonces me encuentro con un escritorio sin unity, ni bordes de ventana y una resolución muy baja. Según el sistema se está usando el controlador Gallium 0.4 on llvmpipe, que no sé muy bien qué significa.

Alguien tiene alguna idea de cómo solucionar esto?

Gracias

Imagen de Jose Luis 1320
+1
0
-1

Y dudo que puedas hacer algo al respecto por solucionar el problema, y esto no es por Ubuntu, sino por nvidia que oficialmente ya no da soporte a esas tarjetas tan viejas, al menos para su driver de Linux.

Estas usando no la tarjeta gráfica sino el procesador directamente, es por eso que el sistema te marca que estas usando Gallium con el llvmpipe.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro