Problema al instalar capturadora Conceptronic Home Video

Imagen de tartesio
0 puntos

Hola a todos.

Recientemente he adquirido una capturadora de video por USB Conceptronic Home Video Creator para poder pasar las cintas VHS familiares a digital antes de que se terminen de estropear. Leí antes de comoprarla en un par de webs que no era difícil de configurar pero, aunque en el lado oscuro funciona, no consigo hacerla funcionar en Ubuntu 12.04.

MI ordenador es un portátil Lenovo 3000 N200 y el kernel es 3.2.0-55-generic

Cuando la conecto, al hacer lsusb obtengo :

Bus 002 Device 003: ID 1d19:6108 Dexatek Technology Ltd.

En las páginas que comenté antes indicaban que, para hacerla funcionar debía ejecutar los siguientes comandos :
1- Para ejecutar los comandos desde root :
#sudo -s
2- Para descargar el módulo si estuviera cargado :
#rmmod em28xx
3- Cargar el módulo :
#modprobe em28xx card=9
#echo 1d19 6108 > /sys/bus/usb/drivers/em28xx/new_id

Una vez hecho esto al hacer :

#ls /dev/video0

me aparecen los dispositivos /dev/video0 y /dev/video1

Abro el VLC con la terminal para capturar el video y selecciono "Medio"-"Abrir dispositivo de captura" y alli me aparecen como "Nombre del dispositivo de sonido" hw:0,0 y como "Nombre del dispositivo de video" /dev/video0 y /dev/video1. Da igual el dispositivo de video que seleccione (el video0 o el video1) porque el resultado es siempre una ventana con este error :

"Su entrada no puede abrirse:
VLC es incapaz de abrir el MRL «v4l2:///dev/video0». Vea el registro para más detalles."

Y en la terminal el error se muestra como :

VLC media player 2.0.8 Twoflower (revision 2.0.8a-0-g68cf50b)
Got bus address: "unix:abstract=/tmp/dbus-3Iyxr9q9Mb,guid=d1a4bcdfac68d263d52f69f300000028"
Connected to accessibility bus at: "unix:abstract=/tmp/dbus-3Iyxr9q9Mb,guid=d1a4bcdfac68d263d52f69f300000028"
Registered DEC: true
Registered event listener change listener: true
QSpiAccessible::accessibleEvent not handled: "6" obj: QMenu(0x7f6d94270950) ""
QSpiAccessible::accessibleEvent not handled: "7" obj: QMenu(0x7f6d94270950) ""
FIXME: handle dialog start.
FIXME: handle dialog end.
[0x7f6d74001178] v4l2 demux error: VIDIOC_QBUF failed
libv4l2: error setting pixformat: Dispositivo o recurso ocupado
libv4l2: error setting pixformat: Dispositivo o recurso ocupado
libv4l2: error setting pixformat: Dispositivo o recurso ocupado
libv4l2: error setting pixformat: Dispositivo o recurso ocupado
libv4l2: error setting pixformat: Dispositivo o recurso ocupado
libv4l2: error setting pixformat: Dispositivo o recurso ocupado
libv4l2: error setting pixformat: Dispositivo o recurso ocupado
libv4l2: error setting pixformat: Dispositivo o recurso ocupado
[0x7f6d740074f8] v4l2 access error: VIDIOC_QBUF failed
[0x7f6d740074f8] v4l2 access error: device does not support mmap I/O
[0x7f6d9c000b78] main input error: open of `v4l2:///dev/video0' failed
FIXME: handle dialog start.
FIXME: handle dialog end.
QSpiAccessible::accessibleEvent not handled: "6" obj: QMenu(0x7f6d94270950) ""
QSpiAccessible::accessibleEvent not handled: "7" obj: QMenu(0x7f6d94270950) ""
QSpiAccessible::accessibleEvent not handled: "6" obj: QMenu(0x7f6d94270950) ""
QSpiAccessible::accessibleEvent not handled: "7" obj: QMenu(0x7f6d94270950) ""
QSpiAccessible::accessibleEvent not handled: "6" obj: QMenu(0x7f6d94270950) ""
QSpiAccessible::accessibleEvent not handled: "7" obj: QMenu(0x7f6d94270950) ""
FIXME: handle dialog start.
QSpiAccessible::accessibleEvent not handled: "6" obj: QMenu(0x7f6d946b0c50, name = "qt_edit_menu") "qt_edit_menu"
QSpiAccessible::accessibleEvent not handled: "7" obj: QMenu(0x7f6d946b0c50, name = "qt_edit_menu") "qt_edit_menu"
FIXME: handle dialog end.
libv4l2: error querying buffer 0: Argumento inválido
libv4l2: error querying buffer 0: Argumento inválido
libv4l2: error querying buffer 0: Argumento inválido
libv4l2: error querying buffer 0: Argumento inválido
libv4l2: error querying buffer 0: Argumento inválido
libv4l2: error querying buffer 0: Argumento inválido
libv4l2: error querying buffer 0: Argumento inválido
libv4l2: error querying buffer 0: Argumento inválido
libv4l2: error querying buffer 0: Argumento inválido
libv4l2: error querying buffer 0: Argumento inválido
libv4l2: error querying buffer 0: Argumento inválido
libv4l2: error querying buffer 0: Argumento inválido
libv4l2: error querying buffer 0: Argumento inválido
libv4l2: error querying buffer 0: Argumento inválido
libv4l2: error querying buffer 0: Argumento inválido
libv4l2: error querying buffer 0: Argumento inválido
libv4l2: error querying buffer 0: Argumento inválido
[0x7f6d840014d8] v4l2 access error: device does not support mmap I/O
libv4l2: error querying buffer 0: Argumento inválido
[0x7f6d840014d8] v4l2 access error: device does not support mmap I/O
[0x7f6d9c006478] main input error: open of `v4l2:///dev/video0' failed
FIXME: handle dialog start.
QSpiAccessible::accessibleEvent not handled: "6" obj: QMenu(0x7f6d9468ea00) ""
QSpiAccessible::accessibleEvent not handled: "7" obj: QMenu(0x7f6d9468ea00) ""

He hecho xawtv -hwscan con el siguiente resultado :
# xawtv -hwscan
This is xawtv-3.102, running on Linux/x86_64 (3.2.0-55-generic)
looking for available devices
port 73-88
type : Xvideo, image scaler
name : Intel(R) Textured Video

port 89-89
type : Xvideo, image scaler
name : Intel(R) Video Overlay

/dev/video0: OK [ -device /dev/video0 ]
type : libv4l
name : Unknown EM2800 video grabber
flags: capture

/dev/video1: OK [ -device /dev/video1 ]
type : libv4l
name : Unknown EM2800 video grabber
flags: capture

Al hacer
#sudo gstreamer-properties
y seleccionar como entrada predeterminada de video Video para Linux 2 (v4l12), como dispositivo Unknow EM2800 video grabber, teniendo como pipe line v4l12src device="/dev/video0" y darle a Prueba obtengo el siguiente error :

Video for Linux 2 (v4l2): No se pueden poner a la cola los búferes en el dispositivo «/dev/video0»

Y en le terminal el error se muestra como :

gstreamer-properties-Message: Error running pipeline 'Video for Linux 2 (v4l2)': No se pueden poner a la cola los búferes en el dispositivo «/dev/video0». [v4l2src_calls.c(84): gst_v4l2src_buffer_pool_activate (): /GstPipeline:pipeline0/GstV4l2Src:v4l2src1:
enqueing buffer 0/4 failed: No existe el archivo o el directorio]

He probado descargando el módulo y cargándolo cambiando el nº en la opción de card en modprobe desde el 0 al 9 con idénticos resultados.

¿Alguien puede echarme una mano?
Gracias de antemano por la atención.