Problema en el Centro de Software de Ubuntu

Imagen de iGalaway
0 puntos

¡Buenas! Me ha surgido un problema en Ubuntu 12.04 y me trae bastante negro, porque no tengo gran idea de cómo solucionarlo ya que soy bastante inexperto en esto (aunque catalogo este problema como algo que puede ocasionar problemas a gente que entienda inclusive algo más que yo, así que creo que este es el subforo indicado, pero en caso de no ser así pido disculpas).

Mi problema es el siguiente: Cuando intento instalar cualquier programa, o simplemente abro el Centro de Software de Ubuntu, aparece que hay un proceso activo, el cual aparece en la siguiente captura: http://imageshack.com/a/img443/6181/1lwy.png

El problema surge en que dicho proceso no puedo cancelarlo, ya que se cuelga, pero el porcentaje tampoco varía (no progresa, sino que la barra aparece 'rellena' así y así se queda) y, tras mirar por Google en foros de ayuda, los comandos y procedimientos a seguir que se proponen tampoco me lo solucionan (o que no he sabido interpretarlos).

Como información adicional, creo que esto procede al haber intentado instalar los drivers de la antena wifi por defecto de mi portátil -bcm43xx-, los cuáles conseguí activar en un principio desde la configuración de controladores adicionales pero que luego desaparecieron, de manera que he de usar una antena wifi externa.

Pues eso es todo lo que puedo decir, espero haberme explicado con suficiente claridad y que alguien pudiera ayudarme, ya que estaría bastante agradecido!

Saludos y gracias de antemano :)