Problema de instalación con un Driver y comando Make

Buenos días, tardes o noches. dependiendo de a qué hora me esten leyendo.

hace poco sugerí a mi novia instalar ubuntu en una partición aparte para que lo probara y le gustara tanto como me gusta a mi. Pero al instalar el sistema resulta que su tarjeta de red no era reconocida, esta es una broadcom y como sabemos estas tarjetas hay que instalarse manualmente.

Buscamos el driver y las instrucciones, y lo intentamos instalar por la terminal. pero a la hora de compilarlo. marcaba error (Error 1, Error 2), ok buscando lei que pudiera faltar el:

build-essential linux-headers-generic y build-dep linux.

De nuevo cerré abri la terminal escribi los comandos:

# apt-get install build-essential linux-headers-generic
# apt-get build-dep linux

Término, pero de nuevo al compilar marco los mismos errores. revise a ver si cuando se descargaron los paquetes había alguna clase de error que no hubiera visto.

Pero lo unico que vi, que llamo mi atencion fue esto:

root@ubuntu:/home/tenshi# apt-get build-dep linux
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
E: Debe poner algunos URIs fuente («source») en su sources.list

La última línea es la que llama mi atención, que siento que algo nos falta de hacer.

Ya he explotado todos los recursos que tenía, y lamentablemente mi ingles no es muy bueno por lo que me veo limitado para solo encontrar ayuda en español. si alguno tiene alguna idea de que esta saliendo mal, agradeceria que me ayudaran a salir de este problema.

P.D. Si es necesario esta es la pag. del driver y sus instrucciones de instalación están aqui
http://www.broadcom.com/support/802.11/linux_sta.php

Imagen de .doc
+1
0
-1

deberías decir, primero, qué modelo de tarjeta broadcom tienes. Porque seguramente habrá otra forma de instalarla sin meterte en líos de compilación, que dices que no dominas.

+1
0
-1
Imagen de Azura Frozenheart
+1
0
-1

Ya revise que tarjeta de red trae su pc, es una:

Broadcom 802.11 Multiband Network Adapter
Tipo de adaptador: IEEE 802.11 wireless

o mínimo es lo que marca windows.

+1
0
-1
Imagen de .doc
+1
0
-1

ya, pero eso son datos genéricos, falta el modelo ¿serie 43, por ejemplo?. Lo digo porque, por ejemplo, con
sudo apt-get install b43-fwcutter firmware-b43-installer
las de esa serie suelen funcionar

+1
0
-1