Problemas con re-instalación luego de desinstalar Wubi. (SOLUCIONADO)

Imagen de Emotion
0 puntos

Buenas, os cuento mi historia. Hace un año y medio decidí instalar Ubuntu mediante Wubi. Mi portátil venía con dos particiones por defecto, una para Windows y otra para que yo guarde ahí mis datos personales. Decidí instalar Ubuntu en la partición libre, pero la cosa no fue bien y tuve que desinstalar Wubi. He actualizado a Windows 8 hace unos meses y actualmente tengo Windows 8.1, y mi problema es que quiero re-instalar Ubuntu (con el instalador normal, ya que wubi no funciona en WIndows 8) y tenerlo conjuntamente con Windows en la misma partición (o en otra, simplemente quiero instalarlo mediante la función "Instalar Ubuntu 13.10 junto Windows 8"), y en vez de Windows 8 me sale "Instalar Ubuntu 13.10 junto Ubuntu XX.XX", pensé que sería problema de que al iniciar mi PC me aparece Windows 8.1 y Ubuntu para iniciar (obviamente da error si presiono en ubuntu), investigué por la red y logré hacer que el Boot Manager de Windows eliminara Ubuntu ya que llevaba a una ruta inexistente, pero en la instalación de Ubuntu me sigue poniendo "Instalar Ubuntu junto Ubuntu XX.XX", y necesito una solución, es verdaderamente urgente. Llevo toda la mañana intentándolo, y ahora por la tarde sigo sin ser capaz.

Imagen de Gabriel_M
+1
0
-1

Desde Windows, reduce una partición en aproximadamente unos 50 gigas.
Inicia con un live-dvd/usb de Ubuntu de 64 bits.
Terminada la carga (de la sesión de pruebas) abre una terminal.
Ejecuta en ella:

sudo su
gparted

Desde gparted:
Verifica que la primer partición esté como Efi system ó Boot grub
Crea en el espacio libre tres particiones en este orden:
Una de 2 gigas o el triple de la ram si suspendes o hibernas, sistema de archivos intercambio.
Una de unos 25 gigas, sistema de archivos ext4.
Una de unos 20 gigas, sistema de archivos ext4.
Aplica los cambios
Reinicia con el live-dvd/usb, inicia la instalación y al llegar a particionamiento elige manual, otras opciones e instala montando:
La partición de 25 gigas como /
La partición de 30 gigas como /home
La de sistema de intercambio es la swap y se monta por defecto.
El Grub va en /dev/sda.

+1
0
-1
Imagen de Emotion
+1
0
-1

Estoy medio perdido, no me sale "sistema de archivos intercambio" ni efi system o boot grub. Estoy intentando crear la nueva partición, te dejo imágenes de como me sale:
http://imgur.com/myPTVTP,xbXYWND
Posiblemente me esté saltando algo, pero a pesar de mi gran experiencia en la informática entiendo poco de Linux. Muchas gracias por la ayuda que me estás dando, y disculpa las molestias.

+1
0
-1
Imagen de Emotion
+1
0
-1

Rectifico, creo que lo de Sistema Intercambio es la partición linux-swap, ¿no? Pero sigo teniendo la duda de "Efi System" o "Boot Grub"

Un saludo

+1
0
-1
Imagen de Emotion
+1
0
-1

He "improvisado" un poco y está instalando. Siento el triple post pero no me deja editar. Cualquier staff que vea esto, que borre los mensajes anteriores. Pondré otro comentario cuando termine la instalación, lo único que deseo además de tener Ubuntu es no haberme cargado nada, que no me extrañaría.

Un saludo.

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

... correcto.
Si no se instala, inicia con el live-dvd/usb
Ejecuta lo ya posteado para cargar gparted.
Elimina las particiones (segun tu imagen)
/dev/sda6, /dev/sda7, /dev/sda8, y cualquier otra que se haya creado
aplica los cambios y crea en el espacio libre, las ya posteadas
Una de 2 gigas o el triple de la ram si suspendes o hibernas, sistema de archivos intercambio.
Una de unos 25 gigas, sistema de archivos ext4.
Una de unos 20 gigas, sistema de archivos ext4.
en ese orden
Reinicia e instala montando tal cual te indique.
/dev/sda1 es la partición system boot, que no debes tocar nunca

+1
0
-1
Imagen de Emotion
+1
0
-1

En primer lugar escribo desde el movil, omitid faltas ortograficas.

En segundo lugar, al parecer se instalo correctamente, PERO:

1. Al reiniciar me dirige directamente a Windows 8.1, no reconoce ubuntu. He probdo con easybcd o algo asi a "maniobrar" y ahora en el arranque me da la posib de ir a windows o a "neosoft linux" donde va supuestamente a un "grub.noseque" o algo asi pero da el error tipico de q el archivo ests dañado o no existe, y no se como soluciomar la cosa
2,). Dwsde Mi PC en windows se ve clarament que se ha redimensionado una particion ya q es mas pequeña, pero no aparece ninguna de las q he creado.
Disculpame por esta poca informacion, desde el movil es dificil. Ojala me ayudes pronto, ya llevo 2 dias seguidos para instalar ubuntu, me esta destrozando el cerebro.

Un saludo y gracias por ayudarme Gabriel

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Desde MsWindows, nunca podrás ver las particiones no Microsoft.
Procedimiento:
Inicia con un live-dvd/usb de Ubuntu 64 bits.
Terminada la carga de la sesión de pruebas, abre una terminal y ejecuta

sudo su
gparted

Desde gparted elimina las particiones:

/dev/sda6
 /dev/sda7
 /dev/sda8
 y cualquier otra que se haya creado con posterioridad

Aplica los cambios y en el espacio libre crea las siguientes:
Una de 2 gigas o el triple de la ram si suspendes o hibernas, sistema de archivos intercambio.
Sería una nueva /dev/sda6
Una de unos 25 gigas, sistema de archivos ext4.
Sería una nueva /dev/sda7
Una de unos 20 gigas, sistema de archivos ext4.
Sería una nueva /dev/sda8
Aplica los cambios y reinicia con el live-dvd/usb
Terminada la carga de la sesión live, inicia la instalación, al llegar a particionamiento elige manual, otras opciones y:
Monta la nueva /dev/sda7 como /, formateando.
Monta la nueva /dev/sda8 como /home, formateando.
El Grub por defecto en /dev/sda

+1
0
-1
Imagen de Emotion
+1
0
-1

Hola, cuando esté en mi pc lo hago y te cuento.
Un saludo

+1
0
-1
Imagen de Emotion
+1
0
-1

Otra cosa que no sé si influirá:
En la BIOS, me da la opción de iniciar por:

DVD etc etc
[UEFI] DVD etc etc

Ya sé un poco cómo es el tema del UEFI, pero no sé cual escoger. La diferencia es que si lo cojo sin ser UEFI antes de abrirme una interfaz gráfica me pregunta "Probar ubuntu sin instalarlo", "instalar ubuntu" y "reparar disco", o algo así (en ingles todo).

Un saludo, y gracias por responder a todas mis preguntas, que tantas no las hace ni el más novato.

Un saludo

+1
0
-1
Imagen de .doc
+1
0
-1

¿y qué problema tienes en que te pregunte si quieres probar Ubuntu antes de instalarlo, o instalarlo directamente? Es lo normal, así que elige lo que mejor te convenga. O mejor, elige primero 'Probar antes de instalar', que siempre es bueno hacerlo.

+1
0
-1
Imagen de Emotion
+1
0
-1

Me refiero a que es distinto lo que me sale si escojo "UEFI: DVD etc etc" o "DVD etc etc". Solo quiero saber si debo usar UEFI o no, o si da igual. A estas alturas quiero tener resueltas todas mis dudas, es mucho tiempo intentando instalar Ubuntu.

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Para tener arranque dual, debes utilizar Uefi sin secure boot, si este último existe.

+1
0
-1
Imagen de Emotion
+1
0
-1

Vale, probaré. Espero que todo vaya bien.

Un saludo, ya comento aquí al terminar la instalación.

+1
0
-1
Imagen de Emotion
+1
0
-1

Muchísimas gracias Gabriel, ya me funciona. He entrado por UEFI y he seguido a completo detalle lo que me has dicho. En parte creo que el problema cuando intenté instalarlo fue por culpa de pequeñísimos detalles, y el único cambio que he visto en mi PC con respecto a la anterior instalación es que ahora SÍ tengo GRUB. Estoy realmente agradecido por tu ayuda, ya pongo que está solucionado en el título, si es que puedo.

Al fin disfruto del poder de Linux en todos mis ordenadores.
Saludos.

+1
0
-1