Xruns con DreamStudio (Solucionado)

Imagen de DwLinuxero
0 puntos

Buenas, vengo a ver si alguien me puede echar un cable, estoy usando Dream Studio (algo así como ubuntu Studio pero con Unity en lugar de Xfce) pero Jackd no deja de arrojarme Xruns incluso sin hacer nada, al igual que ubuntu studio tiene pulse integrado con jack, pero la cosa no va por ahí por que he probado un script que anula pulse audio y lanza solo Jackd y pasa igual.
He probado a poner esto en /etc/security/limits.conf
@audio - rtprio 95
@audio - memlock unlimited
@audio - nice -15 / -19 (he probado con las dos cantidades)
Esto en /etc/security/limits.conf y /etc/security/limitd.d/audio.conf (¿hay que ponerlo en los dos?)
Por otro lado he probado a poner en jackd los siguientes valores
Cuadros / Periodo: 1024/512/256 y nada
Frecuencia de muestreo:48000/440000 c
Periodos/Buffer:2/3
Además estoy metido en el grupo audio y pulse/pulse-access y no hay manera
Mis tarjetas de sonido son estas
0 [Cable ]: USB-Audio - USB Midi Cable
USB Midi Cable at usb-0000:00:1a.7-2.4, full speed
1 [Mk2 ]: USB-Audio - Hercules DJ Console Mk2
Hercules Hercules DJ Console Mk2 at usb-0000:00:1d.0-1, full speed
2 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0x90700000 irq 45
La primera (la 0) es un adaptador midi/usb para mi teclado yamaha psr-gx76
Los xruns tampoco dicen nada de fallo de memoria ni nada semejante
10:45:44.622 Patchbay desactivada.
10:45:44.628 Reiniciar estadísticas.
10:45:44.635 Cambios en las conexiones ALSA.
10:45:44.649 D-BUS: Disponible (org.jackaudio.service aka jackdbus).
10:45:44.692 Cambios en las conexiones JACK.
10:45:44.723 Cliente activado.
10:46:01.289 XRUN callback (1).
10:46:03.105 XRUN callback (9 omitidos).
10:46:05.110 XRUN callback (7 omitidos).
Y el marcador se pone a 0 (18) y cuando estas tocando con el qsynth y un SF2 suena un crujir muy molesto, pero eso da sin hacer nada de nada x(
Saludos

Imagen de DwLinuxero
+1
0
-1

Resulta que al instalar un kernel rt (es algo más viejo pero no importa) funciona perfecto sin xruns ninguno xP pero al intentar instalar el driver de la broadcom me dice esto
david@david-MacBook:~/Descargas/wifi$ make
KBUILD_NOPEDANTIC=1 make -C /lib/modules/`uname -r`/build M=`pwd`
make: *** /lib/modules/3.4.29-rt41/build: No existe el archivo o el directorio. Alto.
make: *** [all] Error 2
david@david-MacBook:~/Descargas/wifi$
Y tengo el paquete del kernel rt headers instalado ¿Alguno sabe?
De momento no me corre prisa, pues el portatil esta echo polvo y no lo muebo de su sitio así que de momento no me urge la Wifi y si me compro un ordenador nuevo no creo que lleve wifi si es de sobremesa y si le compro un Wifi USB me asegurare que sea compatible con los drivers libres
Saludos

+1
0
-1
Imagen de DwLinuxero
+1
0
-1

El tema del firmware ha bastado con instalar el firmware-b43legacy-installer y boala el driver de Broadcom funcionando en el kernel RT ahora solo resta indicarle a grub que arranque por default con el y listos (no se si se podra eliminar el resto de kernels o dejarlos, aunque sería un ahorro de hd pero eso no es problema puesto que tengo 90GB para el sistema)
Saludos

+1
0
-1