punto de acceso "no asociado"

Imagen de iffans
0 puntos

Pues resulta que ahora Dapper "ve" mi tarjeta wireless (Lite-on WN5401A) desde el Network Manager; el problema viene a la hora de configurarla para acceder a Internet y conectarla al router. No hay problemas en visión de las redes, pero desde el NM no me es posible completar la conexión. He cambiado de DHCP a IP estáticas (sobremesa y portátil) y desde consola en iwconfig veo que el Punto de Acceso aparece como (not-associated), teniendo que asociarla manualmente por consola, entonces me va bien la conexión sin problemas.

¿Hay alguna solución para este tema para poder usar el NM? En caso contrario, cómo podría dejar la red configurada para después del reinicio?

Imagen de Anónimo
+1
0
-1

para que las cosas funciones despues del reinicio hay que crear un archivo en bash o sea un *.sh con tu editor preferido que contenga todo lo que quieras que arranque al iniciar(puedes crearlo en /etc/init.d) i hay que crear dentro del directorio /etc/rcS.d un enlace devil(soft link)que apunte al script o archivo que creaste se llame S"numero despues del unltimo que haya""i el nombre que quieras" , algo parecido a S91nombre.

+1
0
-1
Imagen de Anónimo
+1
0
-1

PD:al principio del script deves pones #/bin/bash o sea en la primera linia de codigo.

+1
0
-1
Imagen de iffans
+1
0
-1

Muchas gracias por tu interés; he seguido los pasos que me comentas, pero no sé qué estaré haciendo mal, porque no veo resultados. A ver:

- He creado el archivo con extension .sh en init.d, con la cabecera "/bin/bash" y la orden "sudo iwconfig ath0 ap XXXXXX", siendo X la dirección de mi router.

- Después he creado el enlace al mismo en rcS.d, pero al reiniciar no me asocia el router

¿Qué hago mal? ¿No funciona así con este tipo de órdenes? Espero que alguien me pueda ayudar. Gracias

cal_river®

+1
0
-1

cal_river®

Imagen de iffans
+1
0
-1

Me respondo a mi mismo. Resulta que el "problema" era una cuestión de los permisos de ejecución del script. Lo cambié y va perfecto :)

Muchas gracias por la ayuda!!

cal_river®

+1
0
-1

cal_river®

Imagen de bugmenot
+1
0
-1

buenos días,

podías pegar el script? es q yo no tengo mucha idea....quiero decir para los nuevos en ubuntu, nos vendría muy bien si pudieseis explicarlo un poco más detalladamente. gracias tios.

+1
0
-1
Imagen de Anónimo
+1
0
-1

la primera linia es #/bin/bash i no /bin/bash

+1
0
-1